Package Details: rust-analyzer-vscode-git r7300.c9e1aab88-2

Git Clone URL: https://aur.archlinux.org/rust-analyzer-vscode-git.git (read-only, click to copy)
Package Base: rust-analyzer-vscode-git
Description: An experimental Rust compiler front-end for IDEs (VSCode installation).
Upstream URL: https://github.com/rust-analyzer/rust-analyzer/
Keywords: rust
Licenses: MIT
Conflicts: rust-analyzer-git, rust-analyzer-vscode-git
Provides: rust-analyzer-vscode-git
Submitter: Kibouo
Maintainer: None
Last Packager: Kibouo
Votes: 0
Popularity: 0.000000
First Submitted: 2019-07-15 17:18
Last Updated: 2020-02-04 23:49

Latest Comments

marlon-sousa commented on 2021-03-14 16:10

Hello,

This package worked for me. However, its installation didn't succeed.

I got the following error:

Extension 'rust-analyzer.vsix' was successfully installed.
install: cannot stat '/home/marlon/.cargo/bin/ra_lsp_server': No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...
error making: rust-analyzer-vscode-git

Installation procedure was the following:

yay -S rust-analyzer-vscode-git

Although it aborted, everything I apparently should be getting from VS Code is working, code completion, goto definition, etc.

Due to being blind I can not confirm if syntax highlighting works.

Kibouo commented on 2020-02-04 18:04

@kralyk thanks for your comment. I updated the build section to use the command recommended by upstream (they build everything using cargo xtask now).

If there is a distinction to be made between code and codium you should try having a look at their xtask config. This also eliminates the use of code --install-extension.

kralyk commented on 2019-12-10 15:38

Hi. Thanks for the package. Running the code --install-extension from PKGBUILD can't really work. Consider doing this in an install script instead. Also, the script should probably detect whether to use code or codium.