Package Details: runrestic 0.5.8-1

Git Clone URL: https://aur.archlinux.org/runrestic.git (read-only, click to copy)
Package Base: runrestic
Description: A wrapper script for Restic backup software that inits, creates, prunes and checks backups
Upstream URL: https://github.com/andreasnuesslein/runrestic
Licenses: GPL3
Submitter: Henry78
Maintainer: fryfrog (nutz)
Last Packager: fryfrog
Votes: 4
Popularity: 0.127061
First Submitted: 2019-01-18 22:15
Last Updated: 2020-06-22 22:24

Latest Comments

1 2 3 Next › Last »

fryfrog commented on 2020-04-29 15:00

@RubenKelevra, it was fixed but w/o a pkgrel bump. See if that works now.

RubenKelevra commented on 2020-04-26 17:51

The last update breaks the installation:

Installing runrestic script to /home/ruben/.cache/yay/runrestic/pkg/runrestic/usr/bin
sed: can't read sample/systemd/runrestic.service: No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...
Error making: runrestic

nutz commented on 2020-02-05 09:37

0.5.0 uploaded. The beta seemed stable. :thumbsup:

nutz commented on 2019-12-06 12:57

Hey all,

I finally released a first beta of the overhauled runrestic.

If you're feeling adventurous I'd sure like to hear what you think of it.

https://github.com/andreasnuesslein/runrestic/tree/0.5b0

https://pypi.org/project/runrestic/0.5b0/

peippo commented on 2019-12-05 21:16

Thanks a lot!

fryfrog commented on 2019-12-05 17:10

Put in a patch to fix the setup.py and created an issue on @nutz's github. :)

peippo commented on 2019-12-05 16:50

Yes when you run it, and that's sneaky, if you have a systemd timer more or less silently fail ... :/

peippo commented on 2019-12-05 16:49

@fryfrog: the requirements.txt specifies two criteria, and both have to match: ==3.0.* and >=3.0.0. If I manually change the line in /usr/lib/python3.8/site-packages/runrestic-*egg/requires.txt (where the requirements are installed to) to jsonschema>=3.0.0, it works. Otherwise I get the same error as Junker. I didn't check, but I don't think there have been big API changes between these versions.

fryfrog commented on 2019-12-05 16:44

Ohhh, its when you try to run it. :/

fryfrog commented on 2019-12-05 16:40

The requirements.txt doesn't matter for us, right? I just use it to add deps to the package (and ignore the versioning). I would suggest an upstream issue though. But doesn't the >=3.0.0 cover 3.2.0 anyway?