Package Details: runelite 1:2.1.3-1

Git Clone URL: https://aur.archlinux.org/runelite.git (read-only, click to copy)
Package Base: runelite
Description: Open source Old School RuneScape client.
Upstream URL: https://runelite.net/
Licenses: BSD
Submitter: jcstryker
Maintainer: abex
Last Packager: abex
Votes: 28
Popularity: 0.043971
First Submitted: 2018-02-20 13:00
Last Updated: 2020-06-12 08:02

Dependencies (4)

Required by (0)

Sources (4)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

zangoku commented on 2020-02-01 10:10

Still unable to update even with the new version

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project launcher: Fatal error compiling: invalid flag: --release -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
==> ERROR: A failure occurred in build().

jachymb commented on 2020-01-30 11:07

I suffer the same problem described by Jaakkonen and ThaChillera. But it does not seem to work with any version of jdk, including adoptopenjdk. With adoptopenjdk and jdk 8 and 10, it produces a different error message:

2020-01-30 12:55:03 [Client] ERROR n.r.client.plugins.gpu.GpuPlugin - Error starting GPU plugin com.jogamp.opengl.GLException: Profile GL4bc is not available on X11GraphicsDevice[type .x11, connection :0, unitID 0, handle 0x7f58085e1720, owner true, JAWTToolkitLock[obj 0x7767cfa4, isOwner true, <142dd599, 4497e34f>[count 1, qsz 0, owner <Client>]]], but: [GLProfile[GLES1/GLES1.hw], GLProfile[GLES2/GLES2.hw], GLProfile[GL2ES1/GLES1.hw], GLProfile[GL4ES3/GL4.hw], GLProfile[GL2ES2/GL4.hw], GLProfile[GL4/GL4.hw], GLProfile[GL4/GL4.hw], GLProfile[GL3/GL4.hw], GLProfile[GL2GL3/GL4.hw]] at com.jogamp.opengl.GLProfile.get(GLProfile.java:991) at jogamp.opengl.GLContextImpl.verifyInstance(GLContextImpl.java:1471) at jogamp.opengl.GLContextImpl.setGLFunctionAvailability(GLContextImpl.java:1942) at jogamp.opengl.x11.glx.X11GLXContext.createImpl(X11GLXContext.java:395) at jogamp.opengl.GLContextImpl.makeCurrentWithinLock(GLContextImpl.java:765) at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:648) at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:586) at net.runelite.client.plugins.gpu.GpuPlugin.lambda$startUp$0(GpuPlugin.java:281) at net.runelite.client.callback.ClientThread.invoke(ClientThread.java:99) at net.runelite.client.callback.Hooks.clientMainLoop(Hooks.java:193) at eh.ta(eh.java:5814) at client.ac(client.java) at bf.hv(bf.java:373) at bf.run(bf.java:327) at java.base/java.lang.Thread.run(Thread.java:830)

Reported to runelite tracker: https://github.com/runelite/runelite/issues/10694

Jaakkonen commented on 2019-12-21 13:17

The build seems to be passing with the OpenJDK13 (extra/jdk-openjdk) but the GPU feature of Runelite seems to require AdoptOpenJDK 13, AdoptOpenJDK 11 or any JRE 8.

Crashes with following log when enabling GPU and running under JRE13, JRE12 or JRE 10: Inconsistency detected by ld.so: dl-lookup.c: 111: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

This is caused because of a improper call to jogl (Java OpenGL bindings) that for some reason works for adoptopenjdk builds and arch's jdk8 but not on arch's jdk 10, 11, 12 or 13.

abdulhakeem commented on 2019-12-21 02:06

Similar to my previous comment, I started getting compile errors again and I was able to fix it by running:

sudo archlinux-java set java-13-openjdk

and then updating Runelite. I guess it required Java 13 now?

zangoku commented on 2019-12-20 06:33

Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.UnsupportedClassVersionError: net/runelite/launcher/Launcher has been compiled by a more recent version of the Java Runtime (class file version 55.0), this version of the Java Runtime only recognizes class file versions up to 52.0
    at java.lang.ClassLoader.defineClass1(Native Method)
    at java.lang.ClassLoader.defineClass(ClassLoader.java:756)
    at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
    at java.net.URLClassLoader.defineClass(URLClassLoader.java:468)
    at java.net.URLClassLoader.access$100(URLClassLoader.java:74)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:369)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:363)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:362)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:418)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:352)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:351)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:495)

zangoku commented on 2019-09-01 17:59

Getting this error trying to update:

Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project launcher: Fatal error compiling: invalid flag: --release -> [Help 1]

ruscur commented on 2019-08-20 23:26

Launching the client with JRE 11 or 12 causes a crash in the client with

Inconsistency detected by ld.so: dl-lookup.c: 111: check_match: Assertion 'version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

Searching around just reveals more people with this issue across Java projects with no resolutions that I've found so far, will comment again if I figure something out. Every single resolution is just "Install Java 8 instead"

The AppImage on runelite.net works fine, so for anyone else with this issue, don't use the AUR packages for now

njhanley commented on 2019-08-20 20:22

RuneLite may not require Java 11 but the launcher does. This package should depend on java-environment>=11. The default Java environment must also be set accordingly but this is probably the user's responsibility.

https://github.com/runelite/launcher/commit/d3e4afd393d82bd0fdc808bccf6e6533f78be79c

asamwow commented on 2019-08-10 00:11

@ruscur had to make an account to thank you! This needs jre8!

ThaChillera commented on 2019-08-03 16:44

Trying to start runelite, both on java 11 and 12, results in a crash with the error

Inconsistency detected by ld.so: dl-lookup.c: 111: check_match: Assertion `version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

Anyone experience a similar issue?

update: running with java 10 resolved the issue

update 2: The AppImage from runelite.net doesn't have this issue