Package Details: runelite-launcher 2.0.1-1

Git Clone URL: https://aur.archlinux.org/runelite-launcher.git (read-only, click to copy)
Package Base: runelite-launcher
Description: Open source Old School RuneScape client. (Launcher with auto-update)
Upstream URL: https://github.com/runelite/launcher
Licenses: BSD
Submitter: jcstryker
Maintainer: jcstryker
Last Packager: jcstryker
Votes: 3
Popularity: 0.020971
First Submitted: 2019-02-06 03:55
Last Updated: 2019-08-18 15:23

Dependencies (5)

Required by (0)

Sources (2)

Latest Comments

zangoku commented on 2019-09-01 17:59

Getting this error trying to update:

Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.8.1:compile (default-compile) on project launcher: Fatal error compiling: invalid flag: --release -> [Help 1]

ruscur commented on 2019-08-20 23:26

Launching the client with JRE 11 or 12 causes a crash in the client with

Inconsistency detected by ld.so: dl-lookup.c: 111: check_match: Assertion 'version->filename == NULL || ! _dl_name_match_p (version->filename, map)' failed!

Searching around just reveals more people with this issue across Java projects with no resolutions that I've found so far, will comment again if I figure something out. Every single resolution is just "Install Java 8 instead"

The AppImage on runelite.net works fine, so for anyone else with this issue, don't use the AUR packages for now

njhanley commented on 2019-08-20 20:22

RuneLite may not require Java 11 but the launcher does. This package should depend on java-environment>=11. The default Java environment must also be set accordingly but this is probably the user's responsibility.

https://github.com/runelite/launcher/commit/d3e4afd393d82bd0fdc808bccf6e6533f78be79c

asamwow commented on 2019-08-10 00:11

@ruscur had to make an account to thank you! This needs jre8!

ruscur commented on 2019-07-29 01:15

Hey, why does this require java-runtime>=11? RuneLite works fine with JRE8, and using older versions is recommended on the wiki for working around some GPU bugs. I'm also experiencing a crash with JRE12 that I'm not on JRE8.

lemler3 commented on 2019-05-21 17:05

if you get an error while building then you need to set your default Java environments to Oracle Java, not OpenJDK 1. install Oracle JDK, you're on arch you should know how to do this 2. "archlinux-java status" 3. "sudo archlinux-java set" version name

https://wiki.archlinux.org/index.php/Java#Change_default_Java_environment

AtTheLoj commented on 2019-03-03 00:20

When i try installing with 'yay' I keep getting a build error.

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project launcher: Compilation failure [ERROR] No compiler is provided in this environment. Perhaps you are running on a JRE rather than a JDK?

I have java-8-openjdk installed. any ideas?

deathbeam commented on 2019-02-25 16:03

Hello, RuneLite admin here.

As improvement, you should remove bash dependency (as it is really not needed, you can just use /bin/sh, everything you do in runelite-launcher is POSIX compatible), e.g:

#!/bin/sh

exec java -Dhttps.protocols=TLSv1.2 -jar /usr/share/runelite-launcher/Launcher.jar "$@"

(you should also wrap $@ in quotes like I did there).

And this should probably be updated also for runelite and runelite-git.