Package Details: rubymine 2019.2.3-1

Git Clone URL: https://aur.archlinux.org/rubymine.git (read-only)
Package Base: rubymine
Description: Ruby and Rails IDE with the full stack of essential developer tools.
Upstream URL: https://www.jetbrains.com/ruby/
Keywords: IDE
Licenses: custom
Submitter: None
Maintainer: supermario
Last Packager: supermario
Votes: 100
Popularity: 0.631538
First Submitted: 2011-04-06 08:10
Last Updated: 2019-09-30 10:55

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 Next › Last »

Anonymous comment on 2011-05-02 20:02

@Rogof
I patched in the icon and symlink fix, it installs quite nicely now thanks.

The Java-runtime can be satisfiable by either jre+jdk or openjdk. If you have just jdk or just jre installed, when you install this it'll attempt to install openjdk.

Install a complete java env or clean up yours and try again.

Rogof commented on 2011-05-02 06:04

Good to see new contributors, keep it up.

A few things:
It needs jdk, or java-environment if you want to let the user choose between openjdk/jdk+jre.
About the icon, some packages places application icons in '/usr/share/icons/hicolor', in this case you can either symlink or copy 'RMlogo.svg' in '/usr/share/icons/hicolor/scalable/apps'.
Also, your symliks are wrong, to fix it drop the first '${pkgdir}', like this:
ln -s "/usr/lib/${_realpkgname}-${pkgver}/bin/rubymine.sh" "${pkgdir}/usr/bin/mine"

Rogof commented on 2011-05-02 06:00

Good to see new contributors, keep it up.

A few things:
It needs jdk, or java-environment if you want to let the user choose between openjdk/jdk+jre.
About the icon, some packages places application icons in '/usr/share/icons/hicolor', in this case you can either symlink or copy 'RMlogo.svg' in '/usr/share/icons/hicolor/scalable'
Also, your symliks are wrong, to fix it drop the first '${pkgdir}', like this:
ln -s "/usr/lib/${_realpkgname}-${pkgver}/bin/rubymine.sh" "${pkgdir}/usr/bin/mine"

Anonymous comment on 2011-05-01 19:30

you doing great, don't give up - and have a nice day.
thanks for speedy fixing

Anonymous comment on 2011-05-01 19:29

to be precise patch should be like this :
if [ "$CARCH" = "i686" ]; then
rm "${pkgdir}/usr/lib/${_realpkgname}/bin/fsnotifier64"
rm "${pkgdir}/usr/lib/${_realpkgname}/bin/libyjpagent64.so"
fi

Anonymous comment on 2011-05-01 19:18

Yah, I gotta fix the symlink one, still new to arch.

Anonymous comment on 2011-05-01 19:07

I bumped it with your patch, and put you in contrib (I can remove you if you'd like or change the email). Please try it and see.

Anonymous comment on 2011-05-01 19:07

other issue is the symbolic link /usr/bin/mine is pointed to /home/abs/tmp/yaourt-tmp-marco/aur-rubymine/pkg/usr/lib/RubyMine-3.1.1/bin/rubymine.sh -> means to temporary file from building process

Anonymous comment on 2011-05-01 18:58

gotcha, I see that now, I had just woken up when I read your comment. gimmie a minute.

Anonymous comment on 2011-05-01 18:57

with not patched PKGBUILD process ends with error

/usr/bin/strip:./usr/lib/RubyMine-3.1.1/bin/fsnotifier64: File format not recognized
==> ERROR: Makepkg was unable to build rubymine.

i'm building on i686 arch