Package Details: ruby-travis 1.10.0-1

Git Clone URL: https://aur.archlinux.org/ruby-travis.git (read-only, click to copy)
Package Base: ruby-travis
Description: CLI and Ruby client library for Travis CI
Upstream URL: https://github.com/travis-ci/travis.rb
Licenses: MIT
Submitter: joschi
Maintainer: DDoSolitary (lilac)
Last Packager: DDoSolitary
Votes: 18
Popularity: 0.000063
First Submitted: 2013-01-27 12:49
Last Updated: 2020-09-28 18:08

Latest Comments

1 2 3 4 5 Next › Last »

DDoSolitary commented on 2021-03-01 04:39

@bartus No, I won't fix other broken packages here. You can manually install the missing dependencies as a temporary fix.

bartus commented on 2021-02-27 09:42

@DDoSolitary: could we add ruby-faraday-net_http for the time being, at least until community/ruby-faraday gets fixed...

DDoSolitary commented on 2020-12-21 14:22

@davvore33 It seems that community/ruby-faraday, which this package depends on, is broken due to lack of a dependency. I'm going to report this problem there.

davvore33 commented on 2020-12-21 13:57

Hi, I've got a similar dep issue

travis --help                                                                                                                                                                                                      125 
Traceback (most recent call last):
        12: from /usr/bin/travis:23:in `<main>'
        11: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `activate_bin_path'
        10: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `synchronize'
         9: from /usr/lib/ruby/2.7.0/rubygems.rb:298:in `block in activate_bin_path'
         8: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
         7: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
         6: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         5: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1403:in `block in activate_dependencies'
         4: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
         3: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
         2: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         1: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1400:in `block in activate_dependencies'
/usr/lib/ruby/2.7.0/rubygems/dependency.rb:311:in `to_specs': Could not find 'ruby2_keywords' (>= 0) among 76 total gem(s) (Gem::MissingSpecError)
Checked in 'GEM_PATH=/home/matteo/.gem/ruby/2.7.0:/usr/lib/ruby/gems/2.7.0', execute `gem env` for more information

DDoSolitary commented on 2020-09-09 15:38

@replabrobin It seems that upstream restricted launchy version to < 2.5.0 for compatibility with Ruby 2.3. I just removed that restriction. Please check if it works now.

replabrobin commented on 2020-09-07 11:40

I get some kind of dependency problem after install today

$ travis --help
Traceback (most recent call last):
    8: from /bin/travis:23:in `<main>'
    7: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `activate_bin_path'
    6: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `synchronize'
    5: from /usr/lib/ruby/2.7.0/rubygems.rb:298:in `block in activate_bin_path'
    4: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
    3: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
    2: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
    1: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1400:in `block in activate_dependencies'
/usr/lib/ruby/2.7.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'launchy' (~> 2.1, < 2.5.0) - did find: [launchy-2.5.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/robin/.gem/ruby/2.7.0:/usr/lib/ruby/gems/2.7.0', execute `gem env` for more information

DDoSolitary commented on 2020-05-08 04:38

@J5lx Fixed.

DDoSolitary commented on 2020-05-08 03:13

@J5lx It seems that the missing dependency issues are actually from the ruby-gh package. I will update there.

J5lx commented on 2020-05-07 18:16

Please add ruby-activesupport and ruby-minitest to the dependencies, without those packages running travis fails. Additionally, without ruby-pry the zsh shell completion displays an error.

DDoSolitary commented on 2020-04-15 16:24

Upstream just added a commit that brings compatibility with version 1.0 of ruby-faraday and ruby-faraday-middleware: https://github.com/travis-ci/travis.rb/commit/ea21963ae5827b968cabb30eaf4b60553157adee

So I decide not to fix the dependencies here but wait a few days until they have the changed released.