Package Details: ruby-text 1.3.1-3

Git Clone URL: https://aur.archlinux.org/ruby-text.git (read-only, click to copy)
Package Base: ruby-text
Description: A collection of text algorithms: Levenshtein, Soundex, Metaphone, Double Metaphone, Porter Stemming
Upstream URL: https://github.com/threedaymonk/text
Licenses: MIT
Submitter: lilydjwg
Maintainer: dviktor
Last Packager: dviktor
Votes: 20
Popularity: 0.000682
First Submitted: 2015-04-09 10:15
Last Updated: 2020-01-02 20:49

Latest Comments

bastelfreak commented on 2020-01-01 20:26

Hi, I rebuilt the PKGBUILD to built properly from source:

_gemname='text' pkgname="ruby-${_gemname}" pkgver=1.3.1 pkgrel=3 pkgdesc='A collection of text algorithms: Levenshtein, Soundex, Metaphone, Double Metaphone, Porter Stemming' arch=('any') url='https://github.com/threedaymonk/text' license=('MIT') makedepends=('ruby-rdoc' 'ruby-test-unit' 'ruby-rake') depends=('ruby') source=("https://github.com/threedaymonk/text/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz") options=("!emptydirs") sha512sums=('eaf3ce2d5a8d5cc27b6b9c5b820ffede864466a460dd1a64a1141adf1ee78a616684b484e0548ba8eb47c492f02244ffc06058a87b3ad5c2116929e9e8fe10a8')

update the gemspec to allow newer versions of rake
remove deprecated options from the gemspec

prepare() { cd "${_gemname}-${pkgver}" sed --in-place 's|~>|>=|g' "${_gemname}.gemspec" sed --in-place '/s.rubyforge_project/d' "${_gemname}.gemspec" sed --in-place '/s.has_rdoc/d' "${_gemname}.gemspec" }

build() { cd "${_gemname}-${pkgver}" gem build "${_gemname}.gemspec" }

check() { cd "${_gemname}-${pkgver}" rake test }

package() { cd "${_gemname}-${pkgver}" local _gemdir="$(gem env gemdir)" gem install --verbose --ignore-dependencies --no-user-install --install-dir "${pkgdir}/${_gemdir}" --bindir "${pkgdir}/usr/bin" "${_gemname}-${pkgver}.gem"

install -Dm 644 COPYING.txt -t "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"

rm -rf "${pkgdir}/${_gemdir}/cache" }

vim: ts=2 sw=2 et:

Rogach commented on 2019-01-30 20:09

--no-ri and --no-rdoc options to gem install are deprecated and removed, --no-document should be used instead. Patch to PKGBUILD:

--- PKGBUILD.orig   2019-01-30 23:07:06.756193320 +0300
+++ PKGBUILD    2019-01-30 23:07:52.530236369 +0300
@@ -32,7 +32,7 @@

   # Install the gem
   install -d -m755 $_bindir $_gemdir
-  $_gem install --no-ri --no-rdoc --ignore-dependencies --no-user-install \
+  $_gem install --no-document --ignore-dependencies --no-user-install \
                 --bindir $_bindir --install-dir $_gemdir "$srcdir/$_gemname-$pkgver.gem"
 }