Package Details: ruby-kramdown-rfc2629 1.3.37-1

Git Clone URL: https://aur.archlinux.org/ruby-kramdown-rfc2629.git (read-only, click to copy)
Package Base: ruby-kramdown-rfc2629
Description: An RFC2629 (XML2RFC) generating backend for Thomas Leitner's kramdown markdown parser
Upstream URL: http://github.com/cabo/kramdown-rfc2629
Licenses: MIT
Submitter: tohojo
Maintainer: audeoudh
Last Packager: audeoudh
Votes: 1
Popularity: 0.000000
First Submitted: 2015-06-01 15:20
Last Updated: 2021-03-01 13:49

Latest Comments

audeoudh commented on 2020-11-16 10:48

Confirmed here: working with ruby-kramdown=1.17.0, same error as you with ruby-kramdown>=2.0.0. I update the dependencies, and we'll wait for upstream update. Thank you @twiggers.

twiggers commented on 2020-11-16 08:35

I'm getting the following error:

Traceback (most recent call last):
        8: from /usr/bin/kramdown-rfc2629:23:in `<main>'
        7: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `activate_bin_path'
        6: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `synchronize'
        5: from /usr/lib/ruby/2.7.0/rubygems.rb:298:in `block in activate_bin_path'
        4: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
        3: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
        2: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
        1: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1400:in `block in activate_dependencies'
/usr/lib/ruby/2.7.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'kramdown' (~> 1.17.0) - did find: [kramdown-2.3.0] (Gem::MissingSpecVersionError)

Apparently this package does not yet support Kramdown v2 https://github.com/cabo/kramdown-rfc2629/issues/73