Package Details: rts5227-dkms 1.07-8

Git Clone URL: https://aur.archlinux.org/rts5227-dkms.git (read-only, click to copy)
Package Base: rts5227-dkms
Description: Driver to support Realtek RTS5227/5229 SD Card Reader
Upstream URL: http://www.realtek.com.tw/Downloads/downloadsView.aspx?Langid=1&PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3&GetDown=false
Licenses: GPL2
Submitter: mober
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 8
Popularity: 0.070608
First Submitted: 2017-06-22 13:19
Last Updated: 2019-06-17 22:45

Dependencies (1)

Required by (0)

Sources (2)

Latest Comments

1 2 3 Next › Last »

Shara commented on 2019-11-13 01:50

5229 no more works

09:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5229 PCI Express Card Reader (rev 01)

DamirK commented on 2019-06-24 14:45

I was getting errors about missing files when updating Manjaro on Thinkpad T440.

The last commit added wrong source variable in the .SRCINFO and PKGBUILD files.

PKGBUILD file:

source=("rts5229::git+https://github.com/Zibri/Realtek-rts5229-linux-driver" <<---wrong source=("rts5229::git+https://github.com/Zibri/Realtek-rts5229-linux-driver.git" <<---repaired

.SRCINFO file:

source = rts5229::git+https://github.com/Zibri/Realtek-rts5229-linux-driver <<---wrong source = rts5229::git+https://github.com/Zibri/Realtek-rts5229-linux-driver.git <<---repaired

I changed these lines and installed the package with no problems.

paolobb4 commented on 2019-04-25 09:27

Can't install under manjaro. Builds ok but during installation I get this error message:

==> Unable to install module rts5227/1.07 for kernel 4.19.31-rt18-MANJARO: Missing kernel modules tree.

I can't find anything online about a "kernel modules tree" (Sorry, I'm very ignorant of how the kernel works).

luka.r commented on 2019-04-19 22:35

The driver compiled after uncommenting

// #define SG_END 0x02

At line 319 of rtsx_chip.h

luka.r commented on 2019-04-19 22:16

There seems to be a conflict with SG_END variable... Might have a fix here: https://gitlab.ic.unicamp.br/lkcamp/linux-staging/commit/b5d013bc09e9e76df9cdc85c2598486ba9a5b9b6

luka.r commented on 2019-03-30 14:20

Won't build on Manjaro... Here's the make.log file:

DKMS make.log for rts5227-1.07 for kernel 4.14.93-rt53-MANJARO (x86_64) Sat Mar 30 15:03:18 CET 2019 make: Entering directory '/usr/lib/modules/4.14.93-rt53-MANJARO/build' AR /var/lib/dkms/rts5227/1.07/build/built-in.o CC [M] /var/lib/dkms/rts5227/1.07/build/rtsx.o CC [M] /var/lib/dkms/rts5227/1.07/build/rtsx_chip.o CC [M] /var/lib/dkms/rts5227/1.07/build/rtsx_transport.o CC [M] /var/lib/dkms/rts5227/1.07/build/rtsx_scsi.o /var/lib/dkms/rts5227/1.07/build/rtsx_transport.c: In function ‘rtsx_add_sg_tbl’: /var/lib/dkms/rts5227/1.07/build/rtsx_transport.c:352:26: error: ‘SG_END’ undeclared (first use in this function); did you mean ‘SG_INT’? temp_opt = option & (~SG_END); ^~~~~~ SG_INT /var/lib/dkms/rts5227/1.07/build/rtsx_transport.c:352:26: note: each undeclared identifier is reported only once for each function it appears in /var/lib/dkms/rts5227/1.07/build/rtsx_transport.c: In function ‘rtsx_transfer_sglist_adma_partial’: /var/lib/dkms/rts5227/1.07/build/rtsx_transport.c:462:24: error: ‘SG_END’ undeclared (first use in this function); did you mean ‘SG_INT’? option = SG_VALID | SG_END | SG_TRANS_DATA; ^~~~~~ SG_INT /var/lib/dkms/rts5227/1.07/build/rtsx_transport.c: In function ‘rtsx_transfer_sglist_adma’: /var/lib/dkms/rts5227/1.07/build/rtsx_transport.c:620:25: error: ‘SG_END’ undeclared (first use in this function); did you mean ‘SG_INT’? option = SG_VALID | SG_END | SG_TRANS_DATA; ^~~~~~ SG_INT make[1]: [scripts/Makefile.build:326: /var/lib/dkms/rts5227/1.07/build/rtsx_transport.o] Error 1 make[1]: Waiting for unfinished jobs.... make: *** [Makefile:1535: module/var/lib/dkms/rts5227/1.07/build] Error 2 make: Leaving directory '/usr/lib/modules/4.14.93-rt53-MANJARO/build'

muhviehstarr commented on 2019-03-09 18:44

build fails at linux 5.0

try this

--- PKGBUILD +++ PKGBUILD @@ -13,13 +13,13 @@ url="http://www.realtek.com.tw/Downloads/downloadsView.aspx?Langid=1&PNid=15&PFid=25&Level=4&Conn=3&DownTypeID=3&GetDown=false" license=('GPL2') depends=('dkms') -source=("rts5229::git+https://github.com/astyonax/patched-RTS5227-5229.git" +source=("rts5229::git+https://github.com/kmahyyg/rts5229-dkms.git" 'blacklist-rts5227-dkms.conf' 'rts5227-dkms-suspend.sh' )

package(){ - sourceDir="${srcdir}/rts5229/rts5229" + sourceDir="${srcdir}/rts5229" installDir="${pkgdir}/usr/src/${_pkgbase}-${pkgver}"

# Blacklist rtsx_pci

teamgeist commented on 2019-02-27 12:39

The driver works fine for me on 4.20.12. There is just one small issue as it seems like the device is not detected (not showing in lspci) after after a warm reboot (shutdown -r). However if I shutdown -h and then restart it works.

kmahyyg commented on 2019-01-26 07:20

You may need to append

install rtsx_pci /bin/false

in your blacklist.conf.

By the way, the patch is redundant in RTS5229, I use https://github.com/kmahyyg/rts5229-dkms , It works fine on 4.20.3

rellieberman commented on 2018-06-23 22:47

Also blacklisting rtsx_pci seems to stop at least 2 other modules from loading (rtsx_pci, rtsx_pci_ms, rtsx_pci_sdmmc), these are all replaced by rts5227?