Package Details: rtorrent-pyro-git 20180605-1

Git Clone URL: https://aur.archlinux.org/rtorrent-pyro-git.git (read-only)
Package Base: rtorrent-pyro-git
Description: Ncurses BitTorrent client based on libTorrent - rTorrent-git with Pyroscope patches
Upstream URL: https://github.com/pyroscope/rtorrent-ps
Keywords: pyroscope torrent
Licenses: GPL2
Conflicts: rtorrent, rtorrent-git, rtorrent-ps
Provides: rtorrent
Submitter: skydrome
Maintainer: skydrome
Last Packager: skydrome
Votes: 27
Popularity: 0.000833
First Submitted: 2012-06-15 00:02
Last Updated: 2018-06-06 17:22

Required by (18)

Sources (15)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

skydrome commented on 2015-07-29 17:00

thanks, fixed now

dflt commented on 2015-07-27 20:08

curl: (22) The requested URL returned error: 404 Not Found
==> ERROR: Failure while downloading ps-ui_pyroscope_0.8.8.patch

skydrome commented on 2015-05-16 14:44

hey, since libsigc++ is a requirement, did you happen to somehow not have it installed? Also, try rebuilding libtorrent-pyro-git and then this again..

guiburgueira commented on 2015-05-13 20:12

I can't compile. The error:
https://gist.github.com/anonymous/cd0e3c647d607c1747f2

Please fix!

skydrome commented on 2014-08-16 03:31

fixed, it compiles and runs fine again

kmicu commented on 2014-07-21 20:54

https://github.com/pyroscope/rtorrent-ps/issues/1

kingguru commented on 2014-06-25 23:36

Building currently fails for me with the error pasted here: http://pastebin.com/cfg1SNPP

I'm guessing the relevant part is "error: ‘std::tr1’ has not been declared".

There is an interesting macro definition in the command_pyroscope.cc source (line 48):

#if (RT_HEX_VERSION >= 0x000901)
#define _cxxstd_ tr1
#else
#define _cxxstd_ std
#endif

If I change that to simply:

#define _cxxstd_ std

As well changing this (line 243):

#if RT_HEX_VERSION < 0x000904
sigc::bind(sigc::mem_fun(*(ui::ElementDownloadList*)display, &ui::ElementDownloadList::receive_command),
#else
std::tr1::bind(&ui::ElementDownloadList::receive_command, (ui::ElementDownloadList*)display,
#endif

To simply:

std::bind(&ui::ElementDownloadList::receive_command, (ui::ElementDownloadList*)display,

I am able to compile at least that source file. I did that based on a guess that tr1 support might have been removed from the recent GCC 4.9 I'm using and most of the functionality moved into the std namespace (eg. bind), which seems to be somewhat correct, although I haven't been able to confirm that (no mention of that in the GCC changelogs).

I will be happy too look further into this if it's a help, but I'm not really sure what the correct solution is. I have no idea RT_HEX_VERSION used in the PKGBUILD is for and autotools is not really something I'm strong in. :-)

skydrome commented on 2014-05-28 23:18

should be working now
use 'rtorrent -D' to allow deprecated commands until they are fixed in the PS patches

also there are some command name changes ive changed in the rtorrent.rc.sample, be sure to run a diff on it and make changes to your local copy

skydrome commented on 2014-05-28 22:58

should be working now
use 'rtorrent -D' to allow deprecated commands until they are fixed in the PS patches

nil0x42 commented on 2014-05-27 21:25

There is something wrong with the new version.
rtorrent throws a fatal error if at least one .torrent file is in the sessio directory:
rtorrent: Command "d.get_ratio" does not exist.

Note that i have not d.get_ratio in my .rtorrent.rc. If i remove all torrent files from session directory, rtorrents runs correctly, therefore, if a add a new torrent, the error is raised already.