Package Details: rto-proxy-bin 0.2.3-3

Git Clone URL: https://aur.archlinux.org/rto-proxy-bin.git (read-only)
Package Base: rto-proxy-bin
Description: RuTracker proxy app based at electron + angularjs
Upstream URL: https://rutracker.org/forum/viewtopic.php?t=5403116
Keywords: rto-proxy rutracker
Licenses: MIT
Submitter: naruto522ru
Maintainer: naruto522ru
Last Packager: naruto522ru
Votes: 3
Popularity: 0.123219
First Submitted: 2017-11-03 20:17
Last Updated: 2019-06-29 06:54

Pinned Comments

naruto522ru commented on 2019-02-19 20:19

Все-таки обновил до последней версии, но в случае проблем просьба откатится на самую первую версию как это сделать напишет при установке\обновлении.

Latest Comments

naruto522ru commented on 2019-09-08 06:29

@UshakovVasilii ну короче выяснил опять там что-то там кривые обновления или программа с новыми версиями не работает надо пакеты откатывать аж целых четыре. Ну и как бы надо еще учитывать, то что программа давно не обновляется и сам последний фикс с их стороны просто кривой, что самим пользователям пришлось исправлять. Ну короче пакеты надо откатить. harfbuzz-2.5.3-1,lib32-harfbuzz-2.5.3-1,pango-1.43.0-1,lib32-pango-1:1.43.0-2. Я бы вообще такое ПО ток в snap или flat пакетах юзать т.к там уже установка со всеми зависимостями и пакеты, которые в самой системе никак не сыграют. Правда я юзал первую версию этой проги и она запустилась, а cо второй хз. Щас протестирую. Да работает и на второй версии.

naruto522ru commented on 2019-09-08 05:22

@UshakovVasilii вот честно не знаю как исправить. Сам я ей перестал пользоваться, и пользовался ей очень давно и когда только только ею выпустили, да и программа ширновата, чтобы сами трекера работали проще какой-нибудь бесплатный прокси найти и все.

UshakovVasilii commented on 2019-08-22 10:16

Не работает

[ushakov@desktop ~]$ /opt/rto-proxy/rto-proxy
Segmentation fault (core dumped)
Aug 22 13:11:21 desktop systemd-coredump[6648]: Process 6626 (rto-proxy) of user 0 dumped core.

                                                Stack trace of thread 6626:
                                                #0  0x000000000366647e hb_face_reference_table (rto-proxy)
                                                #1  0x00007f8af85f9244 n/a (libharfbuzz.so.0)
                                                #2  0x00007f8af85f80bc hb_ot_var_get_axis_infos (libharfbuzz.so.0)
                                                #3  0x00007f8af8dfb66a n/a (libpangoft2-1.0.so.0)
                                                #4  0x00007f8afa457923 pango_font_get_hb_font (libpango-1.0.so.0)
                                                #5  0x00007f8afa4425e4 n/a (libpango-1.0.so.0)
                                                #6  0x00007f8afa442e5a pango_shape_with_flags (libpango-1.0.so.0)
                                                #7  0x00007f8afa44c3d6 n/a (libpango-1.0.so.0)
                                                #8  0x00007f8afa44d310 n/a (libpango-1.0.so.0)
                                                #9  0x00007f8afa44e7fa n/a (libpango-1.0.so.0)
                                                #10 0x00007f8afa45168c pango_layout_get_unknown_glyphs_count (libpango-1.0.so.0)
                                                #11 0x00007f8afab1478c n/a (libgtk-x11-2.0.so.0)
                                                #12 0x00007f8afab178a6 n/a (libgtk-x11-2.0.so.0)
                                                #13 0x00007f8afa2d52c0 g_type_create_instance (libgobject-2.0.so.0)
                                                #14 0x00007f8afa2f163e n/a (libgobject-2.0.so.0)
                                                #15 0x00007f8afa2f2a55 g_object_new_with_properties (libgobject-2.0.so.0)
                                                #16 0x00007f8afa2f2b52 g_object_new (libgobject-2.0.so.0)
                                                #17 0x0000000002a40de3 n/a (rto-proxy)
                                                #18 0x0000000002a405c8 n/a (rto-proxy)
                                                #19 0x0000000002a442f1 n/a (rto-proxy)
                                                #20 0x0000000002a43f1b n/a (rto-proxy)
                                                #21 0x0000000003f8aceb _ZN9brightray16BrowserMainParts18ToolkitInitializedEv (rto-proxy)
                                                #22 0x0000000002d3bc35 n/a (rto-proxy)
                                                #23 0x0000000002d8dc17 n/a (rto-proxy)
                                                #24 0x0000000002d2b1c8 n/a (rto-proxy)
                                                #25 0x0000000002a498fc n/a (rto-proxy)
                                                #26 0x0000000002a49cf0 n/a (rto-proxy)
                                                #27 0x0000000003e30488 main (rto-proxy)
                                                #28 0x00007f8af8e2aee3 __libc_start_main (libc.so.6)
                                                #29 0x00000000005a8189 _start (rto-proxy)

UPD: Если я правильно понял то можно просто прописать адреса https://rutracker.org/forum/viewtopic.php?p=75274766#75274766

naruto522ru commented on 2019-06-28 06:01

@utgarda да действительно опечатка. Исправлю как только освобожусь. Ну ты это увидешь))) Спс за отзыв. Я то самой программой не пользуюсь прокси подцепил где только возможно. В крайнем случае впн. Все сам поднял на VDS.

utgarda commented on 2019-06-04 14:25

Всё работает, в т.ч. через socks, версия пакета:
rto-proxy-bin-0.2.3-2

naruto522ru спасибо за упаковку! И у тебя опечатка в комментарии:

echo '>>> git checout a0ec866bb094'

должно быть, конечно, git checkout, а то вдруг кто не знает и не сможет исправить.

naruto522ru commented on 2019-02-19 20:19

Все-таки обновил до последней версии, но в случае проблем просьба откатится на самую первую версию как это сделать напишет при установке\обновлении.

naruto522ru commented on 2018-04-20 20:51

Обновлять не буду т.к разработчики, что-то испортили в последней версии. Она не у кого не работает. Даже ставил Ubuntu и проверял deb пакет итог-не работает.

Update will not be unnecessarily unnecessarily developers, something spoiled in the latest version. She does not work for anyone. Even set up Ubuntu and checked the deb package the total-does not work. @Google Translate