Package Details: rtl8812au-dkms-git 5.9.3.2.r8.gb95e750-1

Git Clone URL: https://aur.archlinux.org/rtl8812au-dkms-git.git (read-only, click to copy)
Package Base: rtl8812au-dkms-git
Description: rtl8812AU chipset driver with firmware v5.9.3.2
Upstream URL: https://github.com/gordboy/rtl8812au-5.9.3.2
Licenses: GPL2
Conflicts: rtl8812au
Submitter: thelinuxguy
Maintainer: zebulon (zebulon)
Last Packager: zebulon
Votes: 67
Popularity: 0.41
First Submitted: 2015-06-08 13:04
Last Updated: 2020-12-25 04:02

Dependencies (3)

Required by (0)

Sources (2)

Pinned Comments

zebulon commented on 2019-10-01 06:19

To all having an issue with this driver: please try https://aur.archlinux.org/packages/rtl88xxau-aircrack-dkms-git alternatively.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Kewl commented on 2021-03-22 08:39

The pkgver() function autobumps the pkgver, a manual bump would defeat the purpose of using VCS. A manual bump is to be used if there is a change in the packaging. In yay use the --devel option to check for updates.

zebulon commented on 2021-03-09 15:28

@eddyecho: I remember there was a guidance stating that a PKGBUILD using VCS should not be bumped if there is change to the upstream sources only. The PKGBUILD should only be changed if the building process, patches or file packaging are changed or added. Now this may have changed, I should check this. I gather it would make sense for a patch that provides compatibility with a new kernel.

eddyecho commented on 2021-03-09 11:33

@zebulon sure, but it doesn't hurt to change the pkgver so that yay automatically prompts the user to update.

zebulon commented on 2021-03-09 09:07

@eddyecho: the PKGBUILD does not need change - the latest git source will always be downloaded but you need to do a reinstall (makepkg -si or use a helper like yay).

eddyecho commented on 2021-03-08 23:13

Seems that the fix (commit d1bf6df)was made 6 days ago to the upstream url but the package maintainer still hasn't updated the PKGBUILD

finoderi commented on 2021-02-28 16:20

There is a PR aleready - https://github.com/gordboy/rtl8812au-5.9.3.2/issues/10 Waiting for gordboy to react. Although flagging this package as ofd was really retarded.

peterpan commented on 2021-02-28 08:00

==> dkms install --no-depmod -m rtl8812au -v 5.9.3.2.r8.gb95e750 -k 5.11.2-arch1-1

Error! Bad return status for module build on kernel: 5.11.2-arch1-1 (x86_64)

Consult /var/lib/dkms/rtl8812au/5.9.3.2.r8.gb95e750/build/make.log for more information.

==> Warning, `dkms install --no-depmod -m rtl8812au -v 5.9.3.2.r8.gb95e750 -k 5.11.2-arch1-1' returned 10

finoderi commented on 2021-02-26 15:05

Unfortunately the current version of the module doesn't work with 5.11 kernel. Is it possible to update the module?

gordboy commented on 2020-12-25 21:40

Good work guys.

And Merry Christmas.

zebulon commented on 2020-12-25 04:03

Pushed. Apologies for the delay. Again, big thanks to gordboy for maintaining the code and dchusovitin for the new PKGBUILD.