Package Details: rstudio-server-bin 1.4.1106-1

Git Clone URL: https://aur.archlinux.org/rstudio-server-bin.git (read-only, click to copy)
Package Base: rstudio-server-bin
Description: A integrated development environment (IDE) for R (binary version from RStudio official website)
Upstream URL: http://www.rstudio.org/
Keywords: ide r rstudio server
Licenses: GPL
Conflicts: rstudio-server, rstudio-server-git
Provides: rstudio-server=1.4.1106
Submitter: familia
Maintainer: bluerider
Last Packager: bluerider
Votes: 13
Popularity: 0.006330
First Submitted: 2015-07-30 13:06
Last Updated: 2021-03-06 23:20

Latest Comments

1 2 3 Next › Last »

arslonga commented on 2021-05-06 09:02

https://archlinux.org/packages/extra/x86_64/postgresql-libs/ should be added as dependency, on a fresh arch install rstudio-server fails to start because libpq.so.5. is missing.

bluerider commented on 2021-03-06 23:21

@vielleich Can you describe the error you are facing?

vielleicht commented on 2021-03-02 22:26

@maximtrp @bluerider this problem still remains. in my installation rserver now runs under rstudio (this user already existed (maybe from earlier installations)) by specifying the user as startup option in the service file:

/usr/bin/rserver --server-daemonize=0 --server-user=rstudio

maximtrp commented on 2020-12-19 12:27

@bluerider Thank you! I think 'rstudio-server' user should be created during package installation (specified in PKGBUILD)

SweetestRug commented on 2020-11-08 17:31

Thank you @bluerider! That solved the problem! Its strange I did not have this issue with Rstudio-server 1.2.x.

bluerider commented on 2020-11-07 04:24

@SweetestRug You'll need add the rstudio-server user. So, something like


# useradd rstudio-server

SweetestRug commented on 2020-11-07 02:05

On Manjaro when installing 1.3.1093 rstudio-server-bin does not start correctly. I get the following after trying to start Rstudio-server when running rstudio-server status.

● rstudio-server.service - RStudio Server daemon
     Loaded: loaded (/etc/systemd/system/rstudio-server.service; disabled; vendor preset: disabled)
     Active: failed (Result: exit-code) since Fri 2020-11-06 21:00:58 EST; 6s ago
    Process: 61876 ExecStart=/usr/bin/rserver --server-daemonize=0 (code=exited, status=1/FAILURE)
   Main PID: 61876 (code=exited, status=1/FAILURE)

Nov 06 21:00:58 callisto systemd[1]: Started RStudio Server daemon.
Nov 06 21:00:58 callisto rserver[61876]: ERROR system error 13 (Permission denied) [description: Failed to get user details., user-value: , description: Could not change owner for path /var/run/rstudio-server. Is>
Nov 06 21:00:58 callisto rserver[61876]: ERROR system error 13 (Permission denied) [description: Failed to get user details., user-value: , description: Could not change owner for path /var/run/rstudio-server. Is>
Nov 06 21:00:58 callisto rserver[61876]: ERROR system error 13 (Permission denied) [description: Failed to get user details., user-value: ]; OCCURRED AT rstudio::core::Error rstudio::core::system::User::Impl::pop>
Nov 06 21:00:58 callisto systemd[1]: rstudio-server.service: Main process exited, code=exited, status=1/FAILURE
Nov 06 21:00:58 callisto systemd[1]: rstudio-server.service: Failed with result 'exit-code'.

This occurs if I try to launch as a normal user or as root.

Downgrading back to 1.2.x fixes the issue. Is anyone else experiencing the same problem?

marekpetrik commented on 2020-08-29 11:50

Please update to 1.3.1073 or disown (would be happy to maintain)

fairmantium commented on 2020-06-02 20:47

+1 Please update to 1.3.959

nofacetou commented on 2020-05-28 12:18

Please update to v1.3.959, thanks a lot!