Package Details: rstudio-desktop-git 1.2.5019.r1893-1

Git Clone URL: https://aur.archlinux.org/rstudio-desktop-git.git (read-only, click to copy)
Package Base: rstudio-desktop-git
Description: A powerful and productive integrated development environment (IDE) for R programming language
Upstream URL: https://www.rstudio.com/products/rstudio/
Keywords: data IDE R science statistics
Licenses: AGPL3
Conflicts: rstudio-desktop, rstudio-desktop-bin, rstudio-desktop-preview
Provides: rstudio-desktop, rstudio-desktop-bin, rstudio-desktop-preview
Submitter: None
Maintainer: artemklevtsov (hwkiller, ConorIA, kngwyu)
Last Packager: hwkiller
Votes: 55
Popularity: 0.037891
First Submitted: 2011-03-09 06:13
Last Updated: 2019-12-02 09:39

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

jpreszler commented on 2018-01-19 20:00

Solution to my last comment (in case someone else is having this problem):

Based on rstudio's github issue #1640, I changed font (global options -> appearence) to Dejavu Sans mono and the trailing space issue is fixed.

jpreszler commented on 2018-01-19 18:25

@hwkiller and @kngwyu, Thanks, I had jdk9. After removal and installing jdk8 the package installs.

However, when I type in either the console or source panes, the visual cursor is moved by extra spaces. This is an rstudio issue, but I thought I'd check if anyone has encountered this and knows of a fix?

Thanks.

ConorIA commented on 2018-01-19 13:18

@kwkiller, the "releases" that the flagger is seeing on GitHub are based on branch v1.1-patch. The tags on master are still at 1.1.371 so the flagger must have assumed that 1.1.371 < 1.1.414 = out of date. However, branch v1.1-patch is 55 commits ahead and 776 behind master. I don't know why there is a split there, but this package is right to follow master.

hwkiller commented on 2018-01-19 08:41

Whoever flagged this out of date: It's a git package. What about it is out of date? The version is auto-generated!

To @jpreszler, which jdk do you have installed? Some folks were struggling to install the server version, and it seemed to be due to differing java versions. I recall jdk8 working fine, but not 9 or 7.

kngwyu commented on 2018-01-19 08:36

@jpreszler I couldn't reproduce, so I think this is RStudio's bag and it's already fixed. If you can encounter the error when you retry installing, please comment again. Edited: my jdk is also jdk8

jpreszler commented on 2018-01-18 16:14

I'm trying to install this package and get the following error

    [java] Jan 18, 2018 8:58:38 AM java.util.prefs.FileSystemPreferences$1 run
     [java] WARNING: java.io.IOException: Permission denied
     [java] Compiling module org.rstudio.studio.RStudio
     [java]    [ERROR] Hint: Check that your module inherits 'com.google.gwt.core.Core' either directly or indirectly (most often by inheriting module 'com.google.gwt.user.User')
     [java] Exception in thread "Sync Timer Thread" java.lang.SecurityException: Could not lock User prefs. Lock file access denied.
     [java]     at java.prefs/java.util.prefs.FileSystemPreferences.checkLockFile0ErrorCode(FileSystemPreferences.java:956)
     [java]     at java.prefs/java.util.prefs.FileSystemPreferences.lockFile(FileSystemPreferences.java:944)
     [java]     at java.prefs/java.util.prefs.FileSystemPreferences.sync(FileSystemPreferences.java:748)
     [java]     at java.prefs/java.util.prefs.FileSystemPreferences.flush(FileSystemPreferences.java:843)
     [java]     at java.prefs/java.util.prefs.FileSystemPreferences.syncWorld(FileSystemPreferences.java:483)
     [java]     at java.prefs/java.util.prefs.FileSystemPreferences.access$1200(FileSystemPreferences.java:49)
     [java]     at java.prefs/java.util.prefs.FileSystemPreferences$4$1.run(FileSystemPreferences.java:461)

BUILD FAILED
/home/preszler/source-inst/aur/rstudio-desktop-git/src/rstudio/src/gwt/build.xml:112: Java returned: 1

Total time: 15 seconds
make[2]: *** [src/gwt/CMakeFiles/gwt_build.dir/build.make:57: gwt_build] Error 1
make[1]: *** [CMakeFiles/Makefile2:107: src/gwt/CMakeFiles/gwt_build.dir/all] Error 2
make: *** [Makefile:152: all] Error 2

Any ideas on a fix?

kngwyu commented on 2018-01-14 04:57

@ConorIA Many thanks for digging the problem! And now, qt5-webengine is required instead of qt5-webkit, by this pull request https://github.com/rstudio/rstudio/pull/1720 (merged just 2 days ago). So dependencies are also need to be updated. Here is a modified PKGBUILD based on ConorIA's. https://pastebin.com/MWVZPR40

ConorIA commented on 2018-01-12 16:57

Looks like the core-dictionaries.zip needs to be downloaded just like gin and gwt. It also seems that the openssl-socketproxy.patch is no longer needed. Updated PKGBUILD: https://pastebin.com/YKw7M5yM

germelcar commented on 2018-01-09 02:19

I have updated my system (boost libs among the updated packages), and now, when I try to reinstall RStudio (rstudio-desktop-git) I got the following error: https://pastebin.com/XRukhaPZ

Is there a fix for this? Thanks in advance.

rkelly commented on 2018-01-08 23:06

@hwkiller. I've been dealing with the same issues. Great description of the problems.