Package Details: rstudio-desktop-bin 1.2.5001-1

Git Clone URL: https://aur.archlinux.org/rstudio-desktop-bin.git (read-only)
Package Base: rstudio-desktop-bin
Description: An integrated development environment (IDE) for R (binary from RStudio official repository)
Upstream URL: http://www.rstudio.org/
Licenses: GPL
Conflicts: rstudio-desktop, rstudio-desktop-git, rstudio-desktop-preview-bin
Provides: rstudio-desktop=1.2.5001
Submitter: Meow
Maintainer: Meow
Last Packager: Meow
Votes: 271
Popularity: 1.27
First Submitted: 2011-06-16 16:26
Last Updated: 2019-10-21 13:55

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 ... Next › Last »

gaelic commented on 2017-10-27 07:52

@artemklevtsov:

try to remove all of the lib* files in that directory (or move them to a bak directory). It works for me that way.

hopimet commented on 2017-10-25 14:29

Since Archlinux 32 bits is no more supported, it could be the right time to use the 64 bits deb package for Ubuntu 16 or Debian 9 (I mean this one: https://download1.rstudio.org/rstudio-xenial-1.1.383-amd64.deb) and get definitely rid of gstreamer0.10.

pat-s commented on 2017-10-25 13:04

My terminal integration is not working - I tried setting a custom path to the terminal but that did not help. Any idea what I might be missing here?

artemklevtsov commented on 2017-10-16 06:05

@gaelic after doing this I can't close an untitled not empty documents.

gaelic commented on 2017-10-10 07:04

Tip:

For anyone struggling with the qt-theme when using r-studio:

rstudio-desktop-bin is shipping bundled qt libraries, which can be safely removed if qt5 is installed anyways. Just remove:

/usr/lib(64)/rstudio/bin/libQt5* & /usr/lib(64)/rstudio/bin/qt.conf

afterwards rstudio is behaving well and is using the theme set by the user (menubar, file dialogs)

leonardof commented on 2017-10-10 00:57

RStudio 1.1 was released.

iyanmv commented on 2017-09-22 17:01

@smallmouse why would you mark this as out of date? RStudio 1.1 is still a preview and this versions installs just fine. If you have problems to install gstreamer0.10-base, try to create the package manually instead of using pacaur. gstreamer0.10-base fails to install when using pacaur (see comments in https://aur.archlinux.org/packages/gstreamer0.10-base/)

dviktor commented on 2017-08-05 22:48

what if add conditional dependencies?
this will be more handful, IMHO

coxackie commented on 2017-08-04 17:59

@hopimet:

ok, this clears up some confusion. however, with the deb version of this package, gstreamer0.10 is still a dependence. and I assume it is better to have a build for both 32 and 64 bit architectures at this point, even though arch deprecated the 32-bit one.

hopimet commented on 2017-08-04 14:36

@coxackie
The 1.0.153 version works without gstreamer0.10. However the rstudio team only published a 64 bits package (here : https://download1.rstudio.org/rstudio-xenial-1.0.153-amd64.deb) for debian 9 or Ubuntu 16. I tested it, it works fine and is no more dependent of the gstreamer0.10 package.

Other 1.0.153 packages (for Ubuntu 12.04 or Fedora) still need gstreamer0.10 but they are released both for 32 and 64 bits architectures.

@dviktor
If the PKGBUILD is modified, it won't work anymore for 32 bit architectures. If you work on a 64 bits installation, you can use this one: https://pastebin.com/n2mzRfQR