Package Details: ros-noetic-desktop-full 1.5.0-1

Git Clone URL: https://aur.archlinux.org/ros-noetic-desktop-full.git (read-only, click to copy)
Package Base: ros-noetic-desktop-full
Description: ROS - A metapackage to aggregate several packages.
Upstream URL: https://github.com/ros/metapackages
Licenses: BSD
Submitter: acxz
Maintainer: acxz
Last Packager: acxz
Votes: 4
Popularity: 0.015577
First Submitted: 2020-05-24 13:53
Last Updated: 2020-05-24 13:53

Pinned Comments

acxz commented on 2020-07-03 21:34

As of now ros-noetic-desktop-full installs properly.

acxz commented on 2020-05-24 14:00

Development is on Github: https://github.com/ros-noetic-arch Please open issues and PRs there instead of commenting.

Latest Comments

zuntik commented on 2021-05-20 16:36

Some of the dependencies of ros-noetic-desktop-full require ignition-common and ignition-common-3 which have conflicting files and as a result, ros-noetic-desktop-full fails to build.

zuntik commented on 2021-05-10 15:54

I primarily use yay but the problem is the same for trizen. These packages are failing to build:

7  aur/ros-noetic-depth-image-proc   1.12.23-3 -> 1.15.3-1
6  aur/ros-noetic-image-proc         1.14.0-2  -> 1.15.3-1
5  aur/ros-noetic-image-publisher    1.15.2-1  -> 1.15.3-1
4  aur/ros-noetic-image-rotate       1.12.23-3 -> 1.15.3-1
3  aur/ros-noetic-image-view         1.15.2-1  -> 1.15.3-1
2  aur/ros-noetic-rqt-image-view     0.4.15-1  -> 0.4.16-1
1  aur/ros-noetic-stereo-image-proc 

Edit: Solved. The problem is that after installing ros-noetic, python was upgraded to python 3.9, while it was python 3.8 during first installation. REbuilding ros-noetic-desktop-full should fix the issue.

acxz commented on 2020-10-02 12:33

@alvaro893 please post your issue on the respective github repo's issue thread so that we can better track and resolve the issue you are facing.

alvaro893 commented on 2020-10-02 08:35

Won't compile, despite installing the 'git' verions of thouse packages that @acxz mentioned. I used "yay -S ros-noetic-desktop-full". It seems to be an issue with Qt version:

CMake Error at CMakeLists.txt:25 (find_package):
Could not find a configuration file for package "Qt5" that exactly matches
requested version "5.15.0".

The following configuration files were considered but not accepted:

/usr/lib64/cmake/Qt5/Qt5Config.cmake, version: 5.15.1
/usr/lib/cmake/Qt5/Qt5Config.cmake, version: 5.15.1
/lib64/cmake/Qt5/Qt5Config.cmake, version: 5.15.1
/lib/cmake/Qt5/Qt5Config.cmake, version: 5.15.1

acxz commented on 2020-07-03 21:34

As of now ros-noetic-desktop-full installs properly.

acxz commented on 2020-05-24 14:00

Development is on Github: https://github.com/ros-noetic-arch Please open issues and PRs there instead of commenting.