Package Details: ros-melodic-rviz 1.13.5-1

Git Clone URL: https://aur.archlinux.org/ros-melodic-rviz.git (read-only)
Package Base: ros-melodic-rviz
Description: ROS - 3D visualization tool for ROS.
Upstream URL: https://wiki.ros.org/rviz
Licenses: BSD, Creative Commons
Submitter: GPereira
Maintainer: bionade24
Last Packager: bionade24
Votes: 3
Popularity: 0.055583
First Submitted: 2018-05-08 14:11
Last Updated: 2019-10-13 09:55

Dependencies (65)

Sources (1)

Pinned Comments

bionade24 commented on 2019-06-20 11:56

We moved our Development to Github: https://github.com/ros-melodic-arch
Please open issues there instead of commenting.

Latest Comments

1 2 Next › Last »

joaocandre commented on 2019-06-25 14:30

@astier that solved it, thanks.

Eyan commented on 2019-06-25 10:16

@joaocandre i try i with the same way, and get the same result. So i just modify the Makefile like @astier do it.

Anonymous comment on 2019-06-25 09:27

I fixed the QT_INSTALL_LIBS error by

  1. Compile first
  2. sed -i 's/$$\[QT_INSTALL_LIBS\]/\/usr\/lib/' src/build/devel/bin/sip/rviz_sip/Makefile
  3. makepkg -sie

joaocandre commented on 2019-06-21 21:10

@Eyan still won't compile, throws instead

/bin/sh: /usr/lib: syntax error: operand expected (error token is "/usr/lib")

shouldn't it be QT_INCLUDE_LIBS or similar?

Eyan commented on 2019-06-21 15:14

@joaocandre compiling this package failed because of $[QT_INSTALL_LIBS] = 0 PLease replace '$[QT_INSTALL_LIBS]' with ‘/usr/lib’.

joaocandre commented on 2019-06-21 15:02

Currently failing with

g++: error: 0/libQt5Core.so: No such file or directory
make[3]: *** [Makefile:38: "/home/user/.cache/yay/ros-melodic-rviz/src/build/devel/lib/python3.7/site-packages/rviz/librviz_sip".so] Error 1
make[2]: *** [src/python_bindings/sip/CMakeFiles/librviz_sip.dir/build.make:61: devel/lib/python3.7/site-packages/rviz/librviz_sip.so] Error 2
make[1]: *** [CMakeFiles/Makefile2:4935: src/python_bindings/sip/CMakeFiles/librviz_sip.dir/all] Error 2
make: *** [Makefile:130: all] Error 2

which I guess is related to @bionade24 previous comment, but I already have pyqt5-common, python-pyqt5, python-sip-pyqt5 and qt5-base installed, don't see how it would help.

Eyan commented on 2019-06-20 23:44

@bionade24 I am using plasma desktop now.

bionade24 commented on 2019-06-20 12:00

@Eyan: Your Qt installations seems to be uncomplete. Please reinstall qt5-base.

bionade24 commented on 2019-06-20 11:56

We moved our Development to Github: https://github.com/ros-melodic-arch
Please open issues there instead of commenting.

Eyan commented on 2019-06-20 08:15

g++ -Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now -Wl,-rpath,"/home/eyan/.cache/yay/ros-melodic-rviz/src/build/devel/lib" -shared -Wl,-rpath,/home/eyan/.cache/yay/ros-melodic-rviz/src/build/devel/lib -Wl,-rpath,/usr/lib -Wl,--version-script="/home/eyan/.cache/yay/ros-melodic-rviz/src/build/devel/lib/python3.7/site-packages/rviz/librviz_sip".exp -o "/home/eyan/.cache/yay/ros-melodic-rviz/src/build/devel/lib/python3.7/site-packages/rviz/librviz_sip".so siplibrviz_sipcmodule.o siplibrviz_siprvizYamlConfigReader.o siplibrviz_siprvizYamlConfigWriter.o siplibrviz_siprvizConfigMapIterator.o siplibrviz_siprvizConfig.o siplibrviz_siprvizOgreLogging.o siplibrviz_siprvizToolManager.o siplibrviz_siprvizTool.o siplibrviz_siprvizViewManager.o siplibrviz_siprvizViewController.o siplibrviz_siprvizPanelDockWidget.o siplibrviz_siprvizBoolProperty.o siplibrviz_siprvizDisplayGroup.o siplibrviz_siprvizDisplay.o siplibrviz_siprvizProperty.o siplibrviz_siprvizVisualizationManager.o siplibrviz_siprvizVisualizationFrame.o siplibrviz_siprviz.o -L/home/eyan/.cache/yay/ros-melodic-rviz/src/build/devel/lib -L/usr/lib -L/usr/X11R6/lib -lrviz -lQt5Core -lpthread -lQt5Gui $[QT_INSTALL_LIBS]/libQt5Core.so -lpthread -lQt5Widgets -lQt5PrintSupport -lXext -lX11 -lm -lpthread g++: error: 0/libQt5Core.so: No such file or directory make: *** [Makefile:38: "/home/eyan/.cache/yay/ros-melodic-rviz/src/build/devel/lib/python3.7/site-packages/rviz/librviz_sip".so] Error 1

Fail for me with this