Package Details: ros-melodic-rostime 0.6.13-2

Git Clone URL: https://aur.archlinux.org/ros-melodic-rostime.git (read-only, click to copy)
Package Base: ros-melodic-rostime
Description: ROS - Time and Duration implementations for C++ libraries, including roscpp.
Upstream URL: https://wiki.ros.org/rostime
Licenses: BSD
Submitter: GPereira
Maintainer: bionade24
Last Packager: bionade24
Votes: 3
Popularity: 0.127918
First Submitted: 2018-02-24 12:25
Last Updated: 2020-02-16 10:43

Latest Comments

bionade24 commented on 2020-07-07 18:08

@tata: Are you using my repo? Then please tell me. Otherwise, you have to rebuild your deps. I'm currently working on rebuilding my repo.

Use this to force download updated version from my repo: sudo pacman -S $(pacman -Qs ros-melodic- | awk ' NR % 2 == 1 { print substr($1, 7) } ')

tata commented on 2020-07-07 16:14

@bionade24 that seemst a rostime and some other ros package specific bug. The make depentency seems to exspect the file "/usr/lib/libconsole_bridge.so.0.4" this doesn exsist any more due to an update to version "libconsole_bridge.so.1.0" so the code semes to be change to either go to verion 1.0 nor to check for file "/usr/lib/libconsole_bridge.so" instead of "/usr/lib/libconsole_bridge.so.0.4".

bionade24 commented on 2019-02-01 15:58

@dwlsalmeida: This is not a rostime-specific bug, so it is discussed at ros-melodic-desktop-full. You can find a workaround there, too.

dwlsalmeida commented on 2019-02-01 15:54

Any news on this?

GPereira commented on 2019-01-09 18:41

This is an upstream bug

TomSev commented on 2018-12-26 14:03

There is an error in the build-process. ... -- Using Python nosetests: /usr/bin/nosetests-3.7 -- catkin 0.7.14 CMake Error at /opt/ros/melodic/share/cpp_common/cmake/cpp_commonConfig.cmake:148 (message): Project 'rostime' tried to find library '-lpthread'. The library is neither a target nor built/installed properly. Did you compile project 'cpp_common'? Did you find_package() it before the subdirectory containing its code is included?

I have to change line 119 from set(libraries "cpp_common;/usr/lib/libboost_system.so;/usr/lib/libboost_thread.so;-lpthread;/usr/lib/libboost_chrono.so;/usr/lib/libboost_date_time.so;/usr/lib/libboost_atomic.so;/usr/lib/libconsole_bridge.so.0.4")

to

set(libraries "cpp_common;/usr/lib/libboost_system.so;/usr/lib/libboost_thread.so;/usr/lib/libpthread.so;/usr/lib/libboost_chrono.so;/usr/lib/libboost_date_time.so;/usr/lib/libboost_atomic.so;/usr/lib/libconsole_bridge.so.0.4")

A similar problem is in aur build ros-melodic-roscpp-serialization

wbthomason commented on 2018-09-24 23:57

This package seems to be broken with the same error seen in most of the other ros-melodic C++ packages - the cmake invocation in build() has the wrong path.

GPereira commented on 2018-06-17 00:13

Thanks for the heads up, I am updating this now

tmmsartor commented on 2018-06-08 12:48

Not working with boost 1.67

Already patched here: https://github.com/ros/roscpp_core/pull/79

roscpp-core should be updated to version 6.11