Package Details: ros-melodic-qt-gui-cpp 0.3.14-1

Git Clone URL: https://aur.archlinux.org/ros-melodic-qt-gui-cpp.git (read-only, click to copy)
Package Base: ros-melodic-qt-gui-cpp
Description: ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates bindings for every generator available.
Upstream URL: https://wiki.ros.org/qt_gui_cpp
Licenses: BSD
Submitter: GPereira
Maintainer: bionade24
Last Packager: bionade24
Votes: 2
Popularity: 0.033259
First Submitted: 2018-05-08 14:15
Last Updated: 2019-10-13 09:42

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

headcra6 commented on 2018-11-06 18:07

Getting the same as @rezenders here... Did anyone stumble upon a solution?

Que commented on 2018-10-22 12:40

Still getting rezenders error and i don't even have pyside2 installed. I have then used pip to install pyside2 and tried to get the package again but the ros-package didn't install.

I then uninstalled the pyside2 it and didn't work after that either.

1CatchMe1 commented on 2018-10-12 19:19

pyside2 should be deleted before installing

rezenders commented on 2018-08-27 20:24

I tired removing python2-pyside2 and installing the package again, but I get the following error:

Using SHIBOKEN_LIBRARY: /usr/lib/libshiboken2.cpython-37m-x86_64-linux-gnu.so
CMake Warning at /opt/ros/melodic/share/python_qt_binding/cmake/shiboken_helper.cmake:23 (find_package):
  By not providing "FindPySide2.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "PySide2", but
  CMake did not find one.

  Could not find a package configuration file provided by "PySide2" with any
  of the following names:

    PySide2Config.cmake
    pyside2-config.cmake

  Add the installation prefix of "PySide2" to CMAKE_PREFIX_PATH or set
  "PySide2_DIR" to a directory containing one of the above files.  If
  "PySide2" provides a separate development package or SDK, be sure it has
  been installed.

GPereira commented on 2018-08-22 15:15

Hello, thanks for the feedback! I can't list it as a conflict since that would prevent users to have both packages installed, and this is "just" a compilation error, I will open a issue on the python package's page so they can fix it. If that keeps happening I will check the license to see if I can alter their code. Thanks for your feedback I really appreciate it :)

Nim65s commented on 2018-08-22 14:29

TheNiceGuy: did you read the other comments ? This error can be fixedby removing the package python2-pyside2 from your system while you build ros-melodic-qt-gui-cpp. This package will then use python2-pyqt5 instead, which is correctly listed as a dependency of ros-melodic-python-qt-binding, which is a dependency of this package.

GPereira: you could maybe update the pkgbuild to say that this package conflicts with python2-pyside2 ? but as this is only an issue at build time, it might better be a warning instead…

TheNiceGuy commented on 2018-08-22 11:50

The package won't build, here's the output https://pastebin.com/U2Su91cc.

Nim65s commented on 2018-08-14 20:17

Fixed by removing python2-pyside2. This package will automatically use pyqt, and installation works then.

Nim65s commented on 2018-08-13 22:01

This error is still here for me :/

GPereira commented on 2018-08-05 11:34

Hello! Should be fixed now, thanks! :)