Package Details: ros-melodic-chomp-motion-planner 1.0.7-1

Git Clone URL: https://aur.archlinux.org/ros-melodic-chomp-motion-planner.git (read-only, click to copy)
Package Base: ros-melodic-chomp-motion-planner
Description: ROS - chomp motion planner
Upstream URL: https://wiki.ros.org/chomp_motion_planner
Licenses: BSD
Submitter: timonegk
Maintainer: bionade24
Last Packager: bionade24
Votes: 0
Popularity: 0.000000
First Submitted: 2018-11-24 18:36
Last Updated: 2020-12-21 13:34

Latest Comments

bionade24 commented on 2020-12-08 09:15

Actually I only have python 3.9 on my system and it's looking for 3.8 so that might be the issue

But the packages this package relies on are still linked against python 3.9. Please learn how linking works. You need a clean build environement like a chroot or a container.

If you're too lazy, please just use my repo https://wiki.archlinux.org/index.php/Unofficial_user_repositories#oscloud

hacksd commented on 2020-12-08 09:03

Actually I only have python 3.9 on my system and it's looking for 3.8 so that might be the issue.

bionade24 commented on 2020-12-08 07:19

@hacksd: Your build environment isn't clean. The package builds fine our Ci: https://abs-cd.oscloud.info/cd_manager/ros-melodic-chomp-motion-planner

hacksd commented on 2020-12-08 07:11

Facing this error:

make[2]: *** No rule to make target '/usr/lib/libpython3.8.so', needed by 'devel/lib/libchomp_motion_planner.so.1.0.6'.  Stop.
make[2]: *** Waiting for unfinished jobs....
[ 83%] Building CXX object CMakeFiles/chomp_motion_planner.dir/src/chomp_planner.cpp.o
make[1]: *** [CMakeFiles/Makefile2:967: CMakeFiles/chomp_motion_planner.dir/all] Error 2
make: *** [Makefile:149: all] Error 2