Package Details: roger-router 2.2.1-1

Git Clone URL: https://aur.archlinux.org/roger-router.git (read-only, click to copy)
Package Base: roger-router
Description: Journal, Fax-Software and Call-Monitor for AVM FRITZ!Box or compatible
Upstream URL: https://www.tabos.org/
Keywords: fax fritzbox router
Licenses: GPL2
Conflicts: roger, rogerrouter
Provides: roger=2.2.1, rogerrouter=2.2.1
Submitter: phw
Maintainer: sgar
Last Packager: sgar
Votes: 18
Popularity: 1.06
First Submitted: 2013-10-21 08:49
Last Updated: 2020-10-27 19:15

Pinned Comments

phw commented on 2019-05-28 08:33

I have finally updated the package to 2.1.0. It was a bit of a PITA, since it requires older versions of gssdp and gupnp, but those are in the AUR now, too.

Fax printer setup is greatly simplified in Roger Router 2, you just need to run:

lpadmin -p Roger-Router-Fax -m drv:///sample.drv/generic.ppd -v socket://localhost:9100/ -E -o PageSize=A4

No need to fiddle with groups or spooling device anymore.

Apart from that I am actually looking for someone who is willing to co-maintain this package with me. The last months made it clear that I lack the time to do bigger updates, and the changes with Roger Router 2 are quite significant. Also upstream, understandible, is focusing on the Flatpak distribution, hence build requirements and build procedure are no longer as clearly documented. For now I think this PKGBUILD is fine, but there could be some tuning in regards to what dependencies are really needed on runtime.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

tsuflux commented on 2016-11-29 22:21

I have the same issue as tuxflo: gnome-keyring (or any other service implementing org.freedesktop.secrets such as ksecretservice) is a hard dependency for Roger Router. libsecret cannot store passwords on its own.

phw commented on 2016-10-27 14:36

@tm-x: Thanks for informing me, fixed

tm-x commented on 2016-10-27 11:47

The build fails with error:

cp: cannot stat '../../address-book.svg': No such file or directory

Any reason for not using the $srcdir PKGBUILD variable? Taken from wiki:
"srcdir: This points to the directory where makepkg extracts or symlinks all files in the source array."

cp $srcdir/address-book.svg roger/images/

Fixed it for me.

phw commented on 2016-10-26 11:18

@seidler2547: Thanks for the info, has been fixed in the PKGBUILD. Looks like this happened due to the recent Gtk update, the icon was missing. See also https://www.tabos.org/topic/compile-error-2/

seidler2547 commented on 2016-10-24 19:17

Cannot build. Error is:

make[4]: *** No rule to make target 'images/address-book.svg', needed by 'roger_gresource.h'. Stop.
make[4]: *** Waiting for unfinished jobs....

What can I do?

mozon commented on 2016-01-05 16:14

Well done!

Works fine for me.

Thx @phw

phw commented on 2016-01-05 11:02

Thanks for the info, I have added gupnp to the dependencies.

The -with-cups=no option should not have blocked the build, it was intentionally there to avoid the unfinished cups plugin which broke the fax printer. Fortunately upstream has removed that plugin in 1.8.12 until it gets stable, so I have removed that option.

I also made a more drastic change: I removed all dependencies required for optional plugins from makedepends. That makes it easier to build the package e.g. if you don't have evolution installed and don't need that plugin. However it makes it a bit harder to produce a binary package from that PKGBUILD that includes all plugins, as you have to make sure to install all optional dependencies *before* building the package.

mozon commented on 2016-01-05 09:48

I have the same issues as SammyHP.

SammysHP commented on 2016-01-04 18:22

configure: WARNING: unrecognized options: --with-cups

The options in the PKGBUILD should be cleaned up. Especially for --with-cups=no there is a comment that the CUPS backend does not work yet.

SammysHP commented on 2016-01-04 18:20

configure: error: Package requirements (glib-2.0 >= 2.40 gio-2.0 >= 2.40 speex >= 1.0 speexdsp >= 1.0 sndfile >= 1.0.0 libxml-2.0 gupnp-1.0 gssdp-1.0) were not met:

No package 'gupnp-1.0' found
No package 'gssdp-1.0' found



Package "gupnp" is missing as a dependency.