Package Details: rocketchat-desktop 3.0.7-1

Git Clone URL: https://aur.archlinux.org/rocketchat-desktop.git (read-only, click to copy)
Package Base: rocketchat-desktop
Description: Rocket.Chat Native Cross-Platform Desktop Application via Electron.
Upstream URL: https://github.com/RocketChat/Rocket.Chat.Electron
Keywords: chat client electron rocket rocketchat
Licenses: MIT
Conflicts: rocketchat-client-bin
Submitter: sum01
Maintainer: matthias.lisin
Last Packager: matthias.lisin
Votes: 17
Popularity: 0.56
First Submitted: 2017-10-23 16:52
Last Updated: 2020-11-09 20:55

Latest Comments

« First ‹ Previous ... 5 6 7 8 9 10

mikky commented on 2018-01-29 12:12

EDIT: seems like upstream source was changed without changing version. The problem, however, remains: https://bpaste.net/show/9d9f7b8f2f47

Even worse I'm afraid @sum01. What do you think was the problem? As the only thing changed in v2 PKGBUILD is pkgrelease number and SHA, everything else is the same, including src file and prepare() and build()...

https://bpaste.net/show/34c8cacd8ffd

sum01 commented on 2018-01-27 18:24

Try again with 2.10.2-2? @mikky

mikky commented on 2018-01-27 08:27

Build failed: https://bpaste.net/show/43864812be21

I have absolutely no idea what's wrong :(

sum01 commented on 2017-11-09 22:22

I can't replicate the issue, and I'm not even sure why it's occurring in the the first place. The repo has a yarn.lock, so it shouldn't fail finding it.

For now, you can run
> makepkg -s --nocheck
to skip the check().

If anyone has any idea why this might happen, I'm open to suggestions.

mikky commented on 2017-11-09 15:00

Check still fails:

https://pastebin.com/qaqVyf9Q

sum01 commented on 2017-11-04 18:10

Hmm. The project doesn't directly depend on gpy (which requires python2), so I guess it's a dependency of a dependency. But anyways, I added it to the makedepends, so hopefully it fixes that.

Not sure why it couldn't find an integrity file, but it might be a by-product of the first error.

SilverRainZ commented on 2017-11-04 16:07

Build failed with extra-x86_64-build:

- Missing python2 makedepends: required by node-gpy
- check() failed:

```
yarn check v1.3.2
error Couldn't find an integrity file
error Found 1 errors.
info Visit https://yarnpkg.com/en/docs/cli/check for documentation about this command.
```

sum01 commented on 2017-10-25 17:02

If you're wondering about the difference between this and rocketchat-client-bin, this builds from the source code.