Package Details: rocketchat-desktop 3.0.7-1

Git Clone URL: https://aur.archlinux.org/rocketchat-desktop.git (read-only, click to copy)
Package Base: rocketchat-desktop
Description: Rocket.Chat Native Cross-Platform Desktop Application via Electron.
Upstream URL: https://github.com/RocketChat/Rocket.Chat.Electron
Keywords: chat client electron rocket rocketchat
Licenses: MIT
Conflicts: rocketchat-client-bin
Submitter: sum01
Maintainer: matthias.lisin
Last Packager: matthias.lisin
Votes: 17
Popularity: 0.56
First Submitted: 2017-10-23 16:52
Last Updated: 2020-11-09 20:55

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

r0b0t commented on 2019-11-25 12:23

@matthias.lisin I wasn't using anything special (not even nvm to change the nodejs versions) , I simply installed nodejs from the community channel with pacman and the current version is 13.2.0-1 Even if I set nodejs to 12 with nvm it wont work. The only solution seems to be installing nodejs-lts-erbium and removing the default nodejs

matthias.lisin commented on 2019-11-25 11:49

@r0b0t This currently doesn't work with nodejs>=13 due to node-spellchecker which is pretty much unmaintained.

I'm not sure why your build errors though. There are nodejs packages for version 8, 10 and 12. Are you running makepkg or using AUR helper?

Edit: I will replace the current nodejs version pinning with nodejs-lts-erbium as soon as I get some feedback on this issue: https://bugs.archlinux.org/task/64641

r0b0t commented on 2019-11-25 11:01

warning: nodejs-13.2.0-1 is up to date -- skipping there is nothing to do error: unable to satisfy dependency 'nodejs<13' required by rocketchat-desktop

Can we have this work with nodejs > 13?

My system is up to date as I'm writing.

matthias.lisin commented on 2019-11-01 19:26

@Polly I can not reproduce this. Build works fine without eslint. The warning comes from upstream and doesn't affect the application at all.

Polly commented on 2019-11-01 11:51

On my machine (up to date on 2019/11/1) the build got stuck while rebuilding packages. Installing eslint solved the issue. Also there is the warning:

warning " > @rocket.chat/eslint-config@0.4.0" has incorrect peer dependency "eslint@^4.19.1 || ^5.16.0".

Is there a missing dependency?

matthias.lisin commented on 2019-10-29 22:47

Just pushed an update to fix build with electron 7.

Finally got rid of the python2 dependency. node-gyp works fine with python now.

Had to pin nodejs version to 12 because it doesn't build with 13 (which is in community-testing right now)

matthias.lisin commented on 2019-08-10 10:26

Updated to 2.15.5. Please excuse the delay, there were some issues upstream.

To build this nodejs<12 is now required. Version 12 is in community-testing right now and breaks the build due to a dependency. I have created an issue upstream https://github.com/anaisbetts/node-system-idle-time/issues/17

Hopefully this will be resolved soon. If it is not the case, I'll recreate the issue in the rocketchat repository.

Turtizzle commented on 2019-02-25 09:06

The notification timeout works fine in the new version... I guess it's fixed by ignoring the issue. :)

matthias.lisin commented on 2019-02-24 19:01

Hello my dudes. So there we go 2.15.0 is out. The notifications timeout patch is gone and hopefully all the related issues as well.

Now depends on electron (3) instead of electron2. This is good, but might not quiet perfect since upstream actually wants electron 4(!).

As you can see in the PKGBUILD, I downgraded to electron@^3.1.4, because I noticed at least one thing that was broken. Looks like 4 is not fully backwardscompatible.

matthias.lisin commented on 2019-02-23 20:20

@Turtizzle

I didn't know what to answer or what to do. But today I saw this merged pull request arrive:

https://github.com/RocketChat/Rocket.Chat.Electron/pull/1101

This might actually solve all the notification issues. Let's hope it does.