Package Details: robocode 1.9.3.6-1

Git Clone URL: https://aur.archlinux.org/robocode.git (read-only)
Package Base: robocode
Description: Programming game, where the goal is to develop a robot battle tank to battle against other tanks in Java or .NET. The robot battles are running in real-time and on-screen.
Upstream URL: http://robocode.sourceforge.net
Licenses: EPL
Submitter: divineant
Maintainer: HER0_01
Last Packager: HER0_01
Votes: 16
Popularity: 0.000068
First Submitted: 2011-09-28 11:44
Last Updated: 2019-05-11 19:33

Latest Comments

1 2 Next › Last »

ixrk commented on 2019-06-03 18:23

It turns out makepkg fails because I have BUILDDIR set in /etc/makepkg.conf. I don't have this problem with other packages. makepkg.conf(5) man page says it has something to do with $startdir:

$ man makepkg.conf | grep -A4 BUILDDIR
BUILDDIR="/path/to/directory"
    If this value is not set, packages will, by default, be built in subdirectories of the
    directory that makepkg is called from. This option allows setting the build location to
    another directory. Incorrect use of $startdir in a PKGBUILD may cause building with this
    option to fail.

HER0_01 commented on 2019-06-02 18:16

ixrk, I am not able to reproduce this. Are you using makepkg? Have you tried deleting the folders and building again?

ixrk commented on 2019-05-31 12:50

:/

==> Starting package()... find: ‘/home/ixrk/dev/pkg/robocode/src’: No such file or directory ==> ERROR: A failure occurred in package(). Aborting...

gandalf3 commented on 2016-11-10 02:29

I get an error during extraction:

-> Extracting robocode-1.9.2.5-setup.jar with bsdtar
libs/: Can't replace existing directory with non-directory
robots/: Can't replace existing directory with non-directory
bsdtar: Error exit delayed from previous errors.
==> ERROR: Failed to extract robocode-1.9.2.5-setup.jar

Gondlar commented on 2014-07-23 12:24

So heres a patch to build the new Version:

3c3
< pkgver=1.8.1.0
---
> pkgver=1.9.2.1
11c11
< md5sums=(25571cb10b37c54443006f44a8fdc62e 8a556209b3ffb39839f28f30479a8c8d)
---
> md5sums=(a541527914ac1fa37d6c2aaeccf19727 8a556209b3ffb39839f28f30479a8c8d)

kraxor commented on 2014-04-30 09:52

1.9.2.0 is out

Not that it matters, as the package is flagged out-of-date since 2013-08-13.

Requesting orphaning.

Armadillux commented on 2014-03-24 10:26

1.9.1.0 is out

whitebrice commented on 2014-03-18 22:20

1.9.0.0 is out

lesto commented on 2013-09-17 11:35

1.8.2.0 is out

Willrandship commented on 2013-02-15 18:00

The previous comment's problem has been fixed. I'm not surprised seeing as it has been a few months. I just wanted it documented.