Package Details: ripme-git latest-3

Git Clone URL: https://aur.archlinux.org/ripme-git.git (read-only, click to copy)
Package Base: ripme-git
Description: Downloads albums in bulk
Upstream URL: https://github.com/RipMeApp/ripme
Licenses: MIT
Conflicts: ripme
Provides: ripme
Submitter: eso
Maintainer: neeshy
Last Packager: neeshy
Votes: 5
Popularity: 0.000000
First Submitted: 2015-12-23 15:47
Last Updated: 2020-04-02 18:00

Latest Comments

1 2 Next › Last »

qs9rx commented on 2020-06-19 07:44

There is some initial config problem. If you run it, the GUI will be broken (accessible with a single click on the icon in systray). The terminal output includes the NPE like deadpyxel said.

If you however run https://github.com/RipMeApp/ripme/releases/download/1.7.92/ripme.jar once, it will work.

edit: Trying to rip anything fails though for me.

deadpyxel commented on 2020-03-06 22:51

Is there anything we can do to help make this package work? I don't really understand why so many people(like me) don't get the interface

deadpyxel commented on 2020-02-23 23:38

Did a clean install and also can't get a GUI.

The output when ran in shell is as follows

Loaded file:/usr/share/java/ripme-git-1.7.91.r2.gcd16aaca.jar!/rip.properties
Setting locale to default
Loaded log4j.properties
Initialized ripme v1.7.91

No errors spilled or warnings during install. I installed using yay.

When run directly (with java -jar /usr/share/java/ripme-git-1.7.91.r0.g4248a0fd.jar), this is the output:

Getting key select.save.dir in  value Select Save Directory
Getting key loading.history.from.configuration in  value Loading history from configuration
Loading history from configuration
Exception in thread "main" java.lang.NullPointerException
        at com.rarchives.ripme.ui.MainWindow.loadHistory(MainWindow.java:1186)
        at com.rarchives.ripme.ui.MainWindow.<init>(MainWindow.java:186)
        at com.rarchives.ripme.App.main(App.java:89)

My System information would be:

  • OS: Archlinux x64
  • kernel: 5.5.5-arch1-1
  • java --version output: openjdk 13.0.2 2020-01-14

Let me know if there's any debugging information that can help.

Anonymous comment on 2020-01-20 15:22

Gui does not show with jdk8

Loaded file:/usr/share/java/ripme-git-1.7.91.r0.g4248a0fd.jar!/rip.properties
Setting locale to default
Loaded log4j.properties
Initialized ripme v1.7.91

malathion commented on 2019-12-31 19:34

Note that I still don't get the GUI when I run it. I think this package needs some more work to be serviceable.

malathion commented on 2019-12-31 03:34

When building I am met with an error:

$ makepkg -s
fatal: unable to access 'https://github.com:ripmeapp/ripme/': URL using bad/illegal format or missing URL

I was able to build by reworking the source url:

diff --git i/PKGBUILD w/PKGBUILD
index 9c3bd88..7219fe8 100644
--- i/PKGBUILD
+++ w/PKGBUILD
@@ -10,7 +10,7 @@ url="https://github.com/RipMeApp/ripme.git"
 license=('MIT')
 depends=('java-runtime')
 makedepends=('git' 'maven')
-source=('ripme::git+http://github.com/ripmeapp/ripme#branch=master')
+source=("$pkgname"::"git://github.com/ripmeapp/ripme#branch=master")
 provides=('ripme')
 conflicts=('ripme' 'ripme-headless-git')
 md5sums=('SKIP')

MrTimscampi commented on 2019-12-08 03:06

2019/12/08: Made this package require the full JRE instead of the headless one. Headless version can be found in ripme-headless-git.

Tio commented on 2019-11-14 23:27

@MrTimscampi Ok thank you very much. Hope it gets updated to work properly ;) cheers

MrTimscampi commented on 2019-11-14 14:07

@Tio: It does. When I took on the package, it already had the depend set to the headless version and, as I use it on a headless machine, I had never even noticed.

The issue is that the headless package doesn't seem to provide the full package, so it means a headless machine would pull the full JRE with GTK, Wayland and all.

I'll need to see what can be done about that in the future.

Tio commented on 2019-11-14 00:39

This doesn't have a User Interface?