Package Details: revelation 0.5.4-1

Git Clone URL: https://aur.archlinux.org/revelation.git (read-only, click to copy)
Package Base: revelation
Description: A password manager for the GNOME desktop
Upstream URL: http://revelation.olasagasti.info/
Licenses: GPL
Submitter: ilpianista
Maintainer: lisu_ml
Last Packager: lisu_ml
Votes: 43
Popularity: 0.000000
First Submitted: 2010-11-13 15:25
Last Updated: 2020-10-05 16:00

Latest Comments

1 2 3 4 Next › Last »

lisu_ml commented on 2020-10-05 16:00

Ah, fixed, thanks again.

yochananmarqos commented on 2020-10-05 15:15

gobject-introspection is only required to build.

lisu_ml commented on 2020-09-21 08:05

Fixed, thanks.

yochananmarqos commented on 2020-09-20 14:22

@lisu_ml: FYI, pkg-config (provided by pkgconf) is part of the base-devel group. Those dependencies are expected to be installed and do not need to be declared in makedepends(). See makepkg: Usage

lisu_ml commented on 2020-09-20 11:44

Thanks @yochananmarqos. The PKGBUILD has been updated!

yochananmarqos commented on 2020-09-14 18:36

Updated PKGBUILD for 0.5.3

lisu_ml commented on 2018-09-02 20:40

I have adopted the package and applied the patch submitted by @sviro as I wanted to have the package fixed, but if anyone is willing to keep the package maintained, let me know and I disown.

tchebb commented on 2018-09-02 16:08

I no longer use Revelation or have interest in maintaining this package, so I've orphaned it.

sviro commented on 2018-09-01 11:15

Hi, build is broken because of removed dependency pycrypto. This dependency needs to be changed to 'python2-crypto'.

Because of the dependency change, there needs to be done some code changes as well.

I have posted these changes as crypto.patch at https://pastebin.com/JKz3LzPJ

sha256sum of that patch should be 6ed410e83810a6cb44ac0e4828ba686fe8ee1a9a7743d7240dcdc038ad15927c

tchebb commented on 2017-02-06 21:58

@snark.real: Thanks! I've fixed that specific issue, so it should build again. On closer inspection, though, it looks like upstream's dependency list is quite out-of-date, so I wouldn't be surprised if there were more dependency issues lurking in this package. namcap is also complaining about some python2/python3 issues. If you or anyone else wants to take over maintenance of this package, just let me know and I'll orphan it; otherwise, I'll fix issues as they crop up, but I don't really have the time to dig through the source and fix issues proactively right now.