Package Details: retroshare-git v0.6.6.RC1.r0.g4199b1a02-1

Git Clone URL: https://aur.archlinux.org/retroshare-git.git (read-only, click to copy)
Package Base: retroshare-git
Description: Serverless encrypted instant messenger with filesharing, chatgroups, e-mail.
Upstream URL: http://retroshare.cc/
Keywords: i2p retroshare tor
Licenses: GPL, LGPL
Conflicts: retroshare
Provides: retroshare
Submitter: sehraf
Maintainer: sehraf
Last Packager: sehraf
Votes: 19
Popularity: 0.000003
First Submitted: 2015-08-04 08:22
Last Updated: 2020-10-15 21:27

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Anonymous comment on 2013-03-01 01:58

Updated:
- fixed retroshare-nogui build again…
- added missing dependencies curl and libxslt for FeedReader, protobuf for retroshare-nogui (found with namcap.)

Anonymous comment on 2013-02-28 21:39

Updated:
- building retroshare-nogui works
- should work whether qt means qt4 or qt5
- added installation of FeedReader plugin
- separate build options for the 3 plugins so you can choose the ones you want
- automatic speex and libssh dependencies if you enable VOIP or nogui

test0 commented on 2013-02-28 21:07

I found my problem. I fucked up my svn dir. Now I removed that folder run your script with my line... and tadaa it works

Thanks for your work.

test0 commented on 2013-02-28 20:21

thanks for the info but I dont have enable [testing] and qt is running at 4.8.4-3.

I will try the replacements.

Anonymous comment on 2013-02-28 18:48

r6163 builds fine here; I guess you have [testing] enabled and are using qt5. I’ll update the package once qt5 leaves testing. I think the only things needed are:
- replace qt with qt4 in the dependencies
- replace qmake with qmake4 in build()

Thanks for the feedreader install line.

test0 commented on 2013-02-28 12:17

lastest version stops with an error at the open PGP point (wrong qmake syntax?)

But here the code for the "new" plugin feedreader

install -D -m 755 \
"plugins/FeedReader/libFeedReader.so" \
"${pkgdir}/usr/lib/retroshare/extensions/libFeedReader.so"

Anonymous comment on 2012-12-10 23:52

Updated for new SVN URL.

Anonymous comment on 2012-11-30 00:35

Enabled VOIP and LinksCloud plugins by default. The VOIP plugin requires speex, and can be used from the private chat windows.

You’ll have to edit the PKGBUILD if you don’t want the plugins (set _build_plugins to false and remove speex from the dependencies.)

Anonymous comment on 2012-10-12 23:06

Updated for the new location of the qss directory. Skins are now in /usr/share/RetroShare/qss. There is no reason to install RS to /opt anymore.

Anonymous comment on 2012-09-17 20:37

Updated to remove libs patch, no longer needed.