Package Details: retdec-git v4.0.r251.g31ffc7c8-1

Git Clone URL: https://aur.archlinux.org/retdec-git.git (read-only, click to copy)
Package Base: retdec-git
Description: A retargetable machine-code decompiler based on LLVM
Upstream URL: https://retdec.com/
Licenses: MIT
Conflicts: retdec
Provides: retdec
Submitter: untitled
Maintainer: io12
Last Packager: io12
Votes: 4
Popularity: 0.000019
First Submitted: 2017-12-13 12:23
Last Updated: 2020-11-18 05:26

Latest Comments

1 2 Next › Last »

io12 commented on 2020-11-18 05:28

kyechou: I just pushed your changes. Thanks! And sorry about not getting to this earlier.

kyechou commented on 2020-11-08 18:32

Hi @blevy, the dependencies listed seem to be outdated (bc, wget, and perl don't seem to be used; upx and graphviz are optional; bison and flex are in base-devel group so they don't need to be in makedepends 1; openssl is now needed as a dependency). Also, retdec's git repo doesn't seem to have submodules anymore, so the prepare function isn't needed, but MIT license still needs to be installed individually 2. Here's an updated PKGBUILD 3 with the changes. Please consider pulling from it or update the PKGBUILD somehow. Thanks! :)

untitled commented on 2018-11-08 16:55

Python dep added.

PedroHLC commented on 2018-11-08 15:40

Seems to require python as dependency, I built from clean chroot

untitled commented on 2018-04-20 20:09

please add flex and bison to makedepends.

@bitwave: done

bitwave commented on 2018-04-19 09:26

please add flex and bison to makedepends.

untitled commented on 2018-02-12 12:53

Hi Hudd!

Not sure what may be the cause of your error message. Try reporting it upstream if you haven't already https://github.com/avast-tl/retdec/issues

Cheers! /u

Hudd commented on 2018-02-02 18:42

I have errors during build:

[ 1%] Performing configure step for 'llvm-project'

-- Target triple: x86_64-unknown-linux-gnu

-- Native target architecture is X86

...

-- Targeting X86

CMake Error at cmake/modules/LLVM-Config.cmake:126 (message):

Target X86 is not in the set of libraries.

untitled commented on 2017-12-26 13:48

Hi c-mauderer,

Thanks for the comment on the name conflict! And good that you decided to report it upstream (https://github.com/avast-tl/retdec/issues/70).

As you noted, the name is used in scripts throughout, so I think it is better to wait for an upstream fix to this. The current recommendation is to install retdec locally, rather than system wide.

I hope that retdec will start using the LLVM system libraries in the future, rather than their own, as that would likely reduce the compile time down from hours to minutes. In doing so, it would be easier to maintain local installations of retdec.

So, for the time being, the is and will remain a name conflict for the fileinfo tool. The upstream issue tracks the resolution of this.

Cheers /u

c-mauderer commented on 2017-12-25 19:05

I get a file conflict for /usr/bin/fileinfo. That one is provided by communit/leptonica (which is a prerequisite for community/tesseract. It seems that they are different programs. Maybe it would be possible to install the one from retdec with a different name? Something like retdecfileinfo?

I didn't take a detailed look at the retdec. Is that a tool from retdec or is it build as some pre-requisite? In the first case, I would report that problem to the retdec github repo.

EDIT: Just noted: That tool seems to be used through some scripts. I'll report it upstream instead.

EDIT2: I opened a ticket at retdec: https://github.com/avast-tl/retdec/issues/70. They currently suggest to use a prefix for the installation and they may want to change the names in the future. So most likely that naming conflict will be there for some time.