Package Details: resvg 0.11.0-2

Git Clone URL: https://aur.archlinux.org/resvg.git (read-only, click to copy)
Package Base: resvg
Description: SVG rendering library and CLI
Upstream URL: https://github.com/RazrFalcon/resvg
Licenses: MPL2
Submitter: flying-sheep
Maintainer: flying-sheep
Last Packager: flying-sheep
Votes: 15
Popularity: 0.98
First Submitted: 2018-05-24 11:10
Last Updated: 2020-10-19 10:05

Latest Comments

1 2 Next › Last »

nyanpasu64 commented on 2020-11-03 13:18

I can't get it to build:

The following warnings were emitted during compilation:

warning: clang-10: error: unknown argument: '-fvar-tracking-assignments'
warning: clang-10: error: unknown argument: '-fvar-tracking-assignments'
warning: clang-10: error: unknown argument: '-fvar-tracking-assignments'
warning: clang-10: error: unknown argument: '-fvar-tracking-assignments'
warning: clang-10: error: unknown argument: '-fvar-tracking-assignments'

error: failed to run custom build command for `tiny-skia v0.1.0`

Caused by:
  process didn't exit successfully: `/home/nyanpasu64/.cache/yay/resvg/src/resvg-0.11.0/target/release/build/tiny-skia-066268c03211979b/build-script-build` (exit code: 1)
  --- stdout
  cargo:rerun-if-env-changed=SKIA_DIR
  cargo:rerun-if-env-changed=SKIA_LIB_DIR
  TARGET = Some("x86_64-unknown-linux-gnu")
  OPT_LEVEL = Some("3")
  HOST = Some("x86_64-unknown-linux-gnu")
  CXX_x86_64-unknown-linux-gnu = None
  CXX_x86_64_unknown_linux_gnu = None
  HOST_CXX = None
  CXX = Some("clang++")
  CXXFLAGS_x86_64-unknown-linux-gnu = None
  CXXFLAGS_x86_64_unknown_linux_gnu = None
  HOST_CXXFLAGS = None
  CXXFLAGS = Some("-march=x86-64 -mtune=generic -O2 -pipe -fno-plt -g -fvar-tracking-assignments -fdebug-prefix-map=/home/nyanpasu64/.cache/yay/resvg/src=/usr/src/debug")
  CRATE_CC_NO_DEFAULTS = None
  DEBUG = Some("false")
  running: "clang++" "-O3" "-ffunction-sections" "-fdata-sections" "-fPIC" "--target=x86_64-unknown-linux-gnu" "-march=x86-64" "-mtune=generic" "-O2" "-pipe" "-fno-plt" "-g" "-fvar-tracking-assignments" "-fdebug-prefix-map=/home/nyanpasu64/.cache/yay/resvg/src=/usr/src/debug" "-I" "skia" "-I" "skia/include/third_party/skcms" "-I" "skia-c" "-std=c++17" "-fPIC" "-fno-exceptions" "-fno-rtti" "-fstrict-aliasing" "-fvisibility=hidden" "-fdata-sections" "-ffunction-sections" "-fvisibility-inlines-hidden" "-Wno-unused-function" "-Wno-unused-parameter" "-Wno-unused-private-field" "-DSK_DEBUG=1" "-o" "/home/nyanpasu64/.cache/yay/resvg/src/resvg-0.11.0/target/release/build/tiny-skia-b655a227c00daeed/out/skia/src/core/SkAlphaRuns.o" "-c" "skia/src/core/SkAlphaRuns.cpp"
  running: "clang++" "-O3" "-ffunction-sections" "-fdata-sections" "-fPIC" "--target=x86_64-unknown-linux-gnu" "-march=x86-64" "-mtune=generic" "-O2" "-pipe" "-fno-plt" "-g" "-fvar-tracking-assignments" "-fdebug-prefix-map=/home/nyanpasu64/.cache/yay/resvg/src=/usr/src/debug" "-I" "skia" "-I" "skia/include/third_party/skcms" "-I" "skia-c" "-std=c++17" "-fPIC" "-fno-exceptions" "-fno-rtti" "-fstrict-aliasing" "-fvisibility=hidden" "-fdata-sections" "-ffunction-sections" "-fvisibility-inlines-hidden" "-Wno-unused-function" "-Wno-unused-parameter" "-Wno-unused-private-field" "-DSK_DEBUG=1" "-o" "/home/nyanpasu64/.cache/yay/resvg/src/resvg-0.11.0/target/release/build/tiny-skia-b655a227c00daeed/out/skia/src/core/SkArenaAlloc.o" "-c" "skia/src/core/SkArenaAlloc.cpp"
  running: "clang++" "-O3" "-ffunction-sections" "-fdata-sections" "-fPIC" "--target=x86_64-unknown-linux-gnu" "-march=x86-64" "-mtune=generic" "-O2" "-pipe" "-fno-plt" "-g" "-fvar-tracking-assignments" "-fdebug-prefix-map=/home/nyanpasu64/.cache/yay/resvg/src=/usr/src/debug" "-I" "skia" "-I" "skia/include/third_party/skcms" "-I" "skia-c" "-std=c++17" "-fPIC" "-fno-exceptions" "-fno-rtti" "-fstrict-aliasing" "-fvisibility=hidden" "-fdata-sections" "-ffunction-sections" "-fvisibility-inlines-hidden" "-Wno-unused-function" "-Wno-unused-parameter" "-Wno-unused-private-field" "-DSK_DEBUG=1" "-o" "/home/nyanpasu64/.cache/yay/resvg/src/resvg-0.11.0/target/release/build/tiny-skia-b655a227c00daeed/out/skia/src/core/SkAnalyticEdge.o" "-c" "skia/src/core/SkAnalyticEdge.cpp"
  running: "clang++" "-O3" "-ffunction-sections" "-fdata-sections" "-fPIC" "--target=x86_64-unknown-linux-gnu" "-march=x86-64" "-mtune=generic" "-O2" "-pipe" "-fno-plt" "-g" "-fvar-tracking-assignments" "-fdebug-prefix-map=/home/nyanpasu64/.cache/yay/resvg/src=/usr/src/debug" "-I" "skia" "-I" "skia/include/third_party/skcms" "-I" "skia-c" "-std=c++17" "-fPIC" "-fno-exceptions" "-fno-rtti" "-fstrict-aliasing" "-fvisibility=hidden" "-fdata-sections" "-ffunction-sections" "-fvisibility-inlines-hidden" "-Wno-unused-function" "-Wno-unused-parameter" "-Wno-unused-private-field" "-DSK_DEBUG=1" "-o" "/home/nyanpasu64/.cache/yay/resvg/src/resvg-0.11.0/target/release/build/tiny-skia-b655a227c00daeed/out/skia/src/core/SkAAClip.o" "-c" "skia/src/core/SkAAClip.cpp"
  cargo:warning=clang-10: error: unknown argument: '-fvar-tracking-assignments'
  cargo:warning=clang-10: error: unknown argument: '-fvar-tracking-assignments'
  exit code: 1
  exit code: 1
  running: "clang++" "-O3" "-ffunction-sections" "-fdata-sections" "-fPIC" "--target=x86_64-unknown-linux-gnu" "-march=x86-64" "-mtune=generic" "-O2" "-pipe" "-fno-plt" "-g" "-fvar-tracking-assignments" "-fdebug-prefix-map=/home/nyanpasu64/.cache/yay/resvg/src=/usr/src/debug" "-I" "skia" "-I" "skia/include/third_party/skcms" "-I" "skia-c" "-std=c++17" "-fPIC" "-fno-exceptions" "-fno-rtti" "-fstrict-aliasing" "-fvisibility=hidden" "-fdata-sections" "-ffunction-sections" "-fvisibility-inlines-hidden" "-Wno-unused-function" "-Wno-unused-parameter" "-Wno-unused-private-field" "-DSK_DEBUG=1" "-o" "/home/nyanpasu64/.cache/yay/resvg/src/resvg-0.11.0/target/release/build/tiny-skia-b655a227c00daeed/out/skia/src/core/SkBitmapCache.o" "-c" "skia/src/core/SkBitmapCache.cpp"
  cargo:warning=clang-10: error: unknown argument: '-fvar-tracking-assignments'
  cargo:warning=clang-10: error: unknown argument: '-fvar-tracking-assignments'
  exit code: 1
  exit code: 1
  cargo:warning=clang-10: error: unknown argument: '-fvar-tracking-assignments'
  exit code: 1

  --- stderr


  error occurred: Command "clang++" "-O3" "-ffunction-sections" "-fdata-sections" "-fPIC" "--target=x86_64-unknown-linux-gnu" "-march=x86-64" "-mtune=generic" "-O2" "-pipe" "-fno-plt" "-g" "-fvar-tracking-assignments" "-fdebug-prefix-map=/home/nyanpasu64/.cache/yay/resvg/src=/usr/src/debug" "-I" "skia" "-I" "skia/include/third_party/skcms" "-I" "skia-c" "-std=c++17" "-fPIC" "-fno-exceptions" "-fno-rtti" "-fstrict-aliasing" "-fvisibility=hidden" "-fdata-sections" "-ffunction-sections" "-fvisibility-inlines-hidden" "-Wno-unused-function" "-Wno-unused-parameter" "-Wno-unused-private-field" "-DSK_DEBUG=1" "-o" "/home/nyanpasu64/.cache/yay/resvg/src/resvg-0.11.0/target/release/build/tiny-skia-b655a227c00daeed/out/skia/src/core/SkAAClip.o" "-c" "skia/src/core/SkAAClip.cpp" with args "clang++" did not execute successfully (status code exit code: 1).

flying-sheep commented on 2020-10-19 10:04

@lyra, well you need to configure a default toolchain if you use rustup. (If you use cargo from the rust package, it should work immediately)

lyra commented on 2020-10-13 12:07

Hi! I can't install any of resvg* packages. Here is log:

[lyra@lyrathink ~]$ yay resvg
4 aur/resvg-qt 0.9.1-1 (+0 0.00) (Out-of-date: 2020-09-08)
    SVG rendering library and CLI (Linked against Qt)
3 aur/resvg-cairo 0.9.1-1 (+4 0.07) (Out-of-date: 2020-09-08)
    SVG rendering library and CLI (Linked against cairo)
2 aur/resvg-git 0.9.0.r11.ge207cc3-1 (+7 0.00)
    SVG rendering library and CLI
1 aur/resvg 0.9.1-1 (+14 1.16) (Out-of-date: 2020-09-08)
    SVG rendering library and CLI
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 1
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo Make:28]  media-player-info-24-2  solid-5.75.0-1  kcoreaddons-5.75.0-1  kjobwidgets-5.75.0-1  kdbusaddons-5.75.0-1  kconfig-5.75.0-1  kcrash-5.75.0-1  kglobalaccel-5.75.0-1  kauth-5.75.0-1  kcodecs-5.75.0-1  kguiaddons-5.75.0-1  ki18n-5.75.0-1  kconfigwidgets-5.75.0-1  kitemviews-5.75.0-1  karchive-5.75.0-1  kiconthemes-5.75.0-1  attica-5.75.0-1  kxmlgui-5.75.0-1  kbookmarks-5.75.0-1  qt5-speech-5.15.1-1  knotifications-5.75.0-1  kservice-5.75.0-1  kwallet-5.75.0-1  kcompletion-5.75.0-1  sonnet-5.75.0-1  ktextwidgets-5.75.0-1  kded-5.75.0-1  kio-5.75.0-1
[Aur:1]  resvg-0.9.1-1

==> Remove make dependencies after install? [y/N] y
  1 resvg                                    (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: PKGBUILD up to date, Skipping (1/1): resvg
  1 resvg                                    (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: (1/1) Parsing SRCINFO: resvg
resolving dependencies...
looking for conflicting packages...

Packages (28) attica-5.75.0-1  karchive-5.75.0-1  kauth-5.75.0-1
              kbookmarks-5.75.0-1  kcodecs-5.75.0-1  kcompletion-5.75.0-1
              kconfig-5.75.0-1  kconfigwidgets-5.75.0-1  kcoreaddons-5.75.0-1
              kcrash-5.75.0-1  kdbusaddons-5.75.0-1  kded-5.75.0-1
              kglobalaccel-5.75.0-1  kguiaddons-5.75.0-1  ki18n-5.75.0-1
              kiconthemes-5.75.0-1  kio-5.75.0-1  kitemviews-5.75.0-1
              kjobwidgets-5.75.0-1  knotifications-5.75.0-1  kservice-5.75.0-1
              ktextwidgets-5.75.0-1  kwallet-5.75.0-1  kxmlgui-5.75.0-1
              media-player-info-24-2  qt5-speech-5.15.1-1  solid-5.75.0-1
              sonnet-5.75.0-1

Total Installed Size:  78.96 MiB

:: Proceed with installation? [Y/n]
(28/28) checking keys in keyring                   [#####################] 100%
(28/28) checking package integrity                 [#####################] 100%
(28/28) loading package files                      [#####################] 100%
(28/28) checking for file conflicts                [#####################] 100%
(28/28) checking available disk space              [#####################] 100%
:: Processing package changes...
( 1/28) installing media-player-info               [#####################] 100%
( 2/28) installing solid                           [#####################] 100%
Optional dependencies for solid
    qt5-declarative: QML bindings [installed]
( 3/28) installing kcoreaddons                     [#####################] 100%
Optional dependencies for kcoreaddons
    python-pyqt5: for the Python bindings [installed]
( 4/28) installing kjobwidgets                     [#####################] 100%
Optional dependencies for kjobwidgets
    python-pyqt5: for the Python bindings [installed]
( 5/28) installing kdbusaddons                     [#####################] 100%
Optional dependencies for kdbusaddons
    python-pyqt5: for the Python bindings [installed]
( 6/28) installing kconfig                         [#####################] 100%
Optional dependencies for kconfig
    python-pyqt5: for the Python bindings [installed]
( 7/28) installing kcrash                          [#####################] 100%
Optional dependencies for kcrash
    drkonqi: KDE crash handler application
( 8/28) installing kglobalaccel                    [#####################] 100%
( 9/28) installing kauth                           [#####################] 100%
Optional dependencies for kauth
    python-pyqt5: for the Python bindings [installed]
(10/28) installing kcodecs                         [#####################] 100%
Optional dependencies for kcodecs
    python-pyqt5: for the Python bindings [installed]
(11/28) installing kguiaddons                      [#####################] 100%
Optional dependencies for kguiaddons
    python-pyqt5: for the Python bindings [installed]
(12/28) installing ki18n                           [#####################] 100%
Optional dependencies for ki18n
    python-pyqt5: for the Python bindings [installed]
    python: to compile .ts files [installed]
(13/28) installing kconfigwidgets                  [#####################] 100%
Optional dependencies for kconfigwidgets
    python-pyqt5: for the Python bindings [installed]
    perl: for preparetips5 [installed]
(14/28) installing kitemviews                      [#####################] 100%
Optional dependencies for kitemviews
    python-pyqt5: for the Python bindings [installed]
(15/28) installing karchive                        [#####################] 100%
(16/28) installing kiconthemes                     [#####################] 100%
Optional dependencies for kiconthemes
    breeze-icons: fallback icon theme
(17/28) installing attica                          [#####################] 100%
(18/28) installing kxmlgui                         [#####################] 100%
(19/28) installing kbookmarks                      [#####################] 100%
(20/28) installing qt5-speech                      [#####################] 100%
Optional dependencies for qt5-speech
    flite: flite TTS backend
    speech-dispatcher: speech-dispatcher TTS backend
(21/28) installing knotifications                  [#####################] 100%
(22/28) installing kservice                        [#####################] 100%
(23/28) installing kwallet                         [#####################] 100%
Optional dependencies for kwallet
    kwalletmanager: Configuration GUI
(24/28) installing kcompletion                     [#####################] 100%
Optional dependencies for kcompletion
    python-pyqt5: for the Python bindings [installed]
(25/28) installing sonnet                          [#####################] 100%
Optional dependencies for sonnet
    hunspell: spell checking via hunspell [installed]
    aspell: spell checking via aspell [installed]
    hspell: spell checking for Hebrew
    libvoikko: Finnish support via Voikko
(26/28) installing ktextwidgets                    [#####################] 100%
(27/28) installing kded                            [#####################] 100%
(28/28) installing kio                             [#####################] 100%
Optional dependencies for kio
    kio-extras: extra protocols support (sftp, fish and more)
    kdoctools: for the help kioslave
    knetattach: to add new kio-remote entries
    kio-fuse: to mount remote filesystems via FUSE
:: Running post-transaction hooks...
(1/6) Updating udev hardware database...
(2/6) Reloading device manager configuration...
(3/6) Arming ConditionNeedsUpdate...
(4/6) Reloading system bus configuration...
(5/6) Updating the desktop file MIME type cache...
(6/6) Updating the MIME type database...
==> Making package: resvg 0.9.1-1 (Tue 13 Oct 2020 03:01:44 PM MSK)
==> Retrieving sources...
  -> Found resvg-0.9.1.tar.gz
  -> Found qt-5.15.patch
==> Validating source files with sha256sums...
    resvg-0.9.1.tar.gz ... Passed
    qt-5.15.patch ... Passed
 -> kio not satisfied, flushing install queue
==> Making package: resvg 0.9.1-1 (Tue 13 Oct 2020 03:01:45 PM MSK)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found resvg-0.9.1.tar.gz
  -> Found qt-5.15.patch
==> Validating source files with sha256sums...
    resvg-0.9.1.tar.gz ... Passed
    qt-5.15.patch ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting resvg-0.9.1.tar.gz with bsdtar
==> Starting prepare()...
patching file bindings/resvg-qt/cpp/qt_capi.cpp
==> Sources are ready.
==> Making package: resvg 0.9.1-1 (Tue 13 Oct 2020 03:01:48 PM MSK)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Starting build()...
  -> Building capi
error: no override and no default toolchain set
==> ERROR: A failure occurred in build().
    Aborting...
checking dependencies...
:: libreoffice-fresh optionally requires kio: for KF5 KDE desktop integration
:: python-pyqt5 optionally requires qt5-speech: QtTextToSpeech
:: vlc optionally requires kwallet: kwallet keystore

Packages (28) attica-5.75.0-1  karchive-5.75.0-1  kauth-5.75.0-1
              kbookmarks-5.75.0-1  kcodecs-5.75.0-1  kcompletion-5.75.0-1
              kconfig-5.75.0-1  kconfigwidgets-5.75.0-1  kcoreaddons-5.75.0-1
              kcrash-5.75.0-1  kdbusaddons-5.75.0-1  kded-5.75.0-1
              kglobalaccel-5.75.0-1  kguiaddons-5.75.0-1  ki18n-5.75.0-1
              kiconthemes-5.75.0-1  kio-5.75.0-1  kitemviews-5.75.0-1
              kjobwidgets-5.75.0-1  knotifications-5.75.0-1  kservice-5.75.0-1
              ktextwidgets-5.75.0-1  kwallet-5.75.0-1  kxmlgui-5.75.0-1
              media-player-info-24-2  qt5-speech-5.15.1-1  solid-5.75.0-1
              sonnet-5.75.0-1

Total Removed Size:  78.96 MiB

:: Do you want to remove these packages? [Y/n]
:: Processing package changes...
( 1/28) removing kio                               [#####################] 100%
( 2/28) removing kded                              [#####################] 100%
( 3/28) removing ktextwidgets                      [#####################] 100%
( 4/28) removing sonnet                            [#####################] 100%
( 5/28) removing kcompletion                       [#####################] 100%
( 6/28) removing kwallet                           [#####################] 100%
( 7/28) removing kservice                          [#####################] 100%
( 8/28) removing knotifications                    [#####################] 100%
( 9/28) removing qt5-speech                        [#####################] 100%
(10/28) removing kbookmarks                        [#####################] 100%
(11/28) removing kxmlgui                           [#####################] 100%
(12/28) removing attica                            [#####################] 100%
(13/28) removing kiconthemes                       [#####################] 100%
(14/28) removing karchive                          [#####################] 100%
(15/28) removing kitemviews                        [#####################] 100%
(16/28) removing kconfigwidgets                    [#####################] 100%
(17/28) removing ki18n                             [#####################] 100%
(18/28) removing kguiaddons                        [#####################] 100%
(19/28) removing kcodecs                           [#####################] 100%
(20/28) removing kauth                             [#####################] 100%
(21/28) removing kglobalaccel                      [#####################] 100%
(22/28) removing kcrash                            [#####################] 100%
(23/28) removing kconfig                           [#####################] 100%
(24/28) removing kdbusaddons                       [#####################] 100%
(25/28) removing kjobwidgets                       [#####################] 100%
(26/28) removing kcoreaddons                       [#####################] 100%
(27/28) removing solid                             [#####################] 100%
(28/28) removing media-player-info                 [#####################] 100%
:: Running post-transaction hooks...
(1/6) Updating udev hardware database...
(2/6) Reloading device manager configuration...
(3/6) Arming ConditionNeedsUpdate...
(4/6) Reloading system bus configuration...
(5/6) Updating the desktop file MIME type cache...
(6/6) Updating the MIME type database...

flying-sheep commented on 2020-06-13 19:37

Ah there’s a 0.9.1, thanks, updated!

jprjr commented on 2020-06-12 12:48

Hi - I updated my local PKGBUILD to update to resvg 0.9.1 and apply that Qt 5.15 fix as a patch

diff --git a/PKGBUILD b/PKGBUILD
index 282e956..383af00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
 # Maintainer: Philipp A. <flying-sheep@web.de>
 pkgname=resvg
-pkgver=0.9.0
+pkgver=0.9.1
 pkgrel=1
 pkgdesc='SVG rendering library and CLI'
 arch=(i686 x86_64)
@@ -13,8 +13,16 @@ optdepends=(
    'kio: For the dolphin thumbnailer'
 )
 makedepends=(cargo qt5-base qt5-tools kio cairo pango cmake extra-cmake-modules)
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('8da2c0463cb76ab2a75c597be9f83384daf27a2d6162b95310b8f68763dfcc47')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz" 'qt-5.15.patch')
+sha256sums=(
+'678e2bb453bd1b979fe1371f6a68da830f300067717604d8b9e83a196528bf36'
+'10f8ac12ac63c12905c7ac4f373e619653ed772e34c60bcaabe180364c5f7f13'
+)
+
+prepare() {
+   cd "$pkgname-$pkgver"
+    patch --forward --strip=1 --input="${srcdir}/qt-5.15.patch"
+}

 build() {
    cd "$pkgname-$pkgver"
diff --git a/qt-5.15.patch b/qt-5.15.patch
new file mode 100644
index 0000000..fb46d8a
--- /dev/null
+++ b/qt-5.15.patch
@@ -0,0 +1,22 @@
+From 8ea12d08a4402eb49a8d371cf7dde1a7e047bb47 Mon Sep 17 00:00:00 2001
+From: Evgeniy Reizner <razrfalcon@gmail.com>
+Date: Thu, 4 Jun 2020 19:21:10 +0300
+Subject: [PATCH] (qt-backend) Fix building with Qt >= 5.15
+
+Closes #294
+---
+ bindings/resvg-qt/cpp/qt_capi.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/bindings/resvg-qt/cpp/qt_capi.cpp b/bindings/resvg-qt/cpp/qt_capi.cpp
+index cabda9d1..952d9754 100644
+--- a/bindings/resvg-qt/cpp/qt_capi.cpp
++++ b/bindings/resvg-qt/cpp/qt_capi.cpp
+@@ -1,6 +1,7 @@
+ #include <QGuiApplication>
+ #include <QImage>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QImageWriter>
+ #include <QDebug>
+ 

flying-sheep commented on 2020-06-05 11:18

As you figured out by now in https://github.com/RazrFalcon/resvg/issues/294, that’s because of Qt 5.15.

You could have told me that here!

ikrivosheev commented on 2020-06-04 13:00

Hi, I have some problem on install:

pikaur -Sy resvg
Caused by:
  process didn't exit successfully: `/tmp/makepkg/resvg/src/resvg-0.9.0/target/release/build/resvg-qt-71581e8be6bf7b3e/build-script-build` (exit code: 1)
--- stdout
cargo:rustc-link-lib=Qt5Gui
cargo:rustc-link-lib=Qt5Core
TARGET = Some("x86_64-unknown-linux-gnu")
OPT_LEVEL = Some("3")
HOST = Some("x86_64-unknown-linux-gnu")
CXX_x86_64-unknown-linux-gnu = None
CXX_x86_64_unknown_linux_gnu = None
HOST_CXX = None
CXX = None
CXXFLAGS_x86_64-unknown-linux-gnu = None
CXXFLAGS_x86_64_unknown_linux_gnu = None
HOST_CXXFLAGS = None
CXXFLAGS = Some("-O2 -pipe -fno-plt")
CRATE_CC_NO_DEFAULTS = None
DEBUG = Some("false")
CARGO_CFG_TARGET_FEATURE = Some("fxsr,sse,sse2")
running: "c++" "-O3" "-ffunction-sections" "-fdata-sections" "-fPIC" "-m64" "-O2" "-pipe" "-fno-plt" "-I" "cpp" "-I" "/usr/include/qt/QtGui" "-I" "/usr/include/qt" "-I" "/usr/include/qt/QtCore" "-std=c++11" "-o" "/tmp/makepkg/resvg/src/resvg-0.9.0/target/release/build/resvg-qt-99a0a220e57eb815/out/cpp/qt_capi.o" "-c" "cpp/qt_capi.cpp"
cargo:warning=cpp/qt_capi.cpp: In function ‘void qtc_qpainter_draw_text(qtc_qpainter*, double, double, const char*)’:
cargo:warning=cpp/qt_capi.cpp:176:18: error: aggregate ‘QPainterPath path’ has incomplete type and cannot be defined
cargo:warning=  176 |     QPainterPath path;
cargo:warning=      |                  ^~~~
cargo:warning=cpp/qt_capi.cpp: In function ‘void qtc_qpainter_reset_clip_path(qtc_qpainter*)’:
cargo:warning=cpp/qt_capi.cpp:220:44: error: invalid use of incomplete type ‘class QPainterPath’
cargo:warning=  220 |     PAINTER_CAST->setClipPath(QPainterPath(), Qt::NoClip);
cargo:warning=      |                                            ^
cargo:warning=In file included from /usr/include/qt/QtGui/qtransform.h:43,
cargo:warning=                 from /usr/include/qt/QtGui/qimage.h:48,
cargo:warning=                 from /usr/include/qt/QtGui/QImage:1,
cargo:warning=                 from cpp/qt_capi.cpp:2:
cargo:warning=/usr/include/qt/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
cargo:warning=   54 | class QPainterPath;
cargo:warning=      |       ^~~~~~~~~~~~
cargo:warning=cpp/qt_capi.cpp: In function ‘qtc_qpainterpath* qtc_qpainterpath_create()’:
cargo:warning=cpp/qt_capi.cpp:242:65: error: invalid use of incomplete type ‘class QPainterPath’
cargo:warning=  242 |     return reinterpret_cast<qtc_qpainterpath*>(new QPainterPath());
cargo:warning=      |                                                                 ^
cargo:warning=In file included from /usr/include/qt/QtGui/qtransform.h:43,
cargo:warning=                 from /usr/include/qt/QtGui/qimage.h:48,
cargo:warning=                 from /usr/include/qt/QtGui/QImage:1,
cargo:warning=                 from cpp/qt_capi.cpp:2:
cargo:warning=/usr/include/qt/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
cargo:warning=   54 | class QPainterPath;
cargo:warning=      |       ^~~~~~~~~~~~
cargo:warning=cpp/qt_capi.cpp: In function ‘void qtc_qpainterpath_move_to(qtc_qpainterpath*, double, double)’:
cargo:warning=cpp/qt_capi.cpp:247:14: error: invalid use of incomplete type ‘class QPainterPath’
cargo:warning=  247 |     PATH_CAST->moveTo(x, y);
cargo:warning=      |              ^~
cargo:warning=In file included from /usr/include/qt/QtGui/qtransform.h:43,
cargo:warning=                 from /usr/include/qt/QtGui/qimage.h:48,
cargo:warning=                 from /usr/include/qt/QtGui/QImage:1,
cargo:warning=                 from cpp/qt_capi.cpp:2:
cargo:warning=/usr/include/qt/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
cargo:warning=   54 | class QPainterPath;
cargo:warning=      |       ^~~~~~~~~~~~
cargo:warning=cpp/qt_capi.cpp: In function ‘void qtc_qpainterpath_line_to(qtc_qpainterpath*, double, double)’:
cargo:warning=cpp/qt_capi.cpp:252:14: error: invalid use of incomplete type ‘class QPainterPath’
cargo:warning=  252 |     PATH_CAST->lineTo(x, y);
cargo:warning=      |              ^~
cargo:warning=In file included from /usr/include/qt/QtGui/qtransform.h:43,
cargo:warning=                 from /usr/include/qt/QtGui/qimage.h:48,
cargo:warning=                 from /usr/include/qt/QtGui/QImage:1,
cargo:warning=                 from cpp/qt_capi.cpp:2:
cargo:warning=/usr/include/qt/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
cargo:warning=   54 | class QPainterPath;
cargo:warning=      |       ^~~~~~~~~~~~
cargo:warning=cpp/qt_capi.cpp: In function ‘void qtc_qpainterpath_curve_to(qtc_qpainterpath*, double, double, double, double, double, double)’:
cargo:warning=cpp/qt_capi.cpp:258:14: error: invalid use of incomplete type ‘class QPainterPath’
cargo:warning=  258 |     PATH_CAST->cubicTo(x1, y1, x2, y2, x, y);
cargo:warning=      |              ^~
cargo:warning=In file included from /usr/include/qt/QtGui/qtransform.h:43,
cargo:warning=                 from /usr/include/qt/QtGui/qimage.h:48,
cargo:warning=                 from /usr/include/qt/QtGui/QImage:1,
cargo:warning=                 from cpp/qt_capi.cpp:2:
cargo:warning=/usr/include/qt/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
cargo:warning=   54 | class QPainterPath;
cargo:warning=      |       ^~~~~~~~~~~~
cargo:warning=cpp/qt_capi.cpp: In function ‘void qtc_qpainterpath_close_path(qtc_qpainterpath*)’:
cargo:warning=cpp/qt_capi.cpp:263:14: error: invalid use of incomplete type ‘class QPainterPath’
cargo:warning=  263 |     PATH_CAST->closeSubpath();
cargo:warning=      |              ^~
cargo:warning=In file included from /usr/include/qt/QtGui/qtransform.h:43,
cargo:warning=                 from /usr/include/qt/QtGui/qimage.h:48,
cargo:warning=                 from /usr/include/qt/QtGui/QImage:1,
cargo:warning=                 from cpp/qt_capi.cpp:2:
cargo:warning=/usr/include/qt/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
cargo:warning=   54 | class QPainterPath;
cargo:warning=      |       ^~~~~~~~~~~~
cargo:warning=cpp/qt_capi.cpp: In function ‘void qtc_qpainterpath_set_fill_rule(qtc_qpainterpath*, FillRule)’:
cargo:warning=cpp/qt_capi.cpp:268:14: error: invalid use of incomplete type ‘class QPainterPath’
cargo:warning=  268 |     PATH_CAST->setFillRule(Qt::FillRule(rule));
cargo:warning=      |              ^~
cargo:warning=In file included from /usr/include/qt/QtGui/qtransform.h:43,
cargo:warning=                 from /usr/include/qt/QtGui/qimage.h:48,
cargo:warning=                 from /usr/include/qt/QtGui/QImage:1,
cargo:warning=                 from cpp/qt_capi.cpp:2:
cargo:warning=/usr/include/qt/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
cargo:warning=   54 | class QPainterPath;
cargo:warning=      |       ^~~~~~~~~~~~
cargo:warning=cpp/qt_capi.cpp: In function ‘void qtc_qpainterpath_destroy(qtc_qpainterpath*)’:
cargo:warning=cpp/qt_capi.cpp:273:5: warning: possible problem detected in invocation of ‘operator delete’ [-Wdelete-incomplete]
cargo:warning=  273 |     delete PATH_CAST;
cargo:warning=      |     ^
cargo:warning=cpp/qt_capi.cpp:11:19: warning: invalid use of incomplete type ‘class QPainterPath’
cargo:warning=   11 | #define PATH_CAST reinterpret_cast<QPainterPath*>(c_pp)
cargo:warning=      |                   ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
cargo:warning=cpp/qt_capi.cpp:273:12: note: in expansion of macro ‘PATH_CAST’
cargo:warning=  273 |     delete PATH_CAST;
cargo:warning=      |            ^~~~~~~~~
cargo:warning=In file included from /usr/include/qt/QtGui/qtransform.h:43,
cargo:warning=                 from /usr/include/qt/QtGui/qimage.h:48,
cargo:warning=                 from /usr/include/qt/QtGui/QImage:1,
cargo:warning=                 from cpp/qt_capi.cpp:2:
cargo:warning=/usr/include/qt/QtGui/qmatrix.h:54:7: note: forward declaration of ‘class QPainterPath’
cargo:warning=   54 | class QPainterPath;
cargo:warning=      |       ^~~~~~~~~~~~
cargo:warning=cpp/qt_capi.cpp:273:5: note: neither the destructor nor the class-specific ‘operator delete’ will be called, even if they are declared when the class is defined
cargo:warning=  273 |     delete PATH_CAST;
cargo:warning=      |     ^
exit code: 1

flying-sheep commented on 2019-03-07 06:51

Arch generally offers quite fully featured packages, so my resvg is the one that would be built upstream.

I offer alternatives because you asked for them, I don't consider them necessary. I'd be fine with cleaning up build deps after being done.

When creating a package depending on resvg, you simply specify “resvg” in the makedeps. If you don't want to pull in all makedeps of the main package, you make sure to install “resvg-qt” or “resvg-cairo” before installing the dependent package, as both -qt and -cairo provide “resvg”.

kubrick commented on 2019-03-07 06:31

Well, I think there needs to be a resvg package which depends neither on cairo nor on qt. If not, which package do I choose as a makedepends ?

flying-sheep commented on 2019-03-06 16:33

just install one of the others. They provide the library without providing the other stuff, and only need minimal build deps.