Package Details: remarkable 1.87-5

Git Clone URL: https://aur.archlinux.org/remarkable.git (read-only)
Package Base: remarkable
Description: A free fully featured markdown editor for Linux.
Upstream URL: http://remarkableapp.github.io
Keywords: editor markdown remarkable
Licenses: MIT
Submitter: visit
Maintainer: chawlindel
Last Packager: chawlindel
Votes: 93
Popularity: 1.300178
First Submitted: 2014-08-15 01:38
Last Updated: 2019-05-27 22:55

Latest Comments

1 2 3 4 5 6 ... Next › Last »

mabl commented on 2019-04-14 13:02

Without python-setuptools, one gets

$ remarkable                                                                                                                                                                                                                    
Traceback (most recent call last):
  File "/usr/bin/remarkable", line 65, in <module>
    import remarkable
  File "/usr/lib/python3.7/site-packages/remarkable/__init__.py", line 30, in <module>
    from remarkable import RemarkableWindow
  File "/usr/lib/python3.7/site-packages/remarkable/RemarkableWindow.py", line 33, in <module>
    import markdown
  File "/usr/lib/python3.7/site-packages/markdown/__init__.py", line 25, in <module>
    from .core import Markdown, markdown, markdownFromFile
  File "/usr/lib/python3.7/site-packages/markdown/core.py", line 29, in <module>
    import pkg_resources
ModuleNotFoundError: No module named 'pkg_resources'

chawlindel commented on 2019-02-20 12:05

@marry_a I tried installing and running remarkable without python-setuptools or any of it's dependencies, and that worked fine for me. What was it that didn't work without it?

marry_a commented on 2019-02-20 10:00

please add package python-setuptools to dependencies, i had to install it manually to get remarkable to work.

chawlindel commented on 2018-08-09 10:55

@dcro95 GitHub must've changed their patch format. Fixed it.

dcro95 commented on 2018-08-07 15:26

sha1sum of the file stable.patch seems to be invalid in PKGBUILD.

I have to update the PKBUILD file to install remarkable.

chawlindel commented on 2018-03-03 20:46

I've decided to patch this package to use webkit2gtk. The new PKGBUILD also uses the source from github instead of unpacking the deb package.

Llama commented on 2017-12-22 19:04

Voted for this package. Five hours' building, no end in sight. It has to be moved to community.

UPD:

All you need is already in the https://wiki.archlinux.org/index.php/Unofficial_user_repositories#archlinuxcn repo.

chawlindel commented on 2017-12-04 22:47

@elgs: Your issue is with webkitgtk, not with remarkable. Use remarkable-webkit2gtk if you're having problems with webkitgtk.

elgs commented on 2017-12-04 18:53

==> Extracting sources... -> Extracting webkitgtk-2.4.11.tar.xz with bsdtar ==> Starting prepare()... mkdir: cannot create directory ‘build-gtk’: File exists mkdir: cannot create directory ‘build-gtk2’: File exists mkdir: cannot create directory ‘path’: File exists ==> ERROR: A failure occurred in prepare(). Aborting... ==> ERROR: Makepkg was unable to build webkitgtk. ==> Restart building webkitgtk ? [y/N]

nhumrich commented on 2017-08-11 01:59

Getting this weird error trying to install:
Traceback (most recent call last):
File "<string>", line 1, in <module>
AttributeError: module 'site' has no attribute 'getsitepackages'

Any ideas?

Edit: Nevermind. I got it to work by deactivating my current virtualenv