Package Details: relational 3.0-1

Git Clone URL: https://aur.archlinux.org/relational.git (read-only, click to copy)
Package Base: relational
Description: Educational tool for relational algebra
Upstream URL: http://ltworf.github.io/relational/
Keywords: algebra relational
Licenses: GPL3
Submitter: metak
Maintainer: metak
Last Packager: metak
Votes: 0
Popularity: 0.000000
First Submitted: 2017-10-02 22:39
Last Updated: 2021-01-08 15:48

Required by (0)

Sources (1)

Latest Comments

Terence commented on 2021-01-08 08:54

EDIT: actually no need to backport, just update to the latest released version 3.0 which contains the fix (3.1 seems also imminent).

The program does not run because of the import sip line 86 which would require python-sip4 :

  File "/usr/bin/relational", line 86, in <module>
    import sip  # needed on windows
ModuleNotFoundError: No module named 'sip'

This was fixed upstream : https://github.com/ltworf/relational/commit/c44a9abff4b7045c3ea1c0c32112a8142499269d

so maybe this commit should be backported.

dantopa commented on 2017-10-02 23:35

It's perfectly now, recently updated and everything working. Thanks!!

metak commented on 2017-10-02 23:27

My bad, got a bit distracted while looking at the latest makefile on github. Should be fine now?

dantopa commented on 2017-10-02 23:08

Thanks for this PKG! But I have a problem, for some reason when I try to run it says "module relational_gui is missing, please install relational package or run make", and nothing happens. I think a make must be added to the script or something like that