Package Details: redis-desktop-manager 2020.0-3

Git Clone URL: https://aur.archlinux.org/redis-desktop-manager.git (read-only, click to copy)
Package Base: redis-desktop-manager
Description: Open source cross-platform Redis Desktop Manager based on Qt 5
Upstream URL: https://redisdesktop.com/
Keywords: gui redis tool
Licenses: GPL3
Conflicts: redis-desktop-manager-bin
Submitter: crabvk
Maintainer: lukaszimmermann
Last Packager: versusvoid
Votes: 25
Popularity: 0.62
First Submitted: 2016-02-06 01:38
Last Updated: 2020-04-29 16:48

Latest Comments

1 2 3 Next › Last »

pidario commented on 2020-10-31 15:25

I just published a bin package here: https://aur.archlinux.org/packages/rdm-bin/

For curious people, building instructions and artifacts are here https://github.com/pidario/rdm-build

tkolo commented on 2020-10-26 19:02

Here's a PKGBUILD for 2020.5 that works for me:

# Maintainer: Versus Void <chaoskeeper &commat; mail FULL STOP ru>
# Maintainer: Mehmet Ozgur Bayhan <mozgurbayhan@gmail.com>
# Contributor: Vyacheslav Konovalov <echo dnlhY2hrb25vdmFsb3ZAZ21haWwuY29tCg== | base64 -d>

pkgname=redis-desktop-manager
pkgver=2020.5
pkgrel=1
pkgdesc='Open source cross-platform Redis Desktop Manager based on Qt 5'
arch=('x86_64')
url="https://redisdesktop.com/"
license=('GPL3')
depends=(
  'qt5-base'
  'qt5-imageformats'
  'qt5-tools'
  'qt5-declarative'
  'qt5-quickcontrols'
  'qt5-quickcontrols2'
  'qt5-charts'
  'qt5-graphicaleffects'
  'qt5-svg'
  'libssh2'
  'python')
makedepends=('git' 'gcc' 'make' 'python-virtualenv')
conflicts=('redis-desktop-manager-bin')
source=("rdm::git://github.com/uglide/RedisDesktopManager.git#tag=$pkgver"
        'rdm.sh'
        'rdm.desktop')
sha256sums=('SKIP'
            'f469d9a5adce723904efe0f1b1db5d79807410f90aafb117f18ae108d8b2d391'
            '9ca6cfe0fc1a050552ec2fa009a2d517de3b049ff6f379f0fda849e4dbca3f68')

prepare() {
  cd rdm/
  git submodule update --init --recursive
}

build() {
  cd $srcdir/rdm/3rdparty/lz4/build/cmake
  cmake -DBUILD_STATIC_LIBS=1 .
  make

  cd $srcdir/rdm/src
  virtualenv .venv
  source .venv/bin/activate
  cp resources/Info.plist.sample resources/Info.plist
  .venv/bin/pip3 install -t ../bin/osx/release -r py/requirements.txt
  qmake && make
}

package() {
  _instdir="$srcdir/rdm/bin/linux/release"
  _bindir="$pkgdir/usr/share/redis-desktop-manager/bin"

  mkdir -p "${_bindir}"
  mkdir "$pkgdir/usr/share/licenses"
  mkdir "$pkgdir/usr/share/pixmaps"
  mkdir "$pkgdir/usr/share/applications"

  install -Dm644 "$srcdir/rdm/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
  install -Dm755 "${_instdir}/rdm" "${_bindir}/rdm"
  install -Dm755 "$srcdir/rdm.sh" "${_bindir}/rdm.sh"
  install -Dm644 "$srcdir/rdm/src/resources/images/rdm.png" "$pkgdir/usr/share/pixmaps/rdm.png"
  install -Dm644 "$srcdir/rdm.desktop" "$pkgdir/usr/share/applications/rdm.desktop"

  mkdir "$pkgdir/usr/bin"
  ln -s '/usr/share/redis-desktop-manager/bin/rdm.sh' "$pkgdir/usr/bin/rdm"
}

versusvoid commented on 2020-03-23 05:57

Nope. Builds fine with miniconda3

jameskutw commented on 2020-03-22 17:41

@versusvoid Thanks. Your comment helped me find the issue. I removed miniconda3 and built successfully. Maybe you can reproduce the problem by installing miniconda3.

versusvoid commented on 2020-03-22 07:10

@jameskutw I can't reproduce such failure. Tried building on empty system (using docker) and it builds fine, so it's likely some package you have installed messes with building.

jameskutw commented on 2020-03-22 02:40

failed to build

/bin/sh: --exec-prefix: command not found
/bin/sh: --includes: command not found
/bin/sh: --libs: command not found
/bin/sh: --cflags: command not found
/bin/sh: --ldflags: command not found
/bin/sh: --extension-suffix: command not found
/bin/sh: --abiflags: command not found
/bin/sh: --help: command not found
/bin/sh: --configdir: command not found
g++: error: Usage:: No such file or directory
g++: error: missing argument to ‘--prefix’
make: *** [Makefile:636: ../bin/linux/release/rdm] Error 127
==> ERROR: A failure occurred in build().
    Aborting...

mkoloberdin commented on 2019-12-27 07:58

Fails to build:

g++ -c -pipe -I/usr/include/python3.8 -I/usr/include/python3.8 -Wno-sign-compare -O2 -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -std=gnu++11 -Wall -Wextra -D_REENTRANT -fPIC -DHAVE_DLADDR -DPYOTHERSIDE_VERSION=\"1.5.8\" -DQT_NO_DEBUG -DQT_QUICKWIDGETS_LIB -DQT_CHARTS_LIB -DQT_SVG_LIB -DQT_WIDGETS_LIB -DQT_QUICK_LIB -DQT_GUI_LIB -DQT_QMLMODELS_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -I. -I../3rdparty/qredisclient/src -I../3rdparty/qredisclient/3rdparty -I../3rdparty/qredisclient/3rdparty/asyncfuture -I../3rdparty/pyotherside/src -I. -Imodules -I/tmp/redis-desktop-manager-9962419960185253452/redis-desktop-manager/src/rdm/src/../bin/linux/release/ui/ -isystem /usr/include/qt -isystem /usr/include/qt/QtQuickWidgets -isystem /usr/include/qt/QtCharts -isystem /usr/include/qt/QtSvg -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtQuick -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtQmlModels -isystem /usr/include/qt/QtQml -isystem /usr/include/qt/QtNetwork -isystem /usr/include/qt/QtConcurrent -isystem /usr/include/qt/QtCore -I../bin/linux/release/obj -I/usr/lib/qt/mkspecs/linux-g++ -o ../bin/linux/release/obj/tabsmodel.o modules/value-editor/tabsmodel.cpp
modules/console/autocompletemodel.cpp: In constructor ‘Console::AutocompleteModel::AutocompleteModel()’:
modules/console/autocompletemodel.cpp:9:5: error: ‘QFile’ was not declared in this scope
    9 |     QFile commandsResource("://commands.json");
      |     ^~~~~
modules/console/autocompletemodel.cpp:10:10: error: ‘commandsResource’ was not declared in this scope
   10 |     if (!commandsResource.open(QIODevice::ReadOnly)) {
      |          ^~~~~~~~~~~~~~~~
modules/console/autocompletemodel.cpp:15:34: error: ‘commandsResource’ was not declared in this scope
   15 |     QByteArray commandsJsonRaw = commandsResource.readAll();
      |                                  ^~~~~~~~~~~~~~~~
modules/console/autocompletemodel.cpp: In member function ‘virtual int Console::AutocompleteModel::rowCount(const QModelIndex&) const’:
modules/console/autocompletemodel.cpp:50:61: warning: unused parameter ‘parent’ [-Wunused-parameter]
   50 | int Console::AutocompleteModel::rowCount(const QModelIndex &parent) const
      |                                          ~~~~~~~~~~~~~~~~~~~^~~~~~

ilovesusu commented on 2019-12-15 03:24

Switching Chinese has no effect, does it not include resources/translations/*. ts

versusvoid commented on 2019-11-18 06:34

Fails to build on python 3.8. Fixed by patching 3rdparty/pyotherside.pri:

-      QMAKE_LIBS += $$system($$PYTHON_CONFIG --ldflags --libs)
+      QMAKE_LIBS += $$system($$PYTHON_CONFIG --embed --ldflags --libs)

Also there is no need for python2 in makedeps, as script it runs is compaitable with python3.

crabvk commented on 2019-10-17 19:09

How to install Redis Desktop Manager:
https://github.com/uglide/RedisDesktopManager/blob/2019/docs/install.md#ubuntu--archlinux--debian--fedora--centos--opensuse--etc