Package Details: rebuild-detector 4.1.3-1

Git Clone URL: https://aur.archlinux.org/rebuild-detector.git (read-only, click to copy)
Package Base: rebuild-detector
Description: Detects which packages need to be rebuilt
Upstream URL: https://github.com/maximbaz/rebuild-detector
Licenses: MIT
Submitter: maximbaz
Maintainer: maximbaz
Last Packager: maximbaz
Votes: 11
Popularity: 1.05
First Submitted: 2018-08-11 16:48
Last Updated: 2020-04-04 18:32

Latest Comments

maximbaz commented on 2020-02-03 14:20

Indeed, thanks, fixed!

nl6720 commented on 2020-02-03 14:17

rebuild-detector 4.0.0 now uses pacconf from pacutils, but pacutils is not listed as a dependency.

maximbaz commented on 2019-11-28 10:23

What do you guys think about improving the detection quality at a significant performance cost? Opinions are very welcome: https://github.com/maximbaz/rebuild-detector/pull/6#issuecomment-559281889

maximbaz commented on 2019-11-24 23:30

You need to import my PGP key, e.g. gpg --recv-keys EB4F9E5A60D32232BB52150C12C87A28FEAC6B20

mdimitro commented on 2019-11-24 22:54

I can't seem to build, and am getting this PGP signature error instead:

==> Verifying source file signatures with gpg...
    rebuild-detector-2.2.0.tar.gz ... FAILED (unknown public key 011FDC52DA839335)
==> ERROR: One or more PGP signatures could not be verified!

maximbaz commented on 2019-10-16 13:44

Added -r flag, but unfortunately didn't manage to come up with ideas on how to make any perf improvements using sogrep :(

By the way, also added a link to Github repo, PRs are always welcome :)

bartus commented on 2019-10-15 06:09

You should add -r flag to ldd to resolve rare situation when library is present, but symbols are missing.

Example:

#yay build against pacman:5.1.3, but system has pacman-git installed.
ldd -r /usr/bin/yay|grep -P "(not found|libalpm|symbol)"
        libalpm.so.11 => /usr/lib/libalpm.so.11 (0x00007f8f1200f000)
undefined symbol: alpm_option_get_deltaratio    (/usr/bin/yay)
undefined symbol: alpm_option_set_deltaratio    (/usr/bin/yay)
undefined symbol: alpm_pkg_get_deltas   (/usr/bin/yay)
undefined symbol: alpm_sync_newversion  (/usr/bin/yay

Alad commented on 2019-08-03 22:13

Maybe sogrep could make this more performant?

https://github.com/archlinux/devtools/blob/master/sogrep

maximbaz commented on 2018-08-16 09:55

Thanks, fixed - also checking now if python is installed.

grawlinson commented on 2018-08-16 08:04

Requires parallel as a dependency.

$ checkrebuild
/bin/checkrebuild: line 14: parallel: command not found