Package Details: rcraid-dkms 17.2.1-2

Git Clone URL: https://aur.archlinux.org/rcraid-dkms.git (read-only, click to copy)
Package Base: rcraid-dkms
Description: AMD AM4 socket X370 chipset motherbroad NVMe/SATA RAID driver (DKMS)
Upstream URL: https://www.amd.com/en/support/chipsets/amd-socket-am4/x370
Licenses: GPL2
Submitter: jamesxu182
Maintainer: jamesxu182
Last Packager: jamesxu182
Votes: 2
Popularity: 0.000092
First Submitted: 2019-06-15 21:43
Last Updated: 2020-04-16 18:55

Latest Comments

1 2 Next › Last »

jamesxu182 commented on 2020-11-11 22:58

Hi @binarydepth, you need to place the zip file at the same directory as the PKGBUILD file. you can download the zip file (compression of source code) from amd official website from either https://www.amd.com/en/support/chipsets/amd-socket-am4/x370 or https://www.amd.com/en/support/chipsets/amd-socket-am4/b350. The same file can be downloaded from both links above. The original version of driver provided by AMD supported ubuntu 16.04 and redhat 7.3, whose kernel version is lower than v4.15. few patches are included to make it able to be compiled with the latest kernel (at this moment the version is v5.9.8) on Arch Linux. Just wanna kindly remind that the author is not responsible for any data losing via using this package. Thanks.

jamesxu182 commented on 2020-11-11 22:15

Hi @binarydepth, from the AMD official page, it seems support for B450, for more details see here: https://www.amd.com/en/support/chipsets/amd-socket-am4/x370

binarydepth commented on 2020-11-11 12:32

Will this work on B350?

FabioLolix commented on 2020-10-23 18:26

Hello, the right protocol for files that need to be downloaded manually is local://

binarydepth commented on 2020-10-03 17:44

And where do I put the zip file?

bebu commented on 2020-10-02 14:20

You have to download the file yourself.

binarydepth commented on 2020-10-02 12:51

I get errors building it with Linux 5.9

Building rcraid-dkms... ==> Making package: rcraid-dkms 17.2.1-2 (vie 02 oct 2020 08:36:29) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... ==> ERROR: Unknown download protocol: manual Aborting... Failed to build rcraid-dkms

jamesxu182 commented on 2020-04-15 23:22

Hi @FritzOnFire. Thanks for your support. I have merged your changes and it has support linux 5.6 kernel.

FritzOnFire commented on 2020-04-15 18:10

Sup! What do I have to do to get this commit on this repo?

https://github.com/FritzOnFire/rcraid-dkms-arch/commit/7fc66f00dccc81980eb0987bfce2b774e4d04fbb

I'll obviously make changes if someone finds something wrong with my code.

bebu commented on 2020-03-16 07:53

I could not see why this is outdated, but for most packaged kernels i use this patch, as the default makerule wants to build some stuff, which is not needed and most probably can not be build:

https://gist.github.com/bebu/0e3a2969edcb38d89d61eb8538a042a4