Package Details: rawstudio-git 2.0.r599.g574b1892-1

Git Clone URL: https://aur.archlinux.org/rawstudio-git.git (read-only)
Package Base: rawstudio-git
Description: An open-source program to read and manipulate RAW images from digital cameras (sergiomb2 fork)
Upstream URL: https://rawstudio.org
Licenses: GPL2
Conflicts: rawstudio
Provides: rawstudio
Submitter: haawda
Maintainer: caleb
Last Packager: caleb
Votes: 16
Popularity: 0.54
First Submitted: 2014-12-18 22:03
Last Updated: 2019-11-16 12:03

Latest Comments

1 2 Next › Last »

caleb commented on 2019-11-15 11:18

All users please note that this is now pointed at segriomb2's fork's devel branch as that is the only thing I know of that currently compiles!

haawda commented on 2015-02-24 18:51

Sounds reasonable, done.

lenzenmi commented on 2015-02-24 02:22

Could you please change the dependency fftw-mpi to fftw

* fftw is in the official repositories, and is used by many other packages, such as blender, luminancehdr, etc.

* rawstudio only requires fftw3f.so, which is included in the official fftw package.

* The PKGBUILD for fftw-mpi on the aur has not been updated, and is one version behind, requiring manual tweaking of the PKGBUILD to install the version that other oficial arch linux packages have been linked against.

Thanks.

lenzenmi commented on 2014-08-05 02:26

automake does not need to be limited to automake-1.12 anymore.

makedepends=('subversion' 'automake')

# use automake-1.12
# patch -p1 -i "$srcdir/autogen.patch"

Compiles fine for me.

rtfreedman commented on 2013-06-15 00:13

Added new dependency 'osm-gps-map', thanks for notifying.

lenzenmi commented on 2013-06-14 01:05

I had to add the 'osm-gps-map' package to the dependency list to get it to compile.

rtfreedman commented on 2013-04-23 05:27

Added some fixes - most notably made lensfun actually work and removed white space after line ending '\' in profiles/Makefile.am leaving out the rest of the camera profiles.

rtfreedman commented on 2013-04-10 16:07

Updated to pacman 4.1 & patched to use automake-1.12

crobe2 commented on 2013-03-23 13:28

I get those errors while trying to compile the package:

Use of uninitialized value $line in pattern match (m//) at /usr/bin/automake line 3893.
plugins/resample/Makefile.am:16: error: Libtool library used but 'LIBTOOL' is undefined
plugins/resample/Makefile.am:16: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
plugins/resample/Makefile.am:16: to 'configure.in' and run 'aclocal' and 'autoconf' again.
plugins/resample/Makefile.am:16: If 'LT_INIT' is in 'configure.in', make sure
plugins/resample/Makefile.am:16: its definition is in aclocal's search path.
plugins/rotate/Makefile.am:9: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
Use of uninitialized value $line in pattern match (m//) at /usr/bin/automake line 3893.
plugins/rotate/Makefile.am:16: error: Libtool library used but 'LIBTOOL' is undefined
plugins/rotate/Makefile.am:16: The usual way to define 'LIBTOOL' is to add 'LT_INIT'
plugins/rotate/Makefile.am:16: to 'configure.in' and run 'aclocal' and 'autoconf' again.
plugins/rotate/Makefile.am:16: If 'LT_INIT' is in 'configure.in', make sure
plugins/rotate/Makefile.am:16: its definition is in aclocal's search path.
profiles/Makefile.am:1022: warning: whitespace following trailing backslash
Use of uninitialized value $line in pattern match (m//) at /usr/bin/automake line 3893.
src/Makefile.am:3: warning: 'INCLUDES' is the old name for 'AM_CPPFLAGS' (or '*_CPPFLAGS')
Use of uninitialized value $line in pattern match (m//) at /usr/bin/automake line 3893.
Running autoconf ...
Running ./configure --enable-maintainer-mode --prefix=/usr ...
configure: WARNING: unrecognized options: --enable-maintainer-mode
./configure: line 2156: syntax error near unexpected token `rawstudio,'
./configure: line 2156: `AM_INIT_AUTOMAKE(rawstudio, 2.1)'

jwhendy commented on 2011-08-03 02:05

Is anyone maintaining this? The libgphoto2 error still isn't fixed since Feb. Can you update the PKGBUILD? Thanks.