Package Details: radium 5.9.83-1

Git Clone URL: https://aur.archlinux.org/radium.git (read-only, click to copy)
Package Base: radium
Description: A graphical music editor. A next generation tracker.
Upstream URL: https://users.notam02.no/~kjetism/radium
Licenses: GPL2
Submitter: speps
Maintainer: KenjiTakahashi (J5lx, Teteros)
Last Packager: Teteros
Votes: 12
Popularity: 0.22
First Submitted: 2013-05-22 03:41
Last Updated: 2019-11-28 11:48

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

J5lx commented on 2017-05-09 13:03

Yeah I use integrated graphics (Intel). I agree that it should not make a difference in theory, but if it does in fact happen I think it can be called a bug, be it in Radium, Mesa, LLVM or somewhere else entirely. It might be a good idea to consult somebody with a deeper understanding of the inner workings involved.

Teteros commented on 2017-05-09 11:53

Do you by any chance have a non-radeon card? When I removed 4.0 libs the radeon/mesa opengl driver stopped working, but radium could start, although it printed an error that opengl is not working which is right of course.

I was thinking of reporting it, but in theory only llvm39 should conflict with llvm, the libs packages are fine without the conflict array as they only provide the extra libs, rather than overriding anything.

Anyway the fix is merged already (!) and in upstream 4.8.0 release, check it out when you can.
EDIT: Merged in master but not in 4.8.0 yet.

J5lx commented on 2017-05-09 11:14

I still don’t quite get why that error occurs for you but not for me, even though I also have installed both 3.9 and 4.0, but if there is in fact some kind of incompatibility between those two versions of llvm-libs you might want to report a bug to the project (i.e. https://bugs.archlinux.org/) (I’d rather not report it myself because I can’t reproduce it and I still don’t really understand what happens). As for the patch, I don’t have the time/calm to review it properly right now so it’ll probably land in a few days or once it gets merged.

Teteros commented on 2017-05-09 03:11

TL;DR I patched radium's bundled faust to work with llvm 4.0, either grab the patch from here:
https://gist.github.com/Teteros/61dfd60f3d2a9216231b97630c0c2401
and add this to the PKGBUILD (and source array)
patch -d bin/packages/faust2 -p0 < "${srcdir}/0001-LLVM-4.0-support.patch"
or wait for my pull request to be merged:
https://github.com/kmatheussen/radium/pull/970

Got the time to track this down, it appears the crash happens when you have llvm-libs from repo installed, which is the 4.0 version, this occurs because llvm39-libs does not seem to conflict with it, so I ended up with llvm39 and llvm39-libs installed (which is intented) as well as llvm-libs (4.0) Of course, this should work as ldd on radium shows it correctly links to libLLVM-3.9.so lib, but for some reason it crashes for me with the 4.0 lib package installed.

I ended up patching radium's faust to work with llvm 4.0 as without it, some important libs like mesa would have to be recompiled to work with llvm39.

Teteros commented on 2017-04-29 08:44

Still occurs with your package build unfortunately. I'll snapshot my current partition, and do a fresh install to eliminate some linking or lingering cache/config from possibly interfering. Though you'd think a chrooted build would help if that was the case.

J5lx commented on 2017-04-29 08:09

Personally I don’t experience that at all. So weird! For now I uploaded my own build of the package at https://repo.j5lx.eu/.radium/, could you try installing it and see whether the error occurs with that build as well?

Teteros commented on 2017-04-29 06:38

Indeed 4.7.6 compiles without errors.
However after I installed the build package and try to run radium, this is the output.

$ radium
JUCE v4.2.4
INIT4
INIT5
Executing -LD_LIBRARY_PATH= /opt/radium/crashreporter L3RtcC9yYWRpdW0uSjEyNjY4 PG5vcGx1Z2lubmFtZXM+ PG5vZW1lcmdlbmN5c2F2ZT4= is_crash&-
QWidget: Must construct a QApplication before a QWidget

Official x64 build runs without this error.

J5lx commented on 2017-04-28 20:18

The commit you mentioned is part of 4.7.6, so I suppose their is nothing special left to do for me. That aside, the package builds perfectly fine for me, both 4.7.4 and 4.7.6, so I’m a little curious as to what exactly you are referring to.

Teteros commented on 2017-04-27 21:15

New master: https://github.com/kmatheussen/radium/commit/6078496bfd480e882a879d49b1f9fb9d7e9b770b

Allows it to build now, but I am getting "QWidget: Must construct a QApplication before a QWidget" on runtime with it, and 4.7.4

Teteros commented on 2017-04-11 20:58

You're right, on investigation: the extra files present in /opt/radium are actually the ones radium creates when it's able to at runtime (the 'warning' file import_midi/mod, python stuff, logs, autosaves...)
Making whole .install file redundant, unless used for documenting.