Package Details: raccoon 4.11.0-1

Git Clone URL: https://aur.archlinux.org/raccoon.git (read-only)
Package Base: raccoon
Description: Alternative Google Play (with GUI) client to download Android APK files to your computer
Upstream URL: https://raccoon.onyxbits.de/
Licenses: Apache
Submitter: si_kabayan
Maintainer: fordprefect
Last Packager: fordprefect
Votes: 49
Popularity: 0.95
First Submitted: 2014-11-04 21:18
Last Updated: 2019-10-22 09:41

Pinned Comments

fordprefect commented on 2019-03-07 11:59

This package builds the raccoon software from source. Since the mainainer is in the process of abandoning Github (see [0] for reasons) and the sources are not available otherwise yet, this package will sit at the last released version published on Github, until new sources are available. If you wish to use the more recent versions of the program instead of waiting for the sources to be released, you can use raccoon-bin [1] as a workaround for now.

Please don't flag this package out-of-date, unless new source versions are available. Thank you for your understanding.

[0] https://blog.onyxbits.de/so-long-github-and-thanks-for-all-the-fish-746/

[1] https://aur.archlinux.org/packages/raccoon-bin/

Latest Comments

1 2 3 4 5 Next › Last »

di72nn commented on 2019-10-01 19:31

sed -i "s/targetCompatibility = 1.7//g" build.gradle can be removed now - it was fixed in the upstream

fordprefect commented on 2019-03-07 11:59

This package builds the raccoon software from source. Since the mainainer is in the process of abandoning Github (see [0] for reasons) and the sources are not available otherwise yet, this package will sit at the last released version published on Github, until new sources are available. If you wish to use the more recent versions of the program instead of waiting for the sources to be released, you can use raccoon-bin [1] as a workaround for now.

Please don't flag this package out-of-date, unless new source versions are available. Thank you for your understanding.

[0] https://blog.onyxbits.de/so-long-github-and-thanks-for-all-the-fish-746/

[1] https://aur.archlinux.org/packages/raccoon-bin/

simona commented on 2018-11-29 23:10

now ok. thanks :-)

fordprefect commented on 2018-11-25 08:28

should be fixed.

simona commented on 2018-11-23 20:38

do not compile...

di72nn commented on 2018-10-14 15:12

Hey!

Removing targetCompatibility parameter solves the problem of building with Java 8. The parameter is not needed unless you need the resulting binaries to run on Java 7.

Here's updated build-on-linux.patch https://gist.github.com/di72nn/f3d3efd7963cc7daae68c2f8d51f76ec

fordprefect commented on 2018-09-20 15:18

@gio: please familiarize yourself with makepkg instead of promoting AUR helpers here. Also, please have a close look at the error output. It clearly states, that your java version does not mach the required version (1.8). So, please fix your java version and refer to the solution posted below.

Gio commented on 2018-09-20 14:03

Hi.

I'm too getting this error while trying to build this package / during Pamac installation:

"> Task :compileJava FAILED javacTask: source release 1.8 requires target release 1.8

FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ':compileJava'.

    Compilation failed; see the compiler error output for details.

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 0s 1 actionable task: 1 executed ==> ERROR: A failure occurred in build(). Aborting... "

Thank You.

Earl_Nick commented on 2018-09-04 17:21

Changing the default Java environment to Java 7 solved the problem, at least for me (https://wiki.archlinux.org/index.php/java#Switching_between_JVM):

sudo pacman -S jdk7-openjdk
sudo archlinux-java set java-7-openjdk

I got this idea from the developers website, where he states that the minimum system required from now on is Java 7: https://raccoon.onyxbits.de/releases (Anyway, I had Java 8 before, which should have worked to, but obviously didn't...)

sergey.orloff commented on 2018-08-19 15:55

==> Запускается build()... Starting a Gradle Daemon (subsequent builds will be faster)

Task :compileJava FAILED javacTask: source release 1.8 requires target release 1.8

FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ':compileJava'.

    Compilation failed; see the compiler error output for details.

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

BUILD FAILED in 7s 1 actionable task: 1 executed ==> ОШИБКА: Произошел сбой в build(). Прерывание...