Package Details: r-mkl 3.6.2-1

Git Clone URL: https://aur.archlinux.org/r-mkl.git (read-only, click to copy)
Package Base: r-mkl
Description: Language and environment for statistical computing and graphics, linked to the Intel(R) MKL.
Upstream URL: http://www.r-project.org/
Keywords: hpc mathematics modelling r statistics
Licenses: GPL
Conflicts: microsoft-r-open, r
Provides: r=3.6.2
Submitter: giniu
Maintainer: alexanderp
Last Packager: alexanderp
Votes: 19
Popularity: 0.195282
First Submitted: 2010-05-06 00:10
Last Updated: 2020-01-07 12:22

Dependencies (26)

Required by (265)

Sources (4)

Latest Comments

« First ‹ Previous ... 2 3 4 5 6 7 8 9 10 11 12 ... Next › Last »

pat-s commented on 2018-03-11 22:46

I was able to get it building by commenting out the "check" section of the PKGBUILD:

check() { cd R-${pkgver} make check-recommended }

pat-s commented on 2018-03-11 22:40

@alexanderp I am also stuck at the same issue as @jbmorgado. Its stuck running the test script of the "Matrix" package called "Simple.R". Building with gcc. Its the default anyways in the current PKGBUILD.

alexanderp commented on 2018-02-17 10:47

@jbmorgado, make sure you're compiling with gcc and not with icc, i.e. the _CC="icc" line should be commented out. Unfortunately, R seems to be incompatible with recent releases of the Intel compilers.

jbmorgado commented on 2018-02-10 11:29

Can't compile this.

Gets stuck for hours during compilation at: "Running ‘Simple.R’"

mys_721tx commented on 2017-11-16 17:29

icc 18.0.1 is out, it should fix the gcc 7.0 compatibility issue

https://software.intel.com/en-us/forums/intel-c-compiler/topic/742701

alexanderp commented on 2017-04-24 18:40

Yes, compilation was fixed with my last update on 2017-03-06.

gergi commented on 2017-04-24 07:29

Compiles again smoothly.

zlib issue got fixed in
https://stat.ethz.ch/pipermail/r-help//2017-January/444162.html

alexanderp commented on 2017-02-16 17:07

That's a general problem with zlib.
Even vanilla R from the repositories doesn't compile.

adalardo commented on 2017-02-14 11:43

Same here

checking if zlib version >= 1.2.5... no
checking whether zlib support suffices... configure: error: zlib library and headers are required

The zlib version installed is 1:1.2.11. I believe the problem is "1:" before official version name.

gergi commented on 2017-02-07 15:11

Build fails on

checking if zlib version >= 1.2.5... no
checking whether zlib support suffices... configure: error: zlib library and headers are required