Package Details: qv2ray 2.6.2-3

Git Clone URL: https://aur.archlinux.org/qv2ray.git (read-only, click to copy)
Package Base: qv2ray
Description: Cross-platform V2ray Client written in Qt (Stable Release)
Upstream URL: https://github.com/Qv2ray/Qv2ray
Keywords: gui qt qv2ray v2ray
Licenses: GPL3
Conflicts: qv2ray
Provides: qv2ray
Submitter: Hork
Maintainer: DuckSoft (Neboer, axionl)
Last Packager: DuckSoft
Votes: 7
Popularity: 0.87
First Submitted: 2019-08-28 13:38
Last Updated: 2020-09-04 16:09

Latest Comments

DuckSoft commented on 2020-02-06 13:52

Hi @craeckie, that's fixed now. Feel free to rebuild.

craeckie commented on 2020-02-06 13:10

Hi, I'm getting an error when building:

==> Making package: qv2ray 2.0.1-1 (Thu 06 Feb 2020 02:07:08 PM CET)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Cloning Qv2ray-2.0.1 git repo...
Cloning into bare repository '/var/cache/private/pikaur/build/qv2ray/Qv2ray-2.0.1'...
remote: Enumerating objects: 52, done.
remote: Counting objects: 100% (52/52), done.
remote: Compressing objects: 100% (39/39), done.
remote: Total 8430 (delta 18), reused 26 (delta 8), pack-reused 8378
Receiving objects: 100% (8430/8430), 23.63 MiB | 10.44 MiB/s, done.
Resolving deltas: 100% (5415/5415), done.
==> Validating source files with sha512sums...
    Qv2ray-2.0.1 ... Skipped
==> Extracting sources...
  -> Creating working copy of Qv2ray-2.0.1 git repo...
Cloning into 'Qv2ray-2.0.1'...
done.
Switched to a new branch 'makepkg'
==> Starting prepare()...
Submodule '3rdparty/QNodeEditor' (<https://github.com/lhy0403/QNodeEditor>) registered for path '3rdparty/QNodeEditor'
Submodule '3rdparty/SingleApplication' (<https://github.com/itay-grudev/SingleApplication>) registered for path '3rdparty/SingleApplication'
Submodule '3rdparty/qhttpserver' (<https://github.com/nikhilm/qhttpserver>) registered for path '3rdparty/qhttpserver'
Submodule '3rdparty/qzxing' (<https://github.com/ftylitak/qzxing>) registered for path '3rdparty/qzxing'
Submodule '3rdparty/x2struct' (<https://github.com/xyz347/x2struct>) registered for path '3rdparty/x2struct'
Submodule 'libs/gRPC-win32' (<https://github.com/Qv2ray/gRPC-Windows-Packages>) registered for path 'libs/gRPC-win32'
Submodule 'libs/libqvb' (<https://github.com/Qv2ray/QvRPCBridge>) registered for path 'libs/libqvb'
Cloning into '/var/cache/private/pikaur/build/qv2ray/src/Qv2ray-2.0.1/3rdparty/QNodeEditor'...
Cloning into '/var/cache/private/pikaur/build/qv2ray/src/Qv2ray-2.0.1/3rdparty/SingleApplication'...
Cloning into '/var/cache/private/pikaur/build/qv2ray/src/Qv2ray-2.0.1/3rdparty/qhttpserver'...
Cloning into '/var/cache/private/pikaur/build/qv2ray/src/Qv2ray-2.0.1/3rdparty/qzxing'...
Cloning into '/var/cache/private/pikaur/build/qv2ray/src/Qv2ray-2.0.1/3rdparty/x2struct'...
Submodule path '3rdparty/QNodeEditor': checked out '3db755eb5e4aaf1b21bb958a0a635fd13ce37c97'
Submodule path '3rdparty/SingleApplication': checked out '3d152b03d872b99d7f36e8463ac253e41194a17a'
Submodule path '3rdparty/qhttpserver': checked out '02a6e7174b5be76e2c0e74a109817e39a141b9fd'
Submodule path '3rdparty/qzxing': checked out '2a58c5032b2180f2cce95e1db106cbaa4ecaed02'
Submodule path '3rdparty/x2struct': checked out '09d790b83155336acb73730ac241fdc4256a85bd'
==> Starting pkgver()...
==> Starting build()...
Info: creating stash file /var/cache/private/pikaur/build/qv2ray/src/Qv2ray-2.0.1/build/.qmake.stash
Project MESSAGE: Qv2ray installation PREFIX=/usr
Project MESSAGE:  
Project MESSAGE: Qv2ray Version: 2.0.1.3100
Project MESSAGE: |-------------------------------------------------|
Project MESSAGE: | Qv2ray, A Cross Platform v2ray Qt GUI Client.   |
Project MESSAGE: | Licenced under GPLv3                            |
Project MESSAGE: |                                                 |
Project MESSAGE: | You may only use this program to the extent     |
Project MESSAGE: | permitted by local law.                         |
Project MESSAGE: |                                                 |
Project MESSAGE: | See: <https://www.gnu.org/licenses/gpl-3.0.html>  |
Project MESSAGE: |-------------------------------------------------|
Project MESSAGE:  
Project MESSAGE: Qv2ray will use libgRPC as API backend
Project MESSAGE:  
Project MESSAGE: -----------------------------------------------
Project MESSAGE: Cannot continue: 
Project MESSAGE:   --> Qv2ray is not properly configured yet: 
Project MESSAGE:       gRPC and protobuf headers for v2ray API is missing.
Project MESSAGE:   --> Please run gen_grpc.sh gen_grpc.bat or deps_macOS.sh located in tools/
Project MESSAGE:   --> Or consider reading the build wiki: <https://github.com/lhy0403/Qv2ray/wiki/Manually-Build-Qv2ray>
Project MESSAGE: -----------------------------------------------
Project MESSAGE:  
Project WARNING: IF YOU THINK IT'S A MISTAKE, PLEASE OPEN AN ISSUE
Project ERROR: ! ABORTING THE BUILD !
==> ERROR: A failure occurred in build().
    Aborting...
Finished with result: exit-code
Main processes terminated with: code=exited/status=4
Service runtime: 19.150s