Package Details: qutebrowser-git 2.0.0.r2.gd3b8b525b-1

Git Clone URL: https://aur.archlinux.org/qutebrowser-git.git (read-only, click to copy)
Package Base: qutebrowser-git
Description: A keyboard-driven, vim-like browser based on PyQt5
Upstream URL: https://www.qutebrowser.org/
Keywords: browser web webkit
Licenses: GPL
Conflicts: qutebrowser
Provides: qutebrowser
Submitter: The-Compiler
Maintainer: The-Compiler
Last Packager: The-Compiler
Votes: 81
Popularity: 0.35
First Submitted: 2014-11-11 21:47
Last Updated: 2021-01-28 08:41

Dependencies (18)

Required by (1)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3

hero commented on 2017-02-17 07:43

I second lucc's request to change the pkgver(). From https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git you can see, that it is recommended to use the following for packages with tags:
pkgver() {
cd "$pkgname"
# cutting off 'v' prefix that presents in the git tag
git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
This provides something in the likes of 0.9.0.r277.g79d22f250

I have not tested, if it demands to increment the pkgrel.

lucc commented on 2017-02-07 09:06

Could you use "git describe" in pkgver(). It has the advantage to include tag names into the output and hence the version number of aur/qutebrowser-git would better compare to the one of commuinty/qutebrowser.

For comparison, I get these kinds of version strings from other packages (pacman -Q|grep -e '-git '):
afew-git 1:0.242.b19a88f-1
i3pystatus-git 3.35.r179.g82555cb-1
mblaze-git r486.113445d-1
qutebrowser-git r11145.e487fe441-1
texlive-localmanager-git 0.5.1.r0.g6befd1e-1
vimpager-git 2.06.r337.ga7d18ce-1
zsh-history-substring-search-git 1:117.aae3388-1

It also seems that you would not even have to update (use) the epoch of the package as pacsort is happy to consider the new format I imagine a newer version. I tried this by updating the pkgver() like this (and some other variants):
pkgver() {
cd "$srcdir/qutebrowser"
local ver=$(git describe)
ver=${ver#v}
ver=${ver/-/.r}
ver=${ver/-g/.}
printf %s "$ver"
}
then executed makepkg and finally ask pacsort what it considers the newest version:
$ ls qute*xz|pacsort
qutebrowser-git-r11138.52e386536-1-any.pkg.tar.xz
qutebrowser-git-r11145.e487fe441-1-any.pkg.tar.xz
qutebrowser-git-0.9.0.r183e487fe441-1-any.pkg.tar.xz
qutebrowser-git-0.9.0.r183.e487fe441-1-any.pkg.tar.xz
qutebrowser-git-0.9.0.183.ge487fe441-1-any.pkg.tar.xz

(Please note that the 0.9.0 is due to issue #2284.)

Ambrevar commented on 2017-02-06 12:29

Currently it is not possible to use qutebrowser with the qt5-webkit-ng package because of the versioned dependency of qt5-webkit, forcing users to use the old
insecure qt5-webkit package. Please remove the version from the dependency: qt5-webkit provides "qt5-webkit" as well.

shioyama commented on 2017-02-04 23:51

Please switch to the new official repository: https://github.com/qutebrowser/qutebrowser

lucc commented on 2017-02-02 09:47

Could you also install some things from the misc folder? Especially the userscripts, maybe to /usr/share/qutebrowser/userscripts. And maybe also the cheatsheet to some docs folder. I don't know if any of the other files would be interesting.

The-Compiler commented on 2016-06-07 07:31

@ainola Thanks for the heads-up, done!

ainola commented on 2016-06-07 03:38

Hi, The-Compiler! Pacman now automatically performs post-install hooks so you can safely remove the .install file entirely.

cyberpsych0sis commented on 2014-11-11 22:55

Should I be getting this after tar?:

====================================
$ tar -xvf qutebrowser-git.tar.gz
qutebrowser-git/
qutebrowser-git/.AURINFO
tar: qutebrowser-git/.AURINFO: time stamp 2014-11-11 16:46:26 is 82896.321678161 s in the future
qutebrowser-git/PKGBUILD
tar: qutebrowser-git/PKGBUILD: time stamp 2014-11-11 16:45:57 is 82867.321400849 s in the future
tar: qutebrowser-git: time stamp 2014-11-11 16:46:26 is 82896.321333557 s in the future