Package Details: qubes-vm-pulseaudio 4.0.27-4

Git Clone URL: https://aur.archlinux.org/qubes-gui-agent-linux.git (read-only, click to copy)
Package Base: qubes-gui-agent-linux
Description: Pulseaudio support for Qubes VM
Upstream URL: https://github.com/QubesOS/qubes-gui-agent-linux
Keywords: agent gui pulseaudio qubes qubesos vm
Licenses: GPL
Submitter: seberm
Maintainer: seberm
Last Packager: seberm
Votes: 1
Popularity: 0.096043
First Submitted: 2020-01-25 20:32
Last Updated: 2020-04-04 16:39

Latest Comments

seberm commented on 2020-02-16 14:07

Hello, I have downgraded the qubes-gui-agent-linux (qubes-vm-gui and qubes-vm-pulseaudio packages) to v4.0.27.

For now I will keep other qubes-* packages [0] in their current versions because they seem to work without any issues also on Qubes 4.0.

From now on I will try to test the packages more carefully.

[0] https://aur.archlinux.org/packages/?O=0&SeB=nd&K=qubes-&outdated=&SB=n&SO=a&PP=50&do_Search=Go

Ota

ghostinthefiber commented on 2020-02-01 12:39

Hey Ota don't worry about it, I actually really appreciate that you have done all this work to put these on here. :)

Yes I have been able to solve this by down grading this package. All the other aur packages for Qubes 4.1 seem to be working without any issues on 4.0 so that very nice!

For me, from a usability standpoint I think that having the 4.0 packages in aur would be nice as it is the current stable version of Qubes. I however think it is also good to have the packages for 4.1 ready as it seems that 4.1 will come out sooner then later. I have not tried to install Qubes 4.1 yet therefore don't know the state that it is in.

Again thanks for putting in the work to add these packages.

seberm commented on 2020-01-31 15:09

Hello, I am really sorry that you found out the hard way. I was tired of rebuilding arch template again and again and I also wanted to have newer version of some packages on my system. That's why I created these [0] packages.

But I am still in progress of getting them ready and there can be some issues.

I know about the issue you described, I found it the hard way too :). I solved it by (locally) rebuilding and downgrading package to v4.0.27 [1].

I should probably downgrade all of the qubes- packages [0] to their stable v4.0. versions and if anybody wants to, one can always locally build newer version. Any ideas?

[0] https://aur.archlinux.org/packages/?O=0&K=qubes [1] https://github.com/QubesOS/qubes-gui-agent-linux/releases/tag/v4.0.27

Ota

ghostinthefiber commented on 2020-01-31 08:09

Hey thanks for getting these packages into aur. I however am having a problem when I update qubes-vm-gui using the aur package. It seems like 4.1.5 is meant for qubes version 4.1. When I run it on qubes 4.0 the arch vm runs fine but no apps are able to open. There is a mailing list about this here (https://groups.google.com/forum/#!topic/qubes-users/fPQ2FaZQvt0). Do you believe that there is a way to download and install the correct version for the right version of qubes in this package?