Package Details: quassel-core-small 0.13.1-8

Git Clone URL: https://aur.archlinux.org/quassel-core-small.git (read-only, click to copy)
Package Base: quassel-core-small
Description: Next-generation distributed IRC client - core only, minimal dependencies
Upstream URL: https://quassel-irc.org/
Licenses: GPL
Conflicts: quassel-core
Provides: quassel-core
Submitter: buzo
Maintainer: buzo
Last Packager: buzo
Votes: 18
Popularity: 0.001884
First Submitted: 2018-12-20 16:45
Last Updated: 2019-11-07 20:12

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

buzo commented on 2018-08-05 11:59

Does not build. Line 58 of PKGBUILD is missing a «\».

buzo commented on 2018-03-16 09:19

This package needs to conflict with and provide at least quassel-core, and maybe other quassel packages, too. Otherwise switching from the regular package to this one and vice versa does not work correctly.

cyrevolt commented on 2016-05-02 09:07

You need qt5-script in order to build. It is deprecated according to http://doc.qt.io/qt-5/qtmodules.html though, so I assume the Quassel developers will migrate at some point. :)

```
-- The following REQUIRED packages have not been found:

* Qt5Script , provides scripting support for Qt5
```

Wabuo commented on 2016-01-25 05:10

I put some comands in to the prepare() funktion for debugging.
Here is what i got:

pwd in _pkgbase
/tmp/makepkg/quassel-light/src/quassel-0.12.2
tree in ../../ | grep patch
├── fix_qt5.5_build.patch -> /tmp/yaourt-tmp-user/aur-quassel-core-light/fix_qt5.5_build.patch
├── fix_ssl_check.patch -> /tmp/yaourt-tmp-user/aur-quassel-core-light/fix_ssl_check.patch
│   │   ├── quassel.pot.patch

So for me the symlinks to the patch files are placed in .../src is that normal?

Wabuo commented on 2016-01-25 04:36

Well mine has ... Will lock in to it.

trollixx commented on 2016-01-25 04:03

I am not sure what the issue is, but the patch is there: https://aur.archlinux.org/cgit/aur.git/tree/fix_ssl_check.patch?h=quassel-light

yaourt has no issues with downloading it.

Wabuo commented on 2016-01-25 03:58

Wont build quits wit:
patch: **** Can't open patch file ../../fix_ssl_check.patch : No such file or directory

trollixx commented on 2015-11-30 02:01

qt5-script is a dependency already, see [1] and [2].

1. https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=quassel-light#n89
2. https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=quassel-light#n119

dgerbaudo commented on 2015-11-09 12:49

I tried it again.

-Qca-qt5 is optional (for encryption)

-The only one required, like you said is: qt5-script.
If quassel-core-light and quassel-monolithic-light depend on qt5-script, I think it would be best to add it to depends in PKGBUILD.
It doesn't compile without it.

-I don't remember why I've installed qt5-tools. It's not required.

trollixx commented on 2015-11-07 06:28

qca-qt5: It is an optional dependency, and this quassel-*-light aims to keep number of dependencies as low as possible. Not sure whether we to always depend on QCA.

qt5-script: quassel-core-light and quassel-monolithic-light do depend on qt5-script, so it should be installed, usually an AUR managemnt tool (like yaourt) takes care about installation of required packages.

qt5-tools: No idea why is it needed, it should build properly anyway. @dgerbaudo?