Package Details: qtwebkit 2.3.4-7

Git Clone URL: https://aur.archlinux.org/qtwebkit.git (read-only)
Package Base: qtwebkit
Description: An open source web browser engine (Qt port)
Upstream URL: http://trac.webkit.org/wiki/QtWebKit
Licenses: GPL3, LGPL2.1
Conflicts: qt<4.8
Submitter: arojas
Maintainer: fbrennan
Last Packager: FredBezies
Votes: 54
Popularity: 0.195023
First Submitted: 2017-02-09 07:52
Last Updated: 2018-07-07 22:15

Sources (6)

Pinned Comments

FredBezies commented on 2018-02-05 17:10

@alban : so just use qtwebkit-bin package.

By the way, last time I build this package successfully? January 15th, 2018.

fred@fredo-arch ~ % pacman -Qi qtwebkit

name : qtwebkit

Version : 2.3.4-6

Description : An open source web browser engine (Qt port)

Architecture : x86_64

URL : http://trac.webkit.org/wiki/QtWebKit

Licenses : LGPL2.1 GPL3

Groups : None

Provides : None

Depends On : qt4 systemd gst-plugins-base-libs

Optional Deps : None

Required By : google-musicmanager

Optional For : None

Conflicts With : qt<4.8

Replaces : None

Installed Size : 35.26 MiB

Packager : Unknown Packager

Build Date : Mon Jan 15 10:41:57 2018

Install Date : Mon Jan 15 10:47:06 2018

Install Reason : Explicitly installed

Install Script : No

Validated By : None

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

severach commented on 2017-06-11 17:20

The hard way is to follow the clean chroot instructions on the wiki. The easy way is to install Graysky's clean-chroot-manager and let it do all the heavy lifting.

bigdaddy commented on 2017-06-11 12:21

Is there any fix currently so that the package can be built (semi-)manually?

I am new to linux and therefore unable to decipher the suggestions given below (i.e. building in a clean chroot etc.).
Sorry for that but I would really appreciate if there was somebody explaining how to get this thing to build.
Thanks in advance for that.

Also why does yaourt tell that this is out of date?

jmsq commented on 2017-06-06 02:34

This package currently fails to build.

Scimmia commented on 2017-06-05 01:35

JohnRobson, what does WebKitGTK have to do with QtWebKit?

JohnRobson commented on 2017-06-05 00:18

Sorry, but last release is 2.17.3, why here is 2.3.4 ?
https://trac.webkit.org/browser/webkit/releases/WebKitGTK?desc=1

sheinz commented on 2017-06-03 13:27

@miltador
qtwebkit: https://drive.google.com/open?id=0B_SA88lTBldUaXhWQ05SY0g0TDg

You might also want vtk-qt4 if you are building FreeCAD
vtk-qt4: https://drive.google.com/open?id=0B_SA88lTBldUdHVyQWhIaGczVm8

miltador commented on 2017-06-02 18:40

Can someone provide a binary (compiled) version of this package?
It is building only in chroot and takes 2-4 hours...
Thanks.

sheinz commented on 2017-06-01 22:27

@Ulin
I also had build errors but building in a clean chroot was actually successful.
And the same behavior on both my arch machines.
Try setting up a chroot and build in it as @WoefulDerelict suggested.

Ulin commented on 2017-06-01 17:57

pp:54:
/usr/include/unicode/umachine.h: На глобальном уровне:
/usr/include/unicode/umachine.h:347:22: ошибка: conflicting declaration «typedef char16_t UChar»
typedef char16_t UChar;
^~~~~

ZeroBit commented on 2017-05-31 07:25

@WoefulDerelict
I tried again with "extra-x86_64-build -c makechrootpkg -c -r $CHROOT" and it worked. Thank you!