Package Details: qtile-git 3444.458c4875-2

Git Clone URL: https://aur.archlinux.org/qtile-git.git (read-only, click to copy)
Package Base: qtile-git
Description: A full-featured, pure-Python tiling window manager. (git version)
Upstream URL: http://www.qtile.org
Licenses: MIT
Conflicts: qtile
Provides: qtile
Submitter: Mr.Elendig
Maintainer: RogerDuran (dequis)
Last Packager: dequis
Votes: 65
Popularity: 0.51
First Submitted: 2008-09-23 19:38
Last Updated: 2020-04-26 11:56

Dependencies (7)

Required by (4)

Sources (1)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

dvzrv commented on 2021-07-19 11:25

@RogerDuran/@dequis: While at it, please also review the Python package guidelines and the VCS guidelines:

dvzrv commented on 2021-07-19 10:40

@RogerDuran/@dequis: Please have a look at the Arch package guidelines (specifically the package etiquette):

  • All occurences of $srcdir and $pkgdir have to be quoted
  • Avoid using makepkg subroutines (e.g. msg): use printf or echo instead (or remove altogether, as install -v is sufficiently verbose)

Please also update the relevant depends, makedepends, checkdepends and optdepends (see community/qtile for further info).

Thanks!

mcol commented on 2021-06-27 21:45

In addition to python-dbus-next, python-xcffib is now an optional dependency (for X11 backend), as are python-xkbcommon, pywayland and pywroots (for Wayland backend).

elParaguayo commented on 2021-02-25 21:31

Qtile now has python-dbus-next as an optional dependency for interaction with dbus (replacing python-dbus).

FalconProgrammer commented on 2021-02-15 08:45

The Memory widget requires the psutil python module (or the python-psutil community package). Could this be added as a dependency?

Granitosaurus commented on 2020-04-19 04:03

Can we update this to use python3 instead of python2? Python2 is dead and there's no reason to not use python3 here since qtile fully supports it.

tjackson commented on 2017-08-20 23:11

Hi there. If xcb-util-cursor isn't installed then the bar doesn't respect your cursor preferences.

kynikos commented on 2015-12-06 11:17

python-setuptools doesn't seem necessary only for building, but also for running (try to uninstall it and restart qtile), I think it should be moved to depends.

lybin commented on 2015-10-02 13:09

@RogerDuran, qtile doesn't works after upgrading python to 3.5. Increase the release please, it need to rebuild qtile.

lybin commented on 2015-08-08 12:52

@RogerDuran, can you to add, please, everywhere:
optdepends=(
'python-setproctitle: change the process name to qtile'
'xcb-util-cursor: show the activity in desktop to qtile'
'python-gobject: widget, notify'
'python-dbus: widget, notify'
'python-wifi: widget, wlan'
)