Package Details: qtcreator-git v4.9.1.r864.g611e1ea837-1

Git Clone URL: https://aur.archlinux.org/qtcreator-git.git (read-only)
Package Base: qtcreator-git
Description: Lightweight, cross-platform integrated development environment
Upstream URL: https://www.qt.io
Licenses: LGPL
Conflicts: qbs, qtcreator
Provides: qbs, qtcreator
Submitter: delor
Maintainer: rodrigo21 (hunger)
Last Packager: rodrigo21
Votes: 31
Popularity: 0.115949
First Submitted: 2009-04-12 14:35
Last Updated: 2019-06-06 12:33

Dependencies (23)

Required by (32)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6

Anonymous comment on 2012-11-27 01:37

I'm having an issue building this on an x86_64 system. Here is the relevant error while compiling:
../../../qt-creator/src/shared/qtsingleapplication/qtsingleapplication.h:43:49: error: 'Type' has not been declared
../../../qt-creator/src/shared/qtsingleapplication/qtsingleapplication.cpp:63:66: error: 'Type' has not been declared

hunger commented on 2011-11-05 23:00

You might want to restrict the dependency to qt>=4.7.4 if possible.

I already mentioned that the URL is wrong.

You might also do a make docs to generate the manual for Qt Creator. That should spare you the need to touch the qch file and to create its directory, faking the existence of the manual.

You might want to consider adding valgrind as an optional dependency for the analyzer plugin, as well as bzr, git, cvs, subversion, mercurial or perforce for version control.

hunger commented on 2011-11-02 17:38

Where did you get the url given above? It is completely wrong: http://qt-project.org/ is the best point to.

Bkmz commented on 2011-06-30 05:43

Maybe, you should to add valgrind to dependence, or additional dependencies!?

delor commented on 2011-06-13 17:34

@maleadt: I'll look into it at weekend.

maleadt commented on 2011-06-12 14:55

You might want to makedepend on qt-private-headers, it is needed to build the qml designer.