Package Details: qtcreator-git v4.9.1.r864.g611e1ea837-1

Git Clone URL: https://aur.archlinux.org/qtcreator-git.git (read-only)
Package Base: qtcreator-git
Description: Lightweight, cross-platform integrated development environment
Upstream URL: https://www.qt.io
Licenses: LGPL
Conflicts: qbs, qtcreator
Provides: qbs, qtcreator
Submitter: delor
Maintainer: rodrigo21 (hunger)
Last Packager: rodrigo21
Votes: 31
Popularity: 0.110610
First Submitted: 2009-04-12 14:35
Last Updated: 2019-06-06 12:33

Dependencies (23)

Required by (32)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

rodrigo21 commented on 2014-07-19 21:35

It's building here with a clean chroot.

Anonymous comment on 2014-07-19 19:31

g++ -Wl,-O1,--sort-common,--as-needed,-z,relro -Wl,-z,origin '-Wl,-rpath,$ORIGIN:$ORIGIN/..:$ORIGIN/../lib/qtcreator' -Wl,-O1 -Wl,-rpath-link,/usr/lib -o ../../../../bin/qmlpuppet .obj/release-shared/nodeinstanceclientproxy.o .obj/release-shared/qt4nodeinstanceserver.o .obj/release-shared/qt4nodeinstanceclientproxy.o .obj/release-shared/qt4informationnodeinstanceserver.o .obj/release-shared/qt4rendernodeinstanceserver.o .obj/release-shared/qt4previewnodeinstanceserver.o .obj/release-shared/graphicsobjectnodeinstance.o .obj/release-shared/qmlgraphicsitemnodeinstance.o .obj/release-shared/positionernodeinstance.o .obj/release-shared/behaviornodeinstance.o .obj/release-shared/dummycontextobject.o .obj/release-shared/childrenchangeeventfilter.o .obj/release-shared/componentnodeinstance.o .obj/release-shared/dummynodeinstance.o .obj/release-shared/nodeinstancemetaobject.o .obj/release-shared/nodeinstanceserver.o .obj/release-shared/nodeinstancesignalspy.o .obj/release-shared/objectnodeinstance.o .obj/release-shared/qmlpropertychangesnodeinstance.o .obj/release-shared/qmlstatenodeinstance.o .obj/release-shared/qmltransitionnodeinstance.o .obj/release-shared/servernodeinstance.o .obj/release-shared/anchorchangesnodeinstance.o .obj/release-shared/synchronizecommand.o .obj/release-shared/debugoutputcommand.o .obj/release-shared/endpuppetcommand.o .obj/release-shared/tokencommand.o .obj/release-shared/componentcompletedcommand.o .obj/release-shared/completecomponentcommand.o .obj/release-shared/statepreviewimagechangedcommand.o .obj/release-shared/childrenchangedcommand.o .obj/release-shared/changebindingscommand.o .obj/release-shared/changefileurlcommand.o .obj/release-shared/changeidscommand.o .obj/release-shared/changenodesourcecommand.o .obj/release-shared/changestatecommand.o .obj/release-shared/changevaluescommand.o .obj/release-shared/informationchangedcommand.o .obj/release-shared/removeinstancescommand.o .obj/release-shared/removepropertiescommand.o .obj/release-shared/reparentinstancescommand.o .obj/release-shared/valueschangedcommand.o .obj/release-shared/clearscenecommand.o .obj/release-shared/createinstancescommand.o .obj/release-shared/createscenecommand.o .obj/release-shared/pixmapchangedcommand.o .obj/release-shared/changeauxiliarycommand.o .obj/release-shared/removesharedmemorycommand.o .obj/release-shared/puppetalivecommand.o .obj/release-shared/addimportcontainer.o .obj/release-shared/imagecontainer.o .obj/release-shared/idcontainer.o .obj/release-shared/informationcontainer.o .obj/release-shared/instancecontainer.o .obj/release-shared/reparentcontainer.o .obj/release-shared/propertyabstractcontainer.o .obj/release-shared/propertybindingcontainer.o .obj/release-shared/propertyvaluecontainer.o .obj/release-shared/nodeinstanceserverinterface.o .obj/release-shared/enumeration.o .obj/release-shared/qmlpuppetmain.o .obj/release-shared/qrc_qmlpuppet.o .obj/release-shared/moc_nodeinstanceclientproxy.o .obj/release-shared/moc_qt4rendernodeinstanceserver.o .obj/release-shared/moc_qt4previewnodeinstanceserver.o .obj/release-shared/moc_dummycontextobject.o .obj/release-shared/moc_childrenchangeeventfilter.o .obj/release-shared/moc_nodeinstanceserver.o .obj/release-shared/moc_nodeinstanceserverinterface.o -L/tmp/makepkg/qtcreator-git/src/build/lib/qtcreator -lQt5Declarative -lQt5Widgets -lQt5Script -lQt5Network -lQt5Concurrent -lQt5Gui -lQt5Core -lGLESv2 -lpthread
make[4]: Leaving directory '/tmp/makepkg/qtcreator-git/src/build/src/tools/qmlpuppet/qmlpuppet'
make[3]: Leaving directory '/tmp/makepkg/qtcreator-git/src/build/src/tools/qmlpuppet'
make[2]: Leaving directory '/tmp/makepkg/qtcreator-git/src/build/src/tools'
Makefile:390: recipe for target 'sub-tools-make_first-ordered' failed
make[1]: *** [sub-tools-make_first-ordered] Error 2
make[1]: Leaving directory '/tmp/makepkg/qtcreator-git/src/build/src'
Makefile:40: recipe for target 'sub-src-make_first-ordered' failed
make: *** [sub-src-make_first-ordered] Error 2
==> ERROR: A failure occurred in build().
Aborting...
==> ERROR: Makepkg was unable to build qtcreator-git

hatred commented on 2013-09-29 09:13

@mloskot: short answer: look into PKGBUILD and study ArchLinux wiki regard VCS packages version autoupdate. This package build master branch. At the deployment moment actual version was 2.6.x.

Just build it and version will be autoupdated.

Anonymous comment on 2013-09-28 19:24

How come the official qtcreator package [1] is 2.8.1 but this qtcreator-git is 2.7.0?

[1] https://www.archlinux.org/packages/?q=qtcreator

plfiorini commented on 2013-03-25 09:18

@gtmanfred: qt-creator-for-qt5-git was made several months ago when Qt 5 wasn't even released and of course there was no official ArchLinux packages for it.

gtmanfred commented on 2013-03-25 04:04

please update this package or disown it, anything that touches $pkgdir should be in the package() function

also needs to be updated for qt5

gtmanfred commented on 2013-03-25 04:03

please don't just make another package because the other one needs updating,

this should be qt-creator-git ... which already exists, merging qtcreator-for-qt5-git to qtcreator-git

trusktr commented on 2013-03-24 21:20

It happened again with libQt5Network.so.5... Can you please fix this?

/opt/qt5/bin/xmlpatterns: error while loading shared libraries: libQt5Network.so.5: cannot open shared object file: No such file or directory

trusktr commented on 2013-03-24 20:25

I'm getting the following error while installing. As a workaround, I have to create a symbolic link in /usr/lib/ to the shared object:

/opt/qt5/bin/xmlpatterns: error while loading shared libraries: libQt5XmlPatterns.so.5: cannot open shared object file: No such file or directory
make[3]: *** [Core.json] Error 127
make[3]: Leaving directory `/home/pacman/cache/pkg/qtcreator-for-qt5-git-31238/qtcreator-for-qt5-git/src/build/src/plugins/coreplugin'
make[2]: *** [sub-coreplugin-make_first] Error 2
make[2]: Leaving directory `/home/pacman/cache/pkg/qtcreator-for-qt5-git-31238/qtcreator-for-qt5-git/src/build/src/plugins'
make[1]: *** [sub-plugins-make_first-ordered] Error 2
make[1]: Leaving directory `/home/pacman/cache/pkg/qtcreator-for-qt5-git-31238/qtcreator-for-qt5-git/src/build/src'
make: *** [sub-src-make_first-ordered] Error 2
==> ERROR: A failure occurred in build().
Aborting...
aura >>= Well, building `qtcreator-for-qt5-git` failed.
aura >>= Building failed.

trusktr commented on 2013-03-24 08:39

Why is the upstream url http://www.qtsoftware.com/products/developer-tools?

The upstream should be http://qt-project.org/wiki/Category:Tools::QtCreator, or at least qt-project.org.