Package Details: qtcreator-git v4.9.1.r864.g611e1ea837-1

Git Clone URL: https://aur.archlinux.org/qtcreator-git.git (read-only)
Package Base: qtcreator-git
Description: Lightweight, cross-platform integrated development environment
Upstream URL: https://www.qt.io
Licenses: LGPL
Conflicts: qbs, qtcreator
Provides: qbs, qtcreator
Submitter: delor
Maintainer: rodrigo21 (hunger)
Last Packager: rodrigo21
Votes: 31
Popularity: 0.127198
First Submitted: 2009-04-12 14:35
Last Updated: 2019-06-06 12:33

Dependencies (23)

Required by (32)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

hunger commented on 2016-02-07 19:43

rodrigo21: Sorry, I forgot to update the license field in the PKGBUILD. Do I need to increment the pkgrel for such a change or should I just push an update to the license field without bothering to do so?

Nothing should pick that up, should it? And even if: It is a git package, so it will get rebuild anyway.

Sorry, this is my first real AUR package;-)

hunger commented on 2016-02-07 17:44

Thanks, I'll push my change (the one in pastebin + an update of the version number) once my CI is done building the package.

rodrigo21 commented on 2016-02-07 17:29

Sure, I'll add you as co-maintainer.

hunger commented on 2016-02-07 17:25

I need to apply the following patch to make things work after the license information has changed upstream:

http://pastebin.com/GwUUrLR7

PS: Do you need help maintaining this? I'd love to help.

MightyPork commented on 2016-01-20 23:49

After over an hour of building, it failed with:

install: cannot stat ‘/tmp/yaourt-tmp-ondra/aur-qtcreator-git/src/qt-creator/LGPL_EXCEPTION.TXT’: No such file or directory

lovely package

romanp commented on 2015-06-03 09:26

Compiles and installs successfully but when running, gives lots of errors:
QXcbConnection: XCB error: 3 (BadWindow)
Can be this
https://bugreports.qt.io/browse/QTCREATORBUG-14427

I am using awesome wm and no dm

nick commented on 2015-04-23 00:18

Does this not work in kf5? builds fine, installs fine, no errors on startup but IDE never shows, and its running...

nick@localhost ~ % ps aux | grep qtcreator
nick 842 94.6 3.7 2277364 151168 ? Rl 01:13 2:06 /usr/bin/qtcreator
nick 863 0.0 0.0 0 0 ? Z 01:13 0:00 [qtcreator] <defunct>
nick 1109 0.0 0.0 10944 2264 pts/1 S+ 01:15 0:00 grep --color=auto qtcreator

journal is full of this too:
QXcbConnection: XCB error: 3 (BadWindow), sequence: 10185, resource id: 37763063, major code: 20 (GetProperty), minor code: 0

nick commented on 2015-04-23 00:16

Does this not work in kf5? builds fine, installs fine, no errors on startup but IDE never shows, and its running...

nick@localhost ~ % ps aux | grep qtcreator
nick 842 94.6 3.7 2277364 151168 ? Rl 01:13 2:06 /usr/bin/qtcreator
nick 863 0.0 0.0 0 0 ? Z 01:13 0:00 [qtcreator] <defunct>
nick 1109 0.0 0.0 10944 2264 pts/1 S+ 01:15 0:00 grep --color=auto qtcreator

rodrigo21 commented on 2015-03-09 15:28

Added CONFIG+=journald.

hunger commented on 2015-03-09 10:26

Could you please add CONFIG+=journald to the qmake call? That will enable code that allows Qt Creator to get debug messages from journald.

The Qt5 packaged by arch-linux does put all its debug messages into the journal, and without this option all those are invisible in Qt Creator (without QT_LOGGING_TO_CONSOLE=1 environment variable being set at least).

Note: journald support is only available in the 3.4 and master branches, so this does not yet apply to the official Qt Creator packages.