Package Details: qtcam-git r145.51ddb5d-1

Git Clone URL: https://aur.archlinux.org/qtcam-git.git (read-only, click to copy)
Package Base: qtcam-git
Description: A free, Open Source Linux Webcamera Software with more than 10 image control settings - alexzk1 fork
Upstream URL: http://www.e-consystems.com/opensource-linux-webcam-software-application.asp
Licenses: GPL
Submitter: dracorp
Maintainer: None
Last Packager: ImNtReal
Votes: 16
Popularity: 0.000403
First Submitted: 2015-09-27 21:28
Last Updated: 2020-05-13 16:19

Latest Comments

« First ‹ Previous 1 2 3

TruckerZer0 commented on 2016-01-21 13:00

Fails to compile:

==> Avvio di prepare() in corso...
patching file src/videoencoder.h
Hunk #1 FAILED at 30 (different line endings).
1 out of 1 hunk FAILED -- saving rejects to file src/videoencoder.h.rej

dracorp commented on 2015-11-08 22:12

@Pandor temporary fixed

Pandor commented on 2015-11-08 10:23

Fails to compile:

-> Starting make
g++ -c -pipe -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -Wall -W -D__STDC_CONSTANT_MACROS -fPIC -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_QUICK_LIB -DQT_GUI_LIB -DQT_QML_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -I. -Iqtquick2applicationviewer -Iv4l2headers/include -isystem /usr/include -isystem /usr/include/qt -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtQuick -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtQml -isystem /usr/include/qt/QtNetwork -isystem /usr/include/qt/QtCore -I. -I/usr/lib/qt/mkspecs/linux-g++ -o main.o main.cpp
In file included from videostreaming.h:41:0,
from cameraproperty.h:42,
from main.cpp:29:
videoencoder.h:60:38: error: ‘CodecID’ has not been declared
bool createFile(QString filename, CodecID encodeType, unsigned width,unsigned height,unsigned fpsDenominator, unsigned fpsNumerator, unsigned bitRate);
^
Makefile:851: recipe for target 'main.o' failed
make: *** [main.o] Error 1
==> ERROR: A failure occurred in build().
Aborting...


ffmpeg 1:2.8.1-3 provides libavcodec.so=56-64

apparently, post libavcodec 53.25.0 the enum CodecID was changed to AVCodecID causing compilation errors.

ffmpeg-compat package provides libavcodec.so=53-64 though but still doesn't compile.

Should be fixed upstream?
https://github.com/econsysqtcam/qtcam/commit/c8e3783c6aa9b043a65fbc6188d3177c102727bd



dracorp commented on 2015-10-04 14:01

@flu: pkgver is the result of command `git describe --always`.
Suggest a better solution.
https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver.28.29_function

flu commented on 2015-10-04 11:14

It seems that the last figure in pkgver (the nine) is bogus and yaourt asks me every time to upgrade even if there is no new version. Could you strip it?