Package Details: qt-sdk-raspberry-pi 5.13.0-4

Git Clone URL: https://aur.archlinux.org/qt-sdk-raspberry-pi.git (read-only)
Package Base: qt-sdk-raspberry-pi
Description: Qt SDK for the Raspberry Pi 1/2/3
Upstream URL: http://www.chaos-reins.com/qpi/
Licenses: GPL3, LGPL3
Provides: qt-sdk-raspberry-pi
Submitter: sirspudd
Maintainer: sirspudd
Last Packager: sirspudd
Votes: 1
Popularity: 0.043429
First Submitted: 2016-06-05 20:12
Last Updated: 2019-09-08 00:06

Latest Comments

zertyz commented on 2019-08-07 16:52

Hello, my friend. Thank you for your work. Do you plan to update your qpi repo? For Raspberry Pi 1, the version is at 5.9...

ggalt commented on 2019-01-17 03:48

One issue I had to correct in PKBUILD is that when building the qpi-toolchain for the Raspberry Pi 2, it gets installed in /opt/x-tools/armv7-rpi2-linux-gnueabihf. Line 120 of PKBUILD looks for it in: _toolchain="/opt/${_toolchain_name}/bin/${_toolchain_name}-". It should be _toolchain="/opt/x-tools/${_toolchain_name}/bin/${_toolchain_name}-"

ggalt commented on 2019-01-17 03:43

I get a warning of "Qt version is not properly installed, please run make install" on the "Qt Versions" tab of the Options dialog. There were no errors on the installation. I've checked and qmake and the other Qt binaries are located in /opt/qt/qt-sdk-raspberry-pi2/bin. Thoughts?

luntik2012 commented on 2018-11-20 13:07

==> Enter n° of packages to be installed (e.g., 1 2 3 or 1-3)
==> ----------------------------------------------------------
==> 4


==> Downloading qt-sdk-raspberry-pi PKGBUILD from AUR...
x .SRCINFO
x .gitignore
x PKGBUILD
x PKGBUILD.libs
x PKGBUILD.libs.debug
x _qpi.install
x python
x qpi-env-exec
x qpi-mesa.sh
x qpi-proprietary.sh
x qpi.install
x qpi.sh
nicholascw commented on 2017-12-28 17:16             

sirspudd commented on 2017-12-28 17:29           

sirspudd commented on 2017-12-28 17:36           

qt-sdk-raspberry-pi 5.12.0-4  (2018-11-20 08:57)
( Unsupported package: Potentially dangerous ! )
Unable to read PKGBUILD

sirspudd commented on 2017-12-28 17:36

@nicholascw

The recipe is well functional, and I have been keeping Qt functional on the pi since 5.6 or so; 5.10 is the first version which has not required patching

sirspudd commented on 2017-12-28 17:29

@nicholascw

This is because I have had to abuse PKGBUILD infrastructure in order to support cross compilation for the raspberry pi. I am also using the same recipe to generate static sdks for the 3 generations of pi (armv6,armv7,aarch64) and the Tinkerboard.

nicholascw commented on 2017-12-28 17:16

yaourt reporting pkgbuild unreadable