Package Details: qt-gtk-platform-plugin-git 20190427.da0e695-1

Git Clone URL: https://aur.archlinux.org/qt-gtk-platform-plugin-git.git (read-only)
Package Base: qt-gtk-platform-plugin-git
Description: GTK platform backend for Qt
Upstream URL: https://github.com/CrimsonAS/gtkplatform
Licenses: LGPL3
Conflicts: qt-gtk-platform-plugin
Provides: qt-gtk-platform-plugin
Submitter: sirspudd
Maintainer: sirspudd
Last Packager: sirspudd
Votes: 4
Popularity: 0.000018
First Submitted: 2017-09-25 20:43
Last Updated: 2019-06-28 07:56

Dependencies (0)

Required by (0)

Sources (1)

Latest Comments

sirspudd commented on 2017-09-28 20:25

@plfiorini: I adopted your proposed versioning scheme as is. It is a pity the tag can't also be encoded in the version scheme, since 4? 5? fields appears to make your aur clients version validation barf?

What I would like is:

$(tag).$(date).$(sha1)

so:

0.1.0.20170925.0b04afa

but this appears to be at odds with valid Arch pkg versioning

plfiorini commented on 2017-09-28 09:19

doesn't build with pacaur:

==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: 0.1.0-1-g8ef5b11

You can change pkgver to:

echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"

sirspudd commented on 2017-09-26 20:17

If you are a Qt Creator user, you can use:

https://aur.archlinux.org/packages/qtcreator-prerelease/

which is patched to actually respect the native system